Support --export-text-to-path when outputting plain SVG

Bug #903772 reported by Philipp Hagemeister on 2011-12-13
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Philipp Hagemeister

Bug Description

Currently, --export-text-to-path only works with PS/EPS/PDF output. It should work with plain SVG output as well, and that has been requested multiple times (http://stackoverflow.com/questions/8422558/converting-text-into-path-svg-on-server , http://stackoverflow.com/questions/8296964/is-there-a-php-library-for-drawing-text-as-a-vector-outline , http://stackoverflow.com/q/7742148/35070 ).

The attached patch implements this feature. The code should probably be moved from main.cpp, but I'm not familiar enough with inkscape to know where it would fit best.

su_v (suv-lp) wrote :

The same feature request had already been filed earlier:
Bug #517391 “Export-text-to-path doesn't wok with export-plain-svg (CLI)”
<https://bugs.launchpad.net/inkscape/+bug/517391>

@JazzyNico - which one to mark as duplicate, the older one or the one with a proposed patch?

tags: added: cli exporting
removed: feature
Changed in inkscape:
importance: Undecided → Wishlist
Philipp Hagemeister (phihag) wrote :

Sorry, I hadn't seen that feature request despite searching for it. My google-fu is apparently weak. Feel free to mark this one as a duplicate; it looks the patch doesn't work correctly on groups yet (Probably because the group's content needs to be relayouted as well).

jazzynico (jazzynico) wrote :

@~suv - I feel it's quite the same. But since I'm too lazy to copy the patch to the oldest report, I've marked it duplicate of the newest one ;)

Changed in inkscape:
assignee: nobody → Philipp Hagemeister (phihag)
status: New → In Progress
Philipp Hagemeister (phihag) wrote :

Updated the patch. This should now work with groups as well.

Philipp Hagemeister (phihag) wrote :

Corrected patch, should now work with all inputs.

Changed in inkscape:
assignee: Philipp Hagemeister (phihag) → nobody
Philipp Hagemeister (phihag) wrote :

Combined both patches for ease of applying.

jazzynico (jazzynico) wrote :

Patch tested successfully on CrunchBang 10 R20111125.
No regression found so far.

(note to self: don't forget to update the man page)

Changed in inkscape:
milestone: none → 0.49
John Smith (john-smithi) wrote :

Thanks Philipp your patch seems to work well.
Committed to trunk r11418 for wider testing.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) on 2012-06-28
Changed in inkscape:
assignee: nobody → Philipp Hagemeister (phihag)
xeo (thomas-pototschnig) wrote :

Why isn't this patch included in 0.48.4?

Were there any problems which prevented the patch from being integrated in the mainline permanently?

jazzynico (jazzynico) wrote :

@xeo - The 0.48.x branch accepts bugfixes only, and not new features or changes that require new translations.
Here we have a new feature and changes in the man pages. That's the reason why we didn't include it in 0.48.4.

su_v (suv-lp) wrote :

Follow-up reports:
Bug #1262782 “inkscape --export-text-to-path - linebreak-bug with flowed text”
Bug #1262792 “inkscape --export-text-to-path --export-plain-svg - position bug”

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers