Some layers should be visible by default in Layers dialog

Bug #902054 reported by John Smith on 2011-12-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
John Smith
inkscape (Ubuntu)
Low
Unassigned

Bug Description

When the layers dialog is first opened the list of layers is hidden, user needs to resize the dialog to see the layers.
Some (maybe 2 or 3) layers should be visible by default.

Related branches

John Smith (john-smithi) on 2011-12-09
tags: added: layers ui
su_v (suv-lp) wrote :

> Some (maybe 2 or 3) layers should be visible by default.

They are usually, if you use a Gtk+ theme with "normal" scroll bar widgets. In my tests, the minimal initial height of the list of layers is determined by the minimal size of the Gtk+ widget (arrows + minimal length of scroll bar slider).
Are you possibly using Inkscape on Ubuntu with the custom scroll bar overlay? (please add information about OS/platform and Inkscape version when filing reports).

Based on my earlier tests, this could be the same issue as
Bug #884368 in Inkscape: “unable to edit attributes in XML Editor”
<https://bugs.launchpad.net/inkscape/+bug/884368>

su_v (suv-lp) wrote :

The general issue that Inkscape does not remember across sessions or set individual default minimal heights for various docked dialogs with (vertically) scalable elements is tracked in:
Bug #597573 “Default height of docked layer window constant instead of dependent on number of layers”
<https://bugs.launchpad.net/inkscape/+bug/597573>

su_v (suv-lp) wrote :

Attaching screenshots demonstrating minimal height of layer list depending on Gtk+ theme settings (for scroll bars):
1) Default Ambiance theme (from Ubuntu's 'light-themes'), no scrollbar-overlay on OS X
   Tweaked Ambiance theme mimicking a minimalistic scroll bar
2) Default Clearlooks theme (same file with 5 layers)

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

Information about the reporter's OS/platform and Gtk+ desktop theme needed.

Changed in inkscape:
status: New → Incomplete
John Smith (john-smithi) wrote :

Ubuntu 11.10 / Unity / Gnome 3.2.1 (current "updated" versions) with untweaked themes.
Both Ambience and Radiance have the same issue.

su_v (suv-lp) wrote :

Based on your screenshot this is the same issue with Ubuntu's custom scrollbar-overlays as reported in Bug #884368.
(Some of Inkscape's GUI elements - which do not use fixed (hard-coded) minimal (px) sizes - seem to get initialized too small if those custom scrollbars are used instead of the default Gtk+ scrollbar: affects also the XML editor, the list of font styles in the 'Text and Fonts…' and the 'Glyphs' dialog, etc.)

Proposing to link as duplicate to bug #884368.

(Whether Inkscape adds support to save the status (and size) of docked dialogs across sessions, and/or parses the list of current layers when opening the layers dialog for the first time in the current session to determine a reasonable minimal height based on the initial number of layers visible in the list - these are different issues already tracked in other reports: bug #171579, bug #597573).

Changed in inkscape:
status: Incomplete → New
John Smith (john-smithi) wrote :

Yes agreed, this is a Ubuntu specific issue,
since Ubuntu is using a custom overlay scrollbar as default since 11.04/11.10.
Should this (and #884368) be marked as a Ubuntu only bug ?

su_v (suv-lp) wrote :

If you look at the list of affected projects and distributions of bug #884368, it has been confirmed for 'Inkscape (Ubuntu)' already, and (auto-)confirmed for the (affected) project 'ayatana-scrollbar'. We tend to leave the original report open in Inkscape's bug tracker for a while so that Ubuntu users filing new reports for Inkscape here can detect the earlier report (else it would be hidden by normal searches).

AFAIU the underlying issue here is the same as in bug #884368 (-> duplicate).

John Smith (john-smithi) wrote :

Perfect ... Thanks suv !
I've submitted a patch for 171579 and will do 597573 too.

John Smith (john-smithi) wrote :

Patch to make the layers dialog with no scrollbars (such as Ubuntu 11.04+/liboverlay-scrollbar) behave the same as other platforms.
Platforms with normal scrollbars should not be affected by this patch.

Tested in Ubuntu 11.10 and Windows 7.

John Smith (john-smithi) wrote :

Screenshot comparision of patch with/without scrollbars

The attachment "902054.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
tags: added: patch-forwarded-upstream
removed: patch
John Smith (john-smithi) on 2011-12-31
Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
jazzynico (jazzynico) on 2012-01-02
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.48.3
status: New → In Progress
jazzynico (jazzynico) wrote :

Fix committed in the branch (revision 9846) and in the trunk (revision 10819).

Changed in inkscape:
status: In Progress → Fix Committed
Changed in inkscape (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.3-0ubuntu1

---------------
inkscape (0.48.3-0ubuntu1) precise; urgency=low

  * New upstream release (LP: #933188). Fixes several Ubuntu bugs:
    - inkscape fails to build with glib 2.31 (LP: #898538)
    - ctrl c ctrl v of text in edit mode crashes inkscape (LP: #496793)
    - Completely replace lcms1 by lcms2 in Ubuntu (LP: #885324)
    - parameters ending with '\' causes python to bomb (LP: #168417)
    - Extensions with <check> tags fail to load (LP: #668895)
    - ESC doesn't cancel move when using the Node Tool (LP: #788560)
    - unable to edit attributes in Inkscape XML Editor (LP: #884368)
    - Some layers should be visible by default in Layers dialog (LP: #902054)
    - Path Effect List is hidden (LP: #909958)
    - Input Devices > Hardware > Tree of devices is hidden (LP: #910467)
    - Glyphs Font styles are hidden (LP: #911079)
    - Error messages from Extensions hidden (LP: #911079)
    - Messages dialog doesn't work (LP: #911123)
  * Drop 02-add-shebangs-and-fix-permissions.dpatch: Applied upstream.
  * Drop build-dependency on specific libwpd/libwpg version.
 -- Alex Valavanis <email address hidden> Thu, 16 Feb 2012 14:33:40 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers