Trace Bitmap Color render inverted

Bug #815596 reported by Kattekrab on 2011-07-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jon A. Cruz

Bug Description

Trace Bitmap is returning inverted colors. The R & B in RGB is round the wrong way.

There is also
#580079 Trace bitmap is not getting proper colors (regression)

Cafuego (cafuego) wrote :

Attached patch reverses the B and R values that are output to XML, so should resolve this bug.

su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.1 and 0.48+devel r10325
Reproduced with r9598 of the cairo-rendering branch, 0.48+devel r10330, and latest trunk (r10501) on Mac OS X 10.5.8

(bug #580079 is not related)

tags: added: regression renderer-cairo tracing
su_v (suv-lp) on 2011-07-24
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Cafuego (cafuego) wrote :

The patch from #2 does indeed fix the problem, the produced objects have the correct colours. However, the potrace preview window still shows the incorrect colours, with R and B values reversed.

Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
Jon A. Cruz (jon-joncruz) wrote :

Looks like I'll need to take the fix a step ealier... but it is in this general area.

Jon A. Cruz (jon-joncruz) wrote :

Fix committed in revision #10508.

Changed in inkscape:
status: Confirmed → In Progress
Changed in inkscape:
milestone: none → 0.49
Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

Changing status to 'Fix Released' in accordance to [1] - the reported issue never occurred in a released version, only in current trunk. Please revert the bug status to 'Fix Committed' if you don't agree (or reopen a discussion about this aspect of bug management in the wiki/mailing list).

[1] <http://wiki.inkscape.org/wiki/index.php/Bug_management>

Changed in inkscape:
milestone: 0.49 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers