Not possible to leave full screen mode

Bug #777567 reported by David Bolton on 2011-05-05
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

Steps to reproduce:
1. View > Fullscreen to start fullscreen mode
2. View > Fullscreen to exit fullscreen mode

Expected behavior: window show return to normal after step two

Actual behavior: window stays in full screen mode. The only change is the scroll bars disappear

Workaround: Quit Inkscape and reopen your Inkscape file.

(Inkscape .48-1, Windows 7)

su_v (suv-lp) on 2011-05-05
tags: added: ui win32
Pablo Trabajos (pajarico) wrote :

Can't confirm in 10141 nor 10194 on Win 7. I don't have 0.48-1 installed so I cannot say if it was present then or not.

Version 0.48.1 has been released: http://inkscape.org/download/?lang=en
(I don't know if it will solve your problem, though)

If that doesn't work, could you try a development snapshot (download the most recent one)? http://inkscape.modevia.com/win32/?C=M;O=D

David Bolton (davidkbolton) wrote :

I wasn't able to reproduce the exact original problem in r10194 on Win 7, but I got plenty of weird behavior as described below. Should I file a separate report?

From a newly opened instance of r. 10194:

1. Click Maximize

2. F11 to switch into full screen mode (notice that the screen flickers but Inkscape doesn't actually switch to full screen yet)

3. Ctl+Shift+F to open File and Stroke properties (notice that the screen flickers again, but still not in full screen mode)

4. Draw an object, such as a rectangle, on the canvas

5. Ctl+Shift+A to open Align and Distribute properties (notice that Inkscape is finally in Full screen mode)

6. F11 to leave full screen mode (notice that the horizontal scroll bar is missing).

David Bolton (davidkbolton) wrote :

Okay I found the steps to reproduce the original bug consistently (tested using r. 10194 on Win 7):

1. Maximize
2. F11
3. Ctrl+Shift+F
4. Ctrl+Shift+A
5. Close and Reopen Align and Distribute
6. Click on a couple buttons in Align and Distribute
7. F11

After step 7 Inkscape stays in Full Screen mode instead of going back to a normal window.

ScislaC (scislac) wrote :

After those steps, if you click back out of the docked dialog on the canvas, will it work then?

David Bolton (davidkbolton) wrote :

If I click on the canvas after step 7 and press F11 again, Inkscape stays in Full Screen mode. The only thing that changes is the scroll bars disappear and reappear each time I press F11.

Do you get different behavior ScislaC?

su_v (suv-lp) wrote :

Possibly related:
Bug #590719 “window resizes when toolbar/popup is opened”

(also triggered when opening a (docked) dialog if maximized using the "windows 7's areo-snap features" - how do you 'maximize' the Window?)

David Bolton (davidkbolton) wrote :

I maximized using the middle button on the top right-hand corner of the window

ScislaC (scislac) wrote :

I fired up WIn7 and can reproduce. Used 0.48.1. Observation, on step 3, the titlebar pops back up... and step 4 it returns to fullscreen. I think it gets confused about window state when the first docked dialog is opened.

Changed in inkscape:
status: New → Confirmed
importance: Undecided → Low
Pablo Trabajos (pajarico) wrote :

Confirmed in r10194+Win 7 too following steps described in comment #3.

Changed in inkscape:
assignee: nobody → akshara proddatoori (akshara-proddaturi)
assignee: akshara proddatoori (akshara-proddaturi) → nobody
Dale Walton (dale-walton) wrote :

I did something that triggered this bug - that is horizontal and vertical scroll bars for the drawing window are missing.
The color selection scroll bar and function scroll bars are still there. - See the attached picture of the screen taken after closing and reopening the application.

I think I was using an alt-D when it happened, but may have hit other keys or a mouse button instead or simultaneously....

In addition cloning stopped functioning, and instead it selected a text item and highlighted it with a red outline...? Sorry I did not print the screen.

However the workaround doesn't work: closing Inkscape and re-opening it does not solve the problem of the scroll bars.

I am using 0.91 on 64 bit Windows 7

Dale Walton (dale-walton) wrote :

RE my comment 10 hrs ago:

There seem to be two independent problems: One involved the spell checker which I found invoked in the function window minimized. So when I was working on the drawing and tried to clone with alt D the program instead highlighted the first text in the file and wrote dictionary files to the same directory as my drawing file.

The second has to do with full screen mode. - When I toggle to full screen mode (View/fullscreen), the bars are there, but there is no button to exit the program. When I toggle off the bars are missing as in my jpg (window maximized or not). Restarting the program after exiting from either mode still leaves the problem.

Work arounds are
1) use it without scroll bars (mouse key works for vertical scrolling, but how do I scroll horizontally?
2) use it in full screen mode only.

Or maybe reinstall?

David Bolton (davidkbolton) wrote :

Dale: Please confirm whether you have scrollbars turned on. From the main menu go to View > Show/Hide > Scrollbars (it should have a checkmark next to it). You may have to do this twice: once in normal window mode and full screen mode (I had to).

When I'm working with text it is easy for me to press Ctrl+B in the wrong context. In text editing mode Ctrl+B makes the text bold. Unfortunately, outside of text editing mode Ctrl+B toggles scrollbars on and off.

Samuel (squamulus) wrote :

Heyo!

Ran into this one today. I've made a ton of art using inkscape over the last few years and have had this come up a few times. Usually I just carry on and, at some indiscriminant point in the future, inkscape returns to working form. I figured out how to fix it on purpose today.

**Here's the trick if this happens to you:**
Just open the file you want to open by double-clicking it wherever it's located. Voila, you're out of fullscreen.

If you try to boot-up inkscape itself by opening the program, you'll still be trapped.

I have no idea why this happens nor why it works, but I ran into an issue with some similar behavior a few months ago and for some reason made the connection. I tried it out today when thinking through the problem and it worked, so I hope it works for everyone else forever!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers