when printing or exporting file inkscape crashes

Bug #724221 reported by ame on 2011-02-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Message: "Microsoft Visual C++ Runtime Library" "This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information." and "Inkscape ist auf einen internen Fehler gestossen und wird nun geschlossen."

Additonal: When changing views to "Page" per menu or pressing number 5 the whole page is filled with grey color.

Version 0.48.0-1

ame (anette-metzger) wrote :

Reinstaled inksape and restarted computer but this didn't help

su_v (suv-lp) wrote :

> (…) or exporting file inkscape crashes

Does Inkscape crash when saving (a copy) in a different format (if so, limited to certain formats, or all),
or only when using 'File > Export Bitmap…'?

tags: added: crash printing win32
summary: - when printing or exporing file inkscape crashes
+ when printing or exporting file inkscape crashes
su_v (suv-lp) wrote :

> when printing (…) inkscape crashes

Do you use an Epson printer? Possibly same as
Bug #212921 “[Win32] Crashes, system freezes when trying to print on some Epson printers”
<https://bugs.launchpad.net/inkscape/+bug/212921>

Changed in inkscape:
importance: Undecided → High
status: New → Incomplete

It crashes when I click on "Export" - the Export-Window doesn't pop up

Am 24.02.2011, 11:25 Uhr, schrieb ~suv <email address hidden>:

>> (…) or exporting file inkscape crashes
>
> Does Inkscape crash when saving (a copy) in a different format (if so,
> limited to certain formats, or all),
> or only when using 'File > Export Bitmap…'?
>
> ** Tags added: crash printing win32
>
> ** Summary changed:
>
> - when printing or exporing file inkscape crashes
> + when printing or exporting file inkscape crashes

No, I'm using a Brother, but it also occured when trying pdf-creator. I
use Inkscape now for some years and a lot with these two printers and
everything was fine.
Yesterday it seemed that there was something not ok when I tried to reduce
the outline-strenght of a path. Suddenly strange grey forms were drawn in
the graphic. First I thought I misstyped the size. But from then it didn't
worked well.
I'm using now inkscape portable and it is no problem to print.

Am 24.02.2011, 11:27 Uhr, schrieb ~suv <email address hidden>:

>> when printing (…) inkscape crashes
>
> Do you use an Epson printer? Possibly same as
> Bug #212921 “[Win32] Crashes, system freezes when trying to print on
> some Epson printers”
> <https://bugs.launchpad.net/inkscape/+bug/212921>
>
> ** Changed in: inkscape
> Importance: Undecided => High
>
> ** Changed in: inkscape
> Status: New => Incomplete

su_v (suv-lp) wrote :

> It crashes when I click on "Export"

Still unclear to me - 'Export' as in menu 'Datei > Bitmap exportieren… Shift+Ctrl+E' (same as the 6th button on the commands bar)? Or do you open the 'Save as…' file dialog (menu 'Datei > Speichern unter…')?

> (…) Suddenly strange grey forms were drawn (…)

Does this happen with a certain document only, or with new files as well?

> I'm using now inkscape portable and it is no problem to print.

Can you try to reset the preferences for the installed version and test if using Inkscape with default settings works again? The preferences file 'preferences.xml' is located in "%APPDATA%\Inkscape" (you can enter the string as is into the address bar of the Explorer). Please close all Inkscape instances, rename or move the current preferences file and restart Inkscape (the installed version). If that works ok, could you attach the "broken" preferences file to your bug report?

ame (anette-metzger) wrote :

Hello,

it happend with one file and as you described it "'Export' as in menu 'Datei
> Bitmap exportieren…
 Shift+Ctrl+E' (same as the 6th button on the commands bar)"

now you got me! It doesn't happen with new files. It is this one file that
seems to remember the bug (attached it). Other existing & new ones are fine

su_v (suv-lp) wrote :

> one file that seems to remember the bug (attached it)

Apparently the attachment didn't make it - could you try again to attach it, using the web interface?

ame (anette-metzger) wrote :

Ok, here it is. Thank you!

su_v (suv-lp) wrote :

It contains an actually small polygon in the upper right corner of the drawing, with a stroke width of '1208646870.49529' (which by far exceeds the dimension of the object itself - on top of that it has a blur of 3.3%), as well as similarly huge values for the dash style:

    <path
       transform="matrix(-0.22431686,-0.37254229,0.22476423,-0.13731004,1057.6332,904.43963)"
       style="fill:#800000;fill-opacity:1;stroke:#828282;stroke-width:1208646870.49529;stroke-miterlimit:4;stroke-dasharray:2417293740.9905801,1208646870.49529;stroke-dashoffset:0;filter:url(#filter4761);stroke-opacity:1"
       d="m 962.2179,264.86243 c 25.2541,4.37234 46.2869,5.27151 66.8978,5.82366 l 4.4239,15.44773 c -16.3387,2.2245 -29.9459,5.26625 -71.3217,0 z"
       id="rect4530-1"
       inkscape:connector-curvature="0"
       sodipodi:nodetypes="ccccc" />

These style attributes seem to cause the (bbox) dimensions of the object to be so huge that they exceed Inkscape's capability to handle the size of the drawing content (when zooming to content or selection, or when exporting 'Drawing' to bitmap. Inkscape 0.48.0 and 0.48+devel r10067 on Mac OS X 10.5.8 (i386) also crashes when trying to node-edit that path:

Console messages:

inkscape(52716,0xa07b2720) malloc: *** mmap(size=4212862976) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug

GLib-ERROR **: gmem.c:170: failed to allocate 4212860484 bytes
aborting...

tags: removed: printing win32
Changed in inkscape:
status: Incomplete → Confirmed
su_v (suv-lp) wrote :

And a second path has the same attributes: id="rect4530". The corrupt path must have been copied&pasted as well as rotated to draw a new red 'X' in the drawing.

Please try the attached version of the file whether you now can continue to work on it without Inkscape crashing when printing or exporting to bitmap.

Do you remember what went wrong when you tried to adjust the stroke width (and possibly the dash style) in the 'Fill & Stroke…' dialog?

ame (anette-metzger) wrote :

Thank you very much for finding the "bug"! Your service has been help- and
wonderful.

Have a good time!

Best regards
Anette

On Thu, Feb 24, 2011 at 6:52 PM, ~suv <email address hidden> wrote:

> It contains an actually small polygon in the upper right corner of the
> drawing, with a stroke width of '1208646870.49529' (which by far exceeds
> the dimension of the object itself - on top of that it has a blur of
> 3.3%), as well as similarly huge values for the dash style:
>
> <path
>
> transform="matrix(-0.22431686,-0.37254229,0.22476423,-0.13731004,1057.6332,904.43963)"
>
> style="fill:#800000;fill-opacity:1;stroke:#828282;stroke-width:1208646870.49529;stroke-miterlimit:4;stroke-dasharray:2417293740.9905801,1208646870.49529;stroke-dashoffset:0;filter:url(#filter4761);stroke-opacity:1"
> d="m 962.2179,264.86243 c 25.2541,4.37234 46.2869,5.27151
> 66.8978,5.82366 l 4.4239,15.44773 c -16.3387,2.2245 -29.9459,5.26625
> -71.3217,0 z"
> id="rect4530-1"
> inkscape:connector-curvature="0"
> sodipodi:nodetypes="ccccc" />
>
> These style attributes seem to cause the (bbox) dimensions of the object
> to be so huge that they exceed Inkscape's capability to handle the size
> of the drawing content (when zooming to content or selection, or when
> exporting 'Drawing' to bitmap. Inkscape 0.48.0 and 0.48+devel r10067 on
> Mac OS X 10.5.8 (i386) also crashes when trying to node-edit that path:
>
> Console messages:
>
> inkscape(52716,0xa07b2720) malloc: *** mmap(size=4212862976) failed (error
> code=12)
> *** error: can't allocate region
> *** set a breakpoint in malloc_error_break to debug
>
> GLib-ERROR **: gmem.c:170: failed to allocate 4212860484 bytes
> aborting...
>
> ** Attachment added: "backtrace from crash when trying to node-edit path
> "rect4530-1""
>
> https://bugs.launchpad.net/inkscape/+bug/724221/+attachment/1869291/+files/724221-gdb.log.txt
>
> ** Tags removed: printing win32
>
> ** Changed in: inkscape
> Status: Incomplete => Confirmed
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/724221
>
> Title:
> when printing or exporting file inkscape crashes
>
> Status in Inkscape: A Vector Drawing Tool:
> Confirmed
>
> Bug description:
> Message: "Microsoft Visual C++ Runtime Library" "This application has
> requested the Runtime to terminate it in an unusual way. Please
> contact the application's support team for more information." and
> "Inkscape ist auf einen internen Fehler gestossen und wird nun
> geschlossen."
>
> Additonal: When changing views to "Page" per menu or pressing number 5
> the whole page is filled with grey color.
>
> Version 0.48.0-1
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/inkscape/+bug/724221/+subscribe
>

ame (anette-metzger) wrote :

I'm sorry, I can not open the file. I get the message "Öffnen ... ist
fehlgeschlagen."

But it is ok. I can work with it in the portable version.

On Thu, Feb 24, 2011 at 7:00 PM, ~suv <email address hidden> wrote:

> And a second path has the same attributes: id="rect4530". The corrupt
> path must have been copied&pasted as well as rotated to draw a new red
> 'X' in the drawing.
>
> Please try the attached version of the file whether you now can continue
> to work on it without Inkscape crashing when printing or exporting to
> bitmap.
>
> Do you remember what went wrong when you tried to adjust the stroke
> width (and possibly the dash style) in the 'Fill & Stroke…' dialog?
>
> ** Attachment added: "724221-Opening Treasure s-fixed.svg"
>
> https://bugs.launchpad.net/inkscape/+bug/724221/+attachment/1869304/+files/724221-Opening%20Treasure%20s-fixed.svg
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/724221
>
> Title:
> when printing or exporting file inkscape crashes
>
> Status in Inkscape: A Vector Drawing Tool:
> Confirmed
>
> Bug description:
> Message: "Microsoft Visual C++ Runtime Library" "This application has
> requested the Runtime to terminate it in an unusual way. Please
> contact the application's support team for more information." and
> "Inkscape ist auf einen internen Fehler gestossen und wird nun
> geschlossen."
>
> Additonal: When changing views to "Page" per menu or pressing number 5
> the whole page is filled with grey color.
>
> Version 0.48.0-1
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/inkscape/+bug/724221/+subscribe
>

su_v (suv-lp) wrote :

It opens fine for me in Inkscape 0.48.0 - how did you save the file from the browser? Try with the file attached as ZIP archive…

su_v (suv-lp) wrote :

> But it is ok. I can work with it in the portable version.

Did you try to reset the preferences for the installed Inkscape version, as described earlier?
<https://bugs.launchpad.net/inkscape/+bug/724221/comments/6>

ame (anette-metzger) wrote :

Perfect! It worked. Thank you very much!

Kind regards
Anette

On Thu, Feb 24, 2011 at 7:45 PM, ~suv <email address hidden> wrote:

> > But it is ok. I can work with it in the portable version.
>
> Did you try to reset the preferences for the installed Inkscape version, as
> described earlier?
> <https://bugs.launchpad.net/inkscape/+bug/724221/comments/6>
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/724221
>
> Title:
> when printing or exporting file inkscape crashes
>
> Status in Inkscape: A Vector Drawing Tool:
> Confirmed
>
> Bug description:
> Message: "Microsoft Visual C++ Runtime Library" "This application has
> requested the Runtime to terminate it in an unusual way. Please
> contact the application's support team for more information." and
> "Inkscape ist auf einen internen Fehler gestossen und wird nun
> geschlossen."
>
> Additonal: When changing views to "Page" per menu or pressing number 5
> the whole page is filled with grey color.
>
> Version 0.48.0-1
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/inkscape/+bug/724221/+subscribe
>

Martin Owens (doctormo) wrote :

Current trunk version of inkscape is protecting the attached SVG correctly, allowing export and print (al-be-it, with giant default proportions)

Changed in inkscape:
status: Confirmed → Fix Released
jazzynico (jazzynico) on 2013-07-01
Changed in inkscape:
milestone: none → 0.49
status: Fix Released → Fix Committed
Paul A. Bristow (pbristow) wrote :

I have a file that Inkscape 0.48 refused to Export to Bitmap.

Says 0.48 on the graphic, but is 0.91pre2 r 13516 and Export to PNG works OK.

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers