newly-added gradient node not active

Bug #627728 reported by John on 2010-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
John Smith

Bug Description

When I add gradient nodes while working with the Node tool, the newly-added node is not the active one. Changing colors or alpha will instead affect the FIRST node in the gradient.

If I adjust the position of a node I've just been working on, then change color values, the first node is the one to see the change.

This behavior is not consistent with that of graphics applications in general, wherein the most recent node or object created or selected is the active one.

OS: Mac OS X 10.6.3v11; Version of Inkscape: 0.48 running in X-11 (XQuarts 2.3.5)

thank you!

John (john-coffeeonmars) wrote :

Added by the OP:

Also, the selected nodes don't change color, or at least do so temporarily...most of the time, nodes are white whether I've succeeded in making them active or not. I have to rely on the Gradient Editor "flickering" once to indicate whether I've selected one node from another.

su_v (suv-lp) on 2010-09-01
tags: added: gradient
su_v (suv-lp) wrote :

In parts reproduced with Inkscape 0.47 and 0.48+devel r9736 on OS X 10.5.8

> When I add gradient nodes while working with the Node tool,
> the newly-added node is not the active one. Changing colors
> or alpha will instead affect the FIRST node in the gradient.

a) Gradient Editor (deprecated): reproduced when adding a gradient stop in the gradient editor dialog (independent of tool context)
b) Gradient Tool: not reproduced when using the newer gradient tool (keyboard shortcut 'g') to edit the gradient on canvas.

> If I adjust the position of a node I've just been working on,
> then change color values, the first node is the one to see
> the change.

Unclear - adjusting a node of the path or a stop of the gradient?

Not reproduced:
a) Gradient Editor (deprecated): changing the position of a gradient stop in the gradient editor dialog keeps that stop active and affected when changing the stop color using the color sliders in the same dialog.
b) Gradient Tool: changing the color of a selected gradient stop on-canvas always works as expected, independent from having dragged its position or not.

> Also, the selected nodes don't change color, or at least do so
> temporarily...most of the time, nodes are white whether I've succeeded
> in making them active or not. I have to rely on the Gradient Editor
> "flickering" once to indicate whether I've selected one node from
> another.

Unclear - selecting a gradient stop in the (deprecated) Gradient Editor is not reflected by the selection of the corresponding gradient stop on-canvas and vice-versa?

su_v (suv-lp) wrote :

> newly-added gradient node not active

Reproduced with Inkscape 0.47 and 0.48 in the Gradient Editor dialog: adding a gradient stop does not activate the new stop.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
John (john-coffeeonmars) wrote :

Clarification by the OP

I mean that when I am using the node tool to select and move the gradient stops, that this is what I'm having trouble with...as opposed to some trouble using the node tool to adjust object nodes.

The two methods I know of for editing a gradient are a Gradient Editor palette, and the more "live" tool you get when you have an selected object containing a gradient, and you choose the node edit tool

You then see a line with a square at the left, and a circle at the right. Any additional gradient stops in between are indicated by diamonds.

I hope this clarifies; I apologize for any ambiguity. Thank you for giving attention to this issue.

John

su_v (suv-lp) wrote :

Correction:
> newly-added gradient node not active

- Reproduced with Inkscape 0.47 and 0.48 in the Gradient Editor dialog: adding a gradient stop does not activate the new stop.
+ Reproduced with Inkscape 0.47 and 0.48 in the Gradient Editor dialog and using the Gradient tool for on-canvas editing: adding a gradient stop does not activate the new stop; to change the color of the newly inserted stop it has to be selected explicitly.

Thanks to prkos for pointing this out here:
<http://www.inkscapeforum.com/viewtopic.php?f=28&t=5881&p=25098#p25097>

su_v (suv-lp) wrote :

John wrote
> The two methods I know of for editing a gradient are a Gradient Editor
> palette, and the more "live" tool you get when you have an selected
> object containing a gradient, and you choose the node edit tool

The recommended tool to edit gradient stops is the Gradient tool, invoked e.g. with the keyboard shortcut 'g'.
<http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Attributes-Fill-Stroke.html#Attributes-Gradients-Define-Onscreen>
Also described in detail in the Release notes for Inkscape 0.46:
<http://wiki.inkscape.org/wiki/index.php/Release_notes/0.46#Gradient_Tool>

The Gradient Editor (floating dialog) is considered depreciated and to be fully replaced with the Gradient tool once all features are accessible on the gradient tool controls bar:
> selecting a gradient stop in the (deprecated) Gradient
> Editor is not reflected by the selection of the corresponding
> gradient stop on- canvas and vice-versa?

See bug #166524, bug #243396 and bug #243409 ("Won't fix").

su_v (suv-lp) wrote :

Issue as originally reported:
> newly-added gradient node not active

Related to or duplicate of bug #179830 “on-canvas gradient editor focus problems”?
<https://bugs.launchpad.net/inkscape/+bug/179830>

John Smith (john-smithi) wrote :

Partial fix committed to trunk as r11135.

When using the Gradient tool, pressing 'Insert' key or clicking 'Insert new stop' from the Gradient tool toolbar, the newly inserted stop(s) should be active.

Does not fix the problem when double clicking a gradient to insert a new stop.

John Smith (john-smithi) wrote :

r11137 should fix the problem when double clicking to add a new stop as well.
Is there are any other cases not working, please reopen this report.

Tested on Ubuntu 11.10 and Windows 7.

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
status: Confirmed → Fix Committed
su_v (suv-lp) on 2012-04-01
Changed in inkscape:
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers