[Node tool] panning with space+LMB fails

Bug #623660 reported by John on 2010-08-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
John Smith

Bug Description

I have my prefs set such that Space + LMB will pan the screen.

I am discovering that I must have the Select and Transform Objects tool active for this to work. If I am using, for example, the Edit paths by nodes tool, pressing Space + LMB will not let me pan the screen.

Inkscape version: the just-released 0.48 (using within X11; XQuartz 2.5.3)
OS: Mac OS X 10.6.3v1.1
Machine: 8-core Mac Pro "nehalem" with 6gb RAM

John

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48 and 0.48+devel r9723 on OS X 10.5.8

Not reproduced with Inkscape 0.47 -> regression with the new node tool (works with other tools in all versions).

tags: added: node-editing regression shortcuts
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
John (john-coffeeonmars) wrote :

EDIT: comment added by OP:

this occurs *only* when the Edit paths by nodes tool is selected. All other tools' being active does not impede the Space + LMB screen panning.

John

su_v (suv-lp) on 2010-08-24
summary: - Improper space+LMB behavior
+ [Node tool] panning with space+LMB fails
su_v (suv-lp) wrote :

related report (deselection of nodes/path still happens in 0.48):

Bug #341866 “path deselects by using mouse+space”:
<https://bugs.launchpad.net/inkscape/+bug/341866>

ScislaC (scislac) on 2011-11-09
Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
milestone: none → 0.48.3
John Smith (john-smithi) wrote :

Patch to enable panning (Space + LMB) for the Node tool.

Tested on Ubuntu 11.10 and Windows 7.

su_v (suv-lp) wrote :

Patch tested with r10919 and fix confirmed on
- OS X Lion (64bit), GTK+/X11 2.24.8, Glib 2.30.2
- Mac OS X Leopard (32bit), GTK+/Quartz 2.24.8, GLib 2.28.8

<off-topic>
On 32bit Leopard, using Inkscape r10919 with the Quartz backend of GTK+, screen-update of formerly off-screen regions when panning (as opposed to scrolling) is often bad with lots of artifacts, independent of the tool context and keyboard shortcut used (LBM + space bar, or Shift + RMB).
</off-topic>

su_v (suv-lp) on 2012-01-23
tags: added: backport-proposed

darn nice of you to continue following up on these bugs, ~suv and colleagues.

I appreciate knowing about the tracking, as Inkscape continues to be and WILL continue to be in my toolkit.

John

On Jan 23, 2012, at 2:50 AM, ~suv wrote:

> ** Tags added: backport-proposed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/623660
>
> Title:
> [Node tool] panning with space+LMB fails
>
> Status in Inkscape: A Vector Drawing Tool:
> Confirmed
>
> Bug description:
> I have my prefs set such that Space + LMB will pan the screen.
>
> I am discovering that I must have the Select and Transform Objects
> tool active for this to work. If I am using, for example, the Edit
> paths by nodes tool, pressing Space + LMB will not let me pan the
> screen.
>
> Inkscape version: the just-released 0.48 (using within X11; XQuartz 2.5.3)
> OS: Mac OS X 10.6.3v1.1
> Machine: 8-core Mac Pro "nehalem" with 6gb RAM
>
>
> John
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/623660/+subscriptions

ScislaC (scislac) on 2012-01-23
Changed in inkscape:
assignee: Krzysztof Kosinski (tweenk) → John Smith (john-smithi)
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

 trunk: rev 10921
0.48.x: rev 9855

tags: removed: backport-proposed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers