crash when changing node type

Bug #605575 reported by Matty on 2010-07-14
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski

Bug Description

system info [ windows 7 professional intel i7 (6core) nvidia quadro (graphics card) asus motherboard 24gb ram ]

build [Inkscape 0.48pre1 r9509]

ok so when i try to edit a path if i change the node type to many times it crashes and displays

[Inkscape encountered an internal error and will close now.
Automatic backups of unsaved documents were done to the following locations:
        C:\Users\matty\New document 1.2010_07_14_15_38_21.0.svg]

edit a point on the line in the file than change it's node type about six times randomly it should happen

Matty (matthew-tikiman) wrote :
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48pre1, 0.48.x (r9612) on OS X 10.5.8

Possibly related to bug #605010 <https://bugs.launchpad.net/inkscape/+bug/605010>?

tags: added: crash node-editing
Changed in inkscape:
importance: Undecided → High

i was not using a mac i was using windows

On Wed, Jul 14, 2010 at 4:32 PM, ~suv <email address hidden> wrote:
> Not reproduced with Inkscape 0.48pre1, 0.48.x (r9612) on OS X 10.5.8
>
> Possibly related to bug #605010
> <https://bugs.launchpad.net/inkscape/+bug/605010>?
>
> ** Tags added: crash node-editing
>
> ** Changed in: inkscape
>   Importance: Undecided => High
>
> --
> crash when changing node type
> https://bugs.launchpad.net/bugs/605575
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> system info [ windows 7 professional  intel i7 (6core) nvidia quadro (graphics card) asus motherboard 24gb ram ]
>
> build [Inkscape 0.48pre1 r9509]
>
> ok so when i try to edit a path if i change the node type to many times it crashes and displays
>
> [Inkscape encountered an internal error and will close now.
> Automatic backups of unsaved documents were done to the following locations:
>        C:\Users\matty\New document 1.2010_07_14_15_38_21.0.svg]
>
>
>
> edit a point on the line in the file than change it's node type about six times randomly it should happen
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/inkscape/+bug/605575/+subscribe
>

Matty (matthew-tikiman) wrote :

i dont want to see this bug in the final release it's annoying and
obstructs work flow i would be verry happy if you guys killed it

On Thu, Jul 15, 2010 at 8:09 AM, Matty Krosschell
<email address hidden> wrote:
> i was not using a mac i was using windows
>
> On Wed, Jul 14, 2010 at 4:32 PM, ~suv <email address hidden> wrote:
>> Not reproduced with Inkscape 0.48pre1, 0.48.x (r9612) on OS X 10.5.8
>>
>> Possibly related to bug #605010
>> <https://bugs.launchpad.net/inkscape/+bug/605010>?
>>
>> ** Tags added: crash node-editing
>>
>> ** Changed in: inkscape
>>   Importance: Undecided => High
>>
>> --
>> crash when changing node type
>> https://bugs.launchpad.net/bugs/605575
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in Inkscape: A Vector Drawing Tool: New
>>
>> Bug description:
>> system info [ windows 7 professional  intel i7 (6core) nvidia quadro (graphics card) asus motherboard 24gb ram ]
>>
>> build [Inkscape 0.48pre1 r9509]
>>
>> ok so when i try to edit a path if i change the node type to many times it crashes and displays
>>
>> [Inkscape encountered an internal error and will close now.
>> Automatic backups of unsaved documents were done to the following locations:
>>        C:\Users\matty\New document 1.2010_07_14_15_38_21.0.svg]
>>
>>
>>
>> edit a point on the line in the file than change it's node type about six times randomly it should happen
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/inkscape/+bug/605575/+subscribe
>>
>

Matty (matthew-tikiman) wrote :

it has nothing to do with Spiro paths it happens with regular paths

On Thu, Jul 15, 2010 at 8:47 AM, Matty Krosschell
<email address hidden> wrote:
> i dont want to see this bug in the final release it's annoying and
> obstructs work flow i would be verry happy if you guys killed it
>
> On Thu, Jul 15, 2010 at 8:09 AM, Matty Krosschell
> <email address hidden> wrote:
>> i was not using a mac i was using windows
>>
>> On Wed, Jul 14, 2010 at 4:32 PM, ~suv <email address hidden> wrote:
>>> Not reproduced with Inkscape 0.48pre1, 0.48.x (r9612) on OS X 10.5.8
>>>
>>> Possibly related to bug #605010
>>> <https://bugs.launchpad.net/inkscape/+bug/605010>?
>>>
>>> ** Tags added: crash node-editing
>>>
>>> ** Changed in: inkscape
>>>   Importance: Undecided => High
>>>
>>> --
>>> crash when changing node type
>>> https://bugs.launchpad.net/bugs/605575
>>> You received this bug notification because you are a direct subscriber
>>> of the bug.
>>>
>>> Status in Inkscape: A Vector Drawing Tool: New
>>>
>>> Bug description:
>>> system info [ windows 7 professional  intel i7 (6core) nvidia quadro (graphics card) asus motherboard 24gb ram ]
>>>
>>> build [Inkscape 0.48pre1 r9509]
>>>
>>> ok so when i try to edit a path if i change the node type to many times it crashes and displays
>>>
>>> [Inkscape encountered an internal error and will close now.
>>> Automatic backups of unsaved documents were done to the following locations:
>>>        C:\Users\matty\New document 1.2010_07_14_15_38_21.0.svg]
>>>
>>>
>>>
>>> edit a point on the line in the file than change it's node type about six times randomly it should happen
>>>
>>> To unsubscribe from this bug, go to:
>>> https://bugs.launchpad.net/inkscape/+bug/605575/+subscribe
>>>
>>
>

Matty (matthew-tikiman) wrote :

just to make it a bit more clear by change the node type i mean corner
smooth auto smooth etc.

On Thu, Jul 15, 2010 at 8:49 AM, Matty Krosschell
<email address hidden> wrote:
> it has nothing to do with Spiro paths it happens with regular paths
>
> On Thu, Jul 15, 2010 at 8:47 AM, Matty Krosschell
> <email address hidden> wrote:
>> i dont want to see this bug in the final release it's annoying and
>> obstructs work flow i would be verry happy if you guys killed it
>>
>> On Thu, Jul 15, 2010 at 8:09 AM, Matty Krosschell
>> <email address hidden> wrote:
>>> i was not using a mac i was using windows
>>>
>>> On Wed, Jul 14, 2010 at 4:32 PM, ~suv <email address hidden> wrote:
>>>> Not reproduced with Inkscape 0.48pre1, 0.48.x (r9612) on OS X 10.5.8
>>>>
>>>> Possibly related to bug #605010
>>>> <https://bugs.launchpad.net/inkscape/+bug/605010>?
>>>>
>>>> ** Tags added: crash node-editing
>>>>
>>>> ** Changed in: inkscape
>>>>   Importance: Undecided => High
>>>>
>>>> --
>>>> crash when changing node type
>>>> https://bugs.launchpad.net/bugs/605575
>>>> You received this bug notification because you are a direct subscriber
>>>> of the bug.
>>>>
>>>> Status in Inkscape: A Vector Drawing Tool: New
>>>>
>>>> Bug description:
>>>> system info [ windows 7 professional  intel i7 (6core) nvidia quadro (graphics card) asus motherboard 24gb ram ]
>>>>
>>>> build [Inkscape 0.48pre1 r9509]
>>>>
>>>> ok so when i try to edit a path if i change the node type to many times it crashes and displays
>>>>
>>>> [Inkscape encountered an internal error and will close now.
>>>> Automatic backups of unsaved documents were done to the following locations:
>>>>        C:\Users\matty\New document 1.2010_07_14_15_38_21.0.svg]
>>>>
>>>>
>>>>
>>>> edit a point on the line in the file than change it's node type about six times randomly it should happen
>>>>
>>>> To unsubscribe from this bug, go to:
>>>> https://bugs.launchpad.net/inkscape/+bug/605575/+subscribe
>>>>
>>>
>>
>

su_v (suv-lp) wrote :

> i was not using a mac i was using windows
Bug triage includes trying to reproduce and confirm a reported problem on different platforms with different Inkscape builds/versions.

> i dont want to see this bug in the final release
The branch for 0.48 has already happened - earliest fix could be in a point release (0.48.1) or 0.49.

> it has nothing to do with Spiro paths it happens with regular paths
As commented in bug #605010, the backtrace of that crash indicates that it happened when changing node types (nothing specific about Spiro or Undo): Inkscape::UI::Node::setType()

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, revision 9535.
Backtrace attached.

Not reproduced on Ubuntu, revision 9617.

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :
tags: added: win32
Matty (matthew-tikiman) wrote :

thank you i hope i was usefull

On Thu, Jul 15, 2010 at 1:48 PM, JazzyNico <email address hidden> wrote:
>
> ** Attachment added: "bt-605575.txt"
>   http://launchpadlibrarian.net/51989186/bt-605575.txt
>
> ** Tags added: win32
>
> --
> crash when changing node type
> https://bugs.launchpad.net/bugs/605575
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: Confirmed
>
> Bug description:
> system info [ windows 7 professional  intel i7 (6core) nvidia quadro (graphics card) asus motherboard 24gb ram ]
>
> build [Inkscape 0.48pre1 r9509]
>
> ok so when i try to edit a path if i change the node type to many times it crashes and displays
>
> [Inkscape encountered an internal error and will close now.
> Automatic backups of unsaved documents were done to the following locations:
>        C:\Users\matty\New document 1.2010_07_14_15_38_21.0.svg]
>
>
>
> edit a point on the line in the file than change it's node type about six times randomly it should happen
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/inkscape/+bug/605575/+subscribe
>

Krzysztof Kosinski (tweenk) wrote :

Probably fixed in r9826 in trunk and r9685 in the stable branch, please test.

Changed in inkscape:
status: Confirmed → Fix Committed
jazzynico (jazzynico) on 2010-10-12
Changed in inkscape:
milestone: none → 0.48.1
Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers