Paint Bucket: Upper/lower value in context menu of Grow/shrink are unrealistic

Bug #587769 reported by Masato HASHIMOTO on 2010-05-31
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

Though the upper and lower value in context menu of Glow/shrink are 1e6 and -1e6, IMHO these are terribly big and small, too far from next item (i.e. 0.50... and -0.50...) and unrealistic.
When I chose upper one and painted, it took enormously long time and drawing become enormously big.

Version:
Inkscape trunk-r9459

Build & Platform:
Build 2010-05-31 on Arch Linux (x86_64)

Tags: ui Edit Tag help
jazzynico (jazzynico) wrote :

Never noticed it before, but yes, there's no point in using such a big value.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
tags: added: ui
jazzynico (jazzynico) wrote :

I've tested with the maximum unzoom available with Inkscape (1%), and the most realistic values should be +10000 and -10000. Bigger values seem to be unusable.

FYI, the intermediate values are calculated from the last selected value by adding or substacting 0.1 and 0.5, which is not really realistic too. What about using a percentage of the selected value instead?

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
su_v (suv-lp) wrote :

Raising importance to 'Medium' since such high min/max values can cause Inkscape to crash when using the paint bucket without rechecking the current values of the 'Grow/shrink' spin box (see new duplicate bug #720699).

Please revert the status changes if you think the two issues are not related.

Changed in inkscape:
importance: Low → Medium
summary: - Paint Bucket: Upper/lower value in context menu of Glow/shrink are
+ Paint Bucket: Upper/lower value in context menu of Grow/shrink are
unrealistic
jazzynico (jazzynico) on 2011-02-18
Changed in inkscape:
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Maximum value lowered from 1e6 to 1e4.
Committed in the trunk (revision 10057) and the 0.48.x branch (revision 9765).

Changed in inkscape:
status: In Progress → Fix Committed
milestone: 0.49 → 0.48.2
Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers