PDF export: crash in 'CairoRenderContext::_showGlyphs'

Bug #564442 reported by Maha on 2010-04-16
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen
inkscape (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Alex Valavanis

Bug Description

When i try to save a certain svg file as pdf file, an error box appears: Inkscape encountered an internal error and will close now.
Would you please help me with this. I'm using 0.47 and Window 7. Thanks.

su_v (suv-lp) wrote :

Could you please attach one of the SVG files that crashes Inkscape on export to PDF?

tags: added: crash exporting pdf
Maha (maha-miu) wrote :

Here is one file of them, hope you find the solution.
Thanks for your time & consideration.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9231 and r9336 on OS X 10.5.8 (Cairo 1.8.10)

Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
su_v (suv-lp) wrote :

crash report (0.47+devel r9336) including backtrace

su_v (suv-lp) on 2010-04-16
summary: - Inkscape encountered an internal error and will close now.
+ PDF export: crash in 'CairoRenderContext::_showGlyphs'
Maha (maha-miu) wrote :

Is there any solution?!

Johan Engelen (johanengelen) wrote :

fixed in r9842

su_v (suv-lp) on 2010-10-23
Changed in inkscape:
status: Confirmed → Fix Committed
Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
su_v (suv-lp) wrote :

Inkscape 0.48+devel r9842 on longer crashes when exporting the sample SVG to PDF:

@Maha - can you check the attached exported PDF file for errors? (Note that I do not have all fonts you used installed on my system, and of course the linked bitmaps are missing).

su_v (suv-lp) wrote :

inkscape trunk: r9842
inkscape 0.48.x: r9694

Changed in inkscape:
milestone: none → 0.48.1
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
Alex Valavanis (valavanisalex) wrote :

Fixed in Ubuntu Natty since inkscape_0.48.1-0ubuntu1. Still affects earlier versions of Ubuntu, but it probably won't qualify for a Stable Release Update... I guess it's a bit too obscure, and doesn't affect enough users for the SRU team to consider risking a patch.

Hopefully, we can get Inkscape 0.48.1 backported to Lucid, which would also solve this problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers