Printing rastered image offsets the page

Bug #508529 reported by quazgar on 2010-01-16
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico
inkscape (Debian)
Fix Released
Unknown

Bug Description

When printing to a file with output set to rastered image instead of vector graphics, the produced output is offset a bit to the upper left.

Please see the attached files for examples.

This happens for Inkscape 0.47 on Gentoo Linux, amd64, and reportedly also on Mac OS X 10.5.8.

quazgar (quazgar) wrote :
quazgar (quazgar) wrote :

The faulty output pdf. It seems that this bug can at least be worked around by setting the 5th and 6th entries in the matrix in line 65 both to 0.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.47 r22583 on OS X 10.5.8
(as confirmed in comment #11 of bug #373309)

Changed in inkscape:
status: New → Confirmed
tags: added: printing
tatankam (tatankam) wrote :

Reproduced on Windows 7 Inkscape 0.47

tatankam (tatankam) wrote :

It seems that when you choose File-Print->Rendering Bitmap = 300 dpi, it shift on the left the output, so it isn't centered.

If you choose File->Print->Rendering Vectorial it is centered on the output.

See the attachmentes.

tatankam (tatankam) wrote :

The vectorial output

tatankam (tatankam) wrote :

Hallo.

Is there any news about this bug?

Thanks

jazzynico (jazzynico) wrote :

No change with 0.48.
It seems that it is less severe with high resolutions (set bitmap export to 300ppp) than with the default 72ppp.

Changed in inkscape:
importance: Undecided → Medium
Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Debian):
status: Unknown → Confirmed

Inkscape 0.48 as shipped in Ubuntu Precise still has this problem

Kevin Shenk (batonac) wrote :

This bug still affects the Inkscape shipped with raring. Is there any known workaround? I can't understand rubik-cube's workaround...

quazgar (quazgar) wrote :

@Kevin: My workaround was really just that: a workaround for when there is no other solution (and maybe a hint for developers what may be wrong). If you open my example pdf in a text editor, it seemed to help (at least in that case), to edit some numbers in said line.

jazzynico (jazzynico) wrote :

Seems to be fixed with the attached patch.

I need to understand why the offset was set before committing the patch to the trunk...
(see comment in the original file: // FIXME: why is the origin offset??)

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
milestone: none → 0.91
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Patch tested on Windows XP and committed revision 13509.

Changed in inkscape:
status: In Progress → Fix Committed
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.