Rectangle with rounded corners

Bug #481805 reported by uwesch on 2009-11-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Markus Engel

Bug Description

1. Draw a rectangle
2. move the first round handle vertical down to get circular corners
3. move the second round handle to the left to get elliptic rounded corners
4. move this one back to starting position to get circular rounded corners again (without elliptical roundings)
5. move the vertical handle .... and nothing is working with this handle anymore. (only if the second round handle is in top right position)

I'm on Vista with devel 22575

su_v (suv-lp) on 2009-11-13
tags: added: shape-editing
su_v (suv-lp) wrote :

reproduced with Inkscape 0.46-2 and Inkscape 0.46+devel r22575 on OS X 10.5.8

workaround: click 'Not rounded' (tooltip 'Make corners sharp') on the rectangle tool controls bar to reset the rx and ry values.

jazzynico (jazzynico) wrote :

Confirmed on Vista, Inkscape revision 22575.

Another workaround: set Rx value to 0 on the tool's control bar (Ry is not changed and Rx correctly reset).

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
marisano (marisano) wrote :

Reproduced in Inkscape 0.48.1 on Windows 7.

Another workaround: Shift+Click one of the circular handles.

I'm learning how to use Inkscape now and I keep running into bugs like this. It can be frustrating because I don't always know what the correct behavior is meant to be. This is probably half and afternoon's work. I think you should fix it.

Markus Engel (engelmarkus) wrote :

I created a little patch for this as I, too, think this behavior is not ideal.
The spec states that if either Rx or Ry are not set, both Rx and Ry should be set to the existing value. There are two possible solutions now to get a consistent behavior: Either always unset Rx or Ry when they are set to zero or never unset them. But at the moment Rx and Ry are unset in the beginning and they are not unsettable by moving the handles to the top right corner again.
With the appended patch values are unset if the handle is moved back. Making the rectangle's edges sharp is possible by either clicking the button, setting the values in the spinners to zero or by moving both of the handles back.

jazzynico (jazzynico) wrote :

Patch tested successfully on Windows XP, Inkscape trunk revision 12253.

Changed in inkscape:
assignee: nobody → Markus Engel (engelmarkus)
milestone: none → 0.49
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 12255.
Thanks Markus!

Changed in inkscape:
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
Mc (mc...) wrote :

There was a problem with this bug in that if the behavior in inkscape was the intended one, the xml (in particular when saving) was kept with the rx=0 attribute, making it fail on other renderers. Now inkscape will still ignore manually set "rx=0;ry≠0" attributes made by other editors (those should be rare). Fixed in trunk r15420, backport-proposed to .92.1

su_v (suv-lp) wrote :

Follow-up report to rev 15420:
* Bug #1657554 “Trunk today : Rectangles and text blocks lacking when reloading file”
  https://bugs.launchpad.net/inkscape/+bug/1657554

@Mc - personally, I would propose to track whatever issue rev 15420 was intended to fix in a new report (a separate report along with context what to look out for in local tests would also make make tracking the backport to lp:inkscape/0.92.x easier).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers