Inkscape: A Vector Drawing Tool

Japanese translation update for web pages

Reported by Masato HASHIMOTO on 2009-10-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

Hi,

Attached is the Japanese translation update of Inkscape web pages.
Included files are as follows:
inkscape_web-ja/showcase/sc-005-branding-ja.inc
inkscape_web-ja/showcase/sc-004-icons-ja.inc
inkscape_web-ja/showcase/sc-003-web-design-ja.inc
inkscape_web-ja/showcase/sc-002-booklet-ja.inc
inkscape_web-ja/showcase/sc-001-game-map-ja.inc
inkscape_web-ja/screenshots/gallery/info/inkscape-0.47-tweakaroo.ja
inkscape_web-ja/screenshots/gallery/info/inkscape-0.47-spiro-typography.ja
inkscape_web-ja/screenshots/gallery/info/inkscape-0.47-pinkitude.ja
inkscape_web-ja/screenshots/gallery/info/inkscape-0.47-photorealism.ja
inkscape_web-ja/index.ja-header.php
inkscape_web-ja/includes/localized-ja.inc

Please check and apply.
Regards

Masato HASHIMOTO (hashimo) wrote :
jazzynico (jazzynico) wrote :

Files committed in revision 22484.
Thanks!

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
importance: Undecided → Low
status: New → Fix Released
jazzynico (jazzynico) wrote :

There things which are not working yet (screen shots and showcases).
I'm working on it.

Changed in inkscape:
status: Fix Released → In Progress
jazzynico (jazzynico) wrote :

None of the uploaded files seem to be updated on the website.
Weird. I'm lost!

jazzynico (jazzynico) wrote :

Ok, I just needed to read the manual... (http://wiki.inkscape.org/wiki/index.php/WebsiteEditing).
Updating the website requires an additional step, which can only be done by a website admin.
I update some other files and then request an update.

jazzynico (jazzynico) wrote :

I've just installed a local web server in order to test the local SVN changes, and your files are ok.

Changed in inkscape:
status: In Progress → Fix Committed
Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached includes some update related web pages.

* ja-2009-10-17.tar.bz2/inkscape_web/
  Add/update Documentation page and update some existing pages.

 I will send the translation of download page after you update it for releasing 0.47.

* ja-2009-10-17.tar.bz2/doc-docbook/
 In the Japanese tutorial's PNG images that you made, Kanji characters are mixed in Japanese and Chinese :)
 I attached all images for ja that I made (I don't know Chinese pages are OK or not).

 In addition, tutorial-elements.ja.* in inkscape_web and inkscape repo are not up-to-date as far as I confirmed.
 Please update from doc-docbook repo ( just to be safe, I wish to be update all tutorial files).

Regards

jazzynico (jazzynico) wrote :

Doc pages updated.

I start a new tutorial build for html and images (will take some time to run and upload...).
I tell you as soon as SVN is updated.

jazzynico (jazzynico) wrote :

Web files updated (in SVN), revision 22510.

I've compare some of the SVN images with the ones you attached, but I see no difference (only a slight change in the shape of the kanjis, due to a different font). Could you confirm you still have Chinese characters in your images?

Masato HASHIMOTO (hashimo) wrote :

# Sorry for late. I had a trouble (please see below).

> Could you confirm you still have Chinese characters in your images?

Well, Chinese fonts are still included.
I suppose Japanese fonts which you are using is VL Gothic so I tried to make tutorials with the fonts.

# However, strangely, png files are not made by "make all" even though svg and html files are made. (Why? Why??)
# I had no choice, I exported typical image from svg

Please see attached. In this case, the VL Gothic font isn't used in all kanjis (not even Sans font) and some (probably all) of them are not Japanese glyph.

BTW, the following files in inkscape_web repo are set "svn:mime-type" property. Please drop it.
* screenshots/gallery/info/inkscape-0.47-photorealism.ja
* screenshots/gallery/info/inkscape-0.47-tweakaroo.ja

Masato HASHIMOTO (hashimo) wrote :

Oops, I forgot to one more issue.

There is a typo in inkscape_web/trunk/screenshots/gallery/info/inkscape-0.47-pinkitude.en

"Susan G. Koman for the Cure" is wrong,
"Susan G. Komen for the Cure" is correct.

Attached corrected ja translation.

Regards

jazzynico (jazzynico) wrote :

> # However, strangely, png files are not made by "make all" even though svg and html files are made. (Why? Why??)

Yes, I've just found out that you need to clean the directory first (rm *.html and rm *.svg.png) and then launch make html to rebuild the pngs (and html).

jazzynico (jazzynico) wrote :

> There is a typo in inkscape_web/trunk/screenshots/gallery/info/inkscape-0.47-pinkitude.en

Corrected.

> BTW, the following files in inkscape_web repo are set "svn:mime-type" property.

I see nothing wrong with these files. They seem to show as expected.

> Please see attached. In this case, the VL Gothic font isn't used in all kanjis (not even Sans font) and some (probably all) of them are not Japanese glyph.

Ok, I understand, now... What I thought was a small difference is in fact a more serious issue. Since I can't get the right images from my OS, I've uploaded your files.

Except svn:mime-type (please explain?), everything committed in revision 22514.

Regards

Masato HASHIMOTO (hashimo) wrote :

> Except svn:mime-type (please explain?)

Please confirm 'svn proplist --verbose screenshots/gallery/info/inkscape-0.47-photorealism.ja@HEAD'.
It result should be as follows:
> svn:mime-type
> application/octet-stream

That is, svn recognizes it as binary. (svn sometimes sets the property automatically when doing 'svn add' even if file is text)
In this case, svn diff doesn't work as expected for text files at least. It's not useful.

> Yes, I've just found out that you need to clean the directory first (rm *.html and rm *.svg.png) and
> then launch make html to rebuild the pngs (and html).

Thanks for suggestion. But, I removed my working copy once and checkout it newly... :(
I'll examine what I made mistake.

Regards

jazzynico (jazzynico) wrote :

> Please confirm 'svn proplist --verbose screenshots/gallery/info/inkscape-0.47-photorealism.ja@HEAD'.
> It result should be as follows:
> svn:mime-type
> application/octet-stream

Confirmed. Never noticed that before. Thanks for pointing that!
Proplist removed in revision 22515.

Regards.

jazzynico (jazzynico) wrote :

Website updated! (Thanks Alexandre).

Changed in inkscape:
status: Fix Committed → Fix Released
Masato HASHIMOTO (hashimo) wrote :

Hi,

> Web files updated (in SVN), revision 22510.

Please update tutorials under inkscape repo too.

I said in #7:
> In addition, tutorial-elements.ja.* in inkscape_web and inkscape repo are not up-to-date as far as I confirmed.
> Please update from doc-docbook repo ( just to be safe, I wish to be update all tutorial files).

Regards

jazzynico (jazzynico) wrote :

Elements and shapes tutorials updated in revision 22521.
All others were already up to date.
Could you please confirm?

Regards.

Masato HASHIMOTO (hashimo) wrote :

Confirmed.

Thank you for your hard work!!

Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is the Japanese translation for descriptions of scrrenshots added recently.
Please check and apply.

Regards

jazzynico (jazzynico) wrote :

Hi,

I've committed your files (and mine...) in revision 22587.
Thanks!

Regards

Masato HASHIMOTO (hashimo) wrote :

Congrats to release 0.47.

Attached is a update of the Japanese translation of web pages.

File list:
inkscape_web/doc/index-ja.inc
inkscape_web/includes/localized-ja.inc
inkscape_web/download/download-ja.inc
inkscape_web/screenshots/gallery/info/inkscape-0.47-spiro-typography.ja

As you already know, current download-ja.inc is a symlink of download-en.inc.

Please check and apply.
Regards

jazzynico (jazzynico) wrote :

Hi,

> Congrats to release 0.47.

Congrats to you too, you also contributed to it!

Update committed in revision 22610.
Thanks!

Regards

Masato HASHIMOTO (hashimo) wrote :

> Congrats to you too, you also contributed to it!

Yeah, thanks :)

Attached is a update of download-ja.inc (sync with en).
Please check and apply.

Regards

jazzynico (jazzynico) wrote :

Update committed in revision 22613.
Thanks!

Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is a update of download/download-ja.inc (add link for portable).

Please check and apply.
Regards

jazzynico (jazzynico) wrote :

Hi,

Sorry for the delay, I almost forgot to commit it...
Now it's done (in SVN revision 22625).

Regards.

Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is the Japanese translation of bzr page.

Please check and apply.

Regards

jazzynico (jazzynico) wrote :

Update committed in revision 22627.
Thanks!

Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is a update of the download page:
* Add download link of MacOSX Tiger ppc
* Replace svn repo info with bzr

Please check and apply.
Regards

jazzynico (jazzynico) wrote :

Update commited in SVN rev22656.
Thanks!

Changed in inkscape:
status: Fix Released → In Progress
Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is a update of 'includes/localized-ja.inc'.
Please check and apply.

Regards

@Masato: committed and updated on the server, many thanks!

jazzynico (jazzynico) on 2010-08-19
Changed in inkscape:
status: In Progress → Fix Released
Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is a update of some web pages for 0.48 and so on.
Please check and apply.

Regards

jazzynico (jazzynico) wrote :

Hi,

I've committed the (big!) update in svn revision 22754. Now waiting for a site update by Alexandre.

Regards.

jazzynico (jazzynico) wrote :

Now online!

Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is a patch for update of the following ja web pages:
M doc/index-ja.inc
M includes/localized-ja.inc
M index.ja-header.php
M download/download-ja.inc
A books/index-ja.inc

Please check and apply.
Regards

jazzynico (jazzynico) wrote :

Hi,

Updated files committed revision 22793.
I ask Alexandre to update the website as soon as I've finished some French translation updates.

Regards.

jazzynico (jazzynico) wrote :

Now online!

Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is a update of the following web pages:
inkscape_web/download/download-ja.inc
inkscape_web/doc/index-ja.inc

Please check and apply.
Regards

jazzynico (jazzynico) wrote :

Update committed in the web trunk, revision 22836.
Thanks!

Masato HASHIMOTO (hashimo) wrote :

Hi,
Attached is update of download page.
Please check and apply.
Regards

Changed in inkscape:
status: Fix Released → In Progress
jazzynico (jazzynico) wrote :

Hi,

Sorry for the delay...
Update committed in the web trunk, revision 22874.
Thanks!

Changed in inkscape:
status: In Progress → Fix Committed
~suv (suv-lp) wrote :

Closing as 'Fix Released' (web site updates have been pushed to the server since the commit).
Feel free to reopen and revert the status change if you don't agree.

Changed in inkscape:
status: Fix Committed → Fix Released
Masato HASHIMOTO (hashimo) wrote :

Hi,

Attached is a patch to update ja web pages.
Please check and apply.

Regards

Changed in inkscape:
status: Fix Released → In Progress
jazzynico (jazzynico) wrote :

Web pages commited revision 22902 (SVN).
Thanks!

Changed in inkscape:
status: In Progress → Fix Released
To post a comment you must log in.