Inkscape: A Vector Drawing Tool

eps import error

Reported by Alper on 2009-10-04
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Eps import fails producing 2 errors

Error reading temporary SVG file: [Errno 2] No such file or directory: 'c:\\docume~1\\auysaler\\locals~1\\temp\\tmp2wpcxf.svg'

When you click OK on the above error the below error is displayed.

Failed to load the requested file C:\Documents and Settings\auysaler\Desktop\DESIGN\Vector - Logotype 3 by DragonArt\Vector - Logotype 3 by DragonArt.eps

This is inkscape.47 pre 3

~suv (suv-lp) wrote :

See <https://answers.launchpad.net/inkscape/+question/83179>
and <https://answers.launchpad.net/inkscape/+question/81818>

<quote>
Inkscape 0.47(pre2) still need 'ps2pdf' for EPS input - 'ps2pdf' is part of Ghostscript:
<http://en.wikipedia.org/wiki/Ghostscript>

More technical details in Bug #227449 in Inkscape: “Runtime Error when loading specific .eps file”:
<https://bugs.launchpad.net/inkscape/+bug/227449>, especially comment #19
</quote>

Proposing to close this report as 'Invalid' or to convert it to a question because it is not about a bug but about a missing helper application.

tags: added: eps extensions-plugins
~suv (suv-lp) wrote :

On second thought - no, there's something else going on here: you shouldn't be able to open *.eps files if you don't have 'ps2pdf' installed.

Rephrasing my previous comment: Do you have GhostScript installed?

Yes i do. And i believe he first error is generated by the ghostscript
script. And the second one is an ordinary message from the python script
saying that the file is not there. I think its a simple matter of dos
filename confusion. Bu i coulnd bypass it by moving the files around to root
directories instead of long named directories. I tried it on 2 seperate
computers with the same result then i reported a bug.

this is a very grateful
Alper Uysaler

2009/10/4 ~suv <email address hidden>

> On second thought - no, there's something else going on here: you
> shouldn't be able to open *.eps files if you don't have 'ps2pdf'
> installed.
>
> Rephrasing my previous comment: Do you have GhostScript installed?
>
> --
> eps import error
> https://bugs.launchpad.net/bugs/442243
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> Eps import fails producing 2 errors
>
>
> Error reading temporary SVG file: [Errno 2] No such file or directory:
> 'c:\\docume~1\\auysaler\\locals~1\\temp\\tmp2wpcxf.svg'
>
> When you click OK on the above error the below error is displayed.
>
> Failed to load the requested file C:\Documents and
> Settings\auysaler\Desktop\DESIGN\Vector - Logotype 3 by DragonArt\Vector -
> Logotype 3 by DragonArt.eps
>
>
>
> This is inkscape.47 pre 3
>

~suv (suv-lp) wrote :

Which Windows and Ghostscript version?

> No such file or directory: 'c:\\docume~1\\auysaler\\locals~1\\temp\\tmp2wpcxf.svg'
Have you changed the location of the default TEMP directory?

tags: added: win32
Alper (alperuysaler) wrote :

GS 8,64 and 8,70 bothand windows XP home

2009/10/5 ~suv <email address hidden>

> Which Windows and Ghostscript version?
>
> > No such file or directory:
> 'c:\\docume~1\\auysaler\\locals~1\\temp\\tmp2wpcxf.svg'
> Have you changed the location of the default TEMP directory?
>
>
> ** Tags added: win32
>
> --
> eps import error
> https://bugs.launchpad.net/bugs/442243
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> Eps import fails producing 2 errors
>
>
> Error reading temporary SVG file: [Errno 2] No such file or directory:
> 'c:\\docume~1\\auysaler\\locals~1\\temp\\tmp2wpcxf.svg'
>
> When you click OK on the above error the below error is displayed.
>
> Failed to load the requested file C:\Documents and
> Settings\auysaler\Desktop\DESIGN\Vector - Logotype 3 by DragonArt\Vector -
> Logotype 3 by DragonArt.eps
>
>
>
> This is inkscape.47 pre 3
>

Alper (alperuysaler) wrote :

Sorry i didnt see your second question. I changed the location of the temp
directory to move it to a dos friendly location. Its old location contained
long names. But that did not change anything.

2009/10/5 ~suv <email address hidden>

> Which Windows and Ghostscript version?
>
> > No such file or directory:
> 'c:\\docume~1\\auysaler\\locals~1\\temp\\tmp2wpcxf.svg'
> Have you changed the location of the default TEMP directory?
>
>
> ** Tags added: win32
>
> --
> eps import error
> https://bugs.launchpad.net/bugs/442243
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> Eps import fails producing 2 errors
>
>
> Error reading temporary SVG file: [Errno 2] No such file or directory:
> 'c:\\docume~1\\auysaler\\locals~1\\temp\\tmp2wpcxf.svg'
>
> When you click OK on the above error the below error is displayed.
>
> Failed to load the requested file C:\Documents and
> Settings\auysaler\Desktop\DESIGN\Vector - Logotype 3 by DragonArt\Vector -
> Logotype 3 by DragonArt.eps
>
>
>
> This is inkscape.47 pre 3
>

~suv (suv-lp) on 2009-11-01
tags: added: importing
removed: extensions-plugins
Dan Craig (thevillageinn) wrote :

I'm also seeing the same error. I can't figure where the extra slashes are coming from.

The error window states: "Inkscape has received additional data from the script executed. The script did not return an error, but this may indicate the results will not be as expected."

This is evidently the extra information:
"Error reading temporary SVG file: [Errno 2] No such file or directory: 'c:\\users\\daniel\\appdata\\local\\temp\\tmpo88jfm.svg' "

My system is Win 7. All files are in default locations. Ghost Script 8.70 is installed. Inkscape 0.47 r22583, built Nov 21 2009. That temp directory exists so to speak.

I'd be happy to offer any additional information that's needed.

Alvin Penner (apenner) wrote :

could you try copying the file gswin32c.exe from the directory :
C:\Program Files\gs\gs8.64\bin
to the directory :
C:\Program Files\gs\gs8.64\lib
so that it exists in both places?
The 'lib' directory is probably already in the path, but the 'bin' directory may not be in the path, and the file gswin32c.exe is essential for this procedure. (You'll need to adjust the version number 8.64 as required)

Alper (alperuysaler) wrote :

Its done.. Finally. Thank you very much Alvin Penner.

2010/1/31 Alvin Penner <email address hidden>

> could you try copying the file gswin32c.exe from the directory :
> C:\Program Files\gs\gs8.64\bin
> to the directory :
> C:\Program Files\gs\gs8.64\lib
> so that it exists in both places?
> The 'lib' directory is probably already in the path, but the 'bin'
> directory may not be in the path, and the file gswin32c.exe is essential for
> this procedure. (You'll need to adjust the version number 8.64 as required)
>
> --
> eps import error
> https://bugs.launchpad.net/bugs/442243
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: New
>
> Bug description:
> Eps import fails producing 2 errors
>
>
> Error reading temporary SVG file: [Errno 2] No such file or directory:
> 'c:\\docume~1\\auysaler\\locals~1\\temp\\tmp2wpcxf.svg'
>
> When you click OK on the above error the below error is displayed.
>
> Failed to load the requested file C:\Documents and
> Settings\auysaler\Desktop\DESIGN\Vector - Logotype 3 by DragonArt\Vector -
> Logotype 3 by DragonArt.eps
>
>
>
> This is inkscape.47 pre 3
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/inkscape/+bug/442243/+subscribe
>

--
Alper Uysaler
t. 0262 641 66 16
c. 0555 724 51 90
e. <email address hidden>

Dan Craig (thevillageinn) wrote :

heh - good thinking.

I'd tried testing the ps2pdf.bat file directly earlier today and was getting errors about gswin32c.exe not being available so I added the \bin folder to the path variable and while that didn't help my testing of the script (I completely neglected to re-test in Inkscape) it turns out, thanks to your suggestion - to have resolved the problem for me too.

So in summary - I just added C:\Program Files\gs\gs8.70\bin\ to my path variable instead of copying the executable.

Dan Craig (thevillageinn) wrote :

sorry I forgot to say thank you!

Alvin Penner (apenner) wrote :

good to hear; in that case, if there is no objection, I'll mark this as fix released

Changed in inkscape:
status: New → Fix Released
Mario Juárez (pachinsv) wrote :

Hey muchas gracias Alvin eres un genio ... thank you very much Alvin you're a genius =D

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers