Draw a chessboard (checkerboard) in the background to know when alpha < 100%

Bug #397723 reported by Yann Papouin on 2009-07-10
120
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Tavmjong Bah

Bug Description

A chessboard (checkerboard) is commonly used in drawing applications to show the "real" canvas background.
Inkscape should allow this in per document settings.

See attached mockup

Tags: ui Edit Tag help
Yann Papouin (yann-papouin) wrote :
jazzynico (jazzynico) wrote :

Yann, could you take a look at bug #169623 and see if it's what you wish?

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
Yann Papouin (yann-papouin) wrote :

No it seems that this bug is a proposal to replace canvas transparency color, my wish is a checked board replacement of the current white canvas when transparency < 100%.

jazzynico (jazzynico) wrote :

https://bugs.launchpad.net/inkscape/+bug/169623/comments/12
"In a perfect world, the canvas color would actually be a checkerboard of two colors, like the GIMP or any other program has."
The original report may not be about checker board, but it's author fully agrees with you :)

su_v (suv-lp) on 2009-10-29
tags: added: ui
Adrian Hungate (a-adrian) wrote :

We have a reasonably common sense request here that is almost 5 years old, and it appears there has been no progress, nor and explanation of why it will not be done. Does anyone have an update?

jazzynico (jazzynico) on 2014-05-20
Changed in inkscape:
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

@Adrian - I agree with you it's an interesting feature to have, but unfortunately the Inkscape contributors are already pretty busy fixing bugs and other wishlist items they estimate have an higher priority. Don't forget that Inkscape development relies on enthusiasts developing on their spare time.
Of course, it would be great if someone (maybe you?) could share a patch...

Kevin Cox (kevincox) wrote :

I would also like to suggest that there is an option for solid colors as well. For example sometimes is is useful to draw on a dark background but have the exported image have a transparent background.

su_v (suv-lp) on 2014-12-22
summary: - Draw a chessboard in the background to know when alpha < 100%
+ Draw a chessboard (checkerboard) in the background to know when alpha <
+ 100%
description: updated
Derek (bugs-m8y) wrote :

WRT comment #8 by Kevin - suv pointed out that you can now do that with background colour in the latest beta. He gave me a bug # in launchpad which I regrettably didn't note down. Perhaps he can add it.

Also, obviously, if you set the checkerboard colours to the same colour, you would then have a solid background ๐Ÿ˜‰.

If the sliders had a lock option, could even adjust both smoothly over a range of brightnesses for checkerboard/solid.

Derei (derei.uk) wrote :

Any updates on this?

Will Inkscape have checker pattern for transparent background? Is something that is a really big issue, as is impossible to tell the level of transparency of the objects, can't see any white object.

And the workaround with "colored" background it just doesn't work. One has to make it transparent back prior export. Should be fixed properly.
Especially because the opacity sliders in inkscape use that checkerboard to show the transparency level.

su_v (suv-lp) wrote :

Option for checkerboard background added in rev 14539.

Changed in inkscape:
assignee: nobody → Tavmjong Bah (tavmjong-free)
milestone: none → 0.92
status: Triaged → Fix Committed

2016-10-08 VictorWestmann: Is this feature implemented in Inkscape?

I would like to know this to, because I didn't find the option anywhere.

Alvin Penner (apenner) wrote :

I think you will need to visit the menu item File->Document Properties and check the item called "Background", as in the attached figure

su_v (suv-lp) wrote :

@all - please note the milestone of this bug report (0.92), as well as the bug status ('Fix Committed', which is not the same as 'Fix Released'): this feature will be available in the _next_ version (Inkscape 0.92, soon to be released, but not yet out). Current stable Inkscape 0.91 does _not_ include this feature yet.

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
Liran Barsisa (ad-lb) wrote :

Any news about this?
For some reason it's marked as fixed, but I still can't find any global setting to set transparent background to be shown as checkerboard.
Instead I only see a per-project setting for changing it.
Am I missing anything ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions