Filter editor problems (unable to reapply filters)

Bug #390165 reported by rirad on 2009-06-21
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I encountered several (maybe related) problems with the filter editor.

System: Ubuntu 9.04, Inkscape 0.47pre0 r21549, built Jun 12 2009,

Correct behavior:

First start inkscape, draw a box, apply the black outline filter to the box (black outline is correctly applied) and open the filter editor. The black outline filter is listed in the editor and the checkmark is checked.

Close inkscape.

Bug1:

Start inkscape, draw a box, open the filter editor, select the black outline filter from the menu (black outline filter is correctly applied', In the filter editor, the black outline filter name is now called 'filter'# (random number). The checkbox is also not check while the filter is applied. To fix this click the checkbox (this will activate the checkbox and the filter will still be applied).

Applying another filter will rename the black outline filter name (filter#) to its default 'black outline' name.

Bug2 (serious):

In the filter editor, select the black outline filter entry when it is applied to the object (checkmarked or not checkmarked as described in the situation above). Richt-click on the filter name and select remove. The filter is removed from the filter editor en the effect is removed from the object. Now re-apply the black outline filter (or any other filter) to the same object via the filter menu and the filter will not be applied to the object nor will it be displayed in the filter editor.

So, once an active filter is removed, new filters can not be applied to that object. The only way is to remove that object and redraw it. First the active filter needs to be deslected (by first activating the checkbox and than deactivating the checkbox in front of the filter name) and than the filter can be safely removed.

tags: added: filters-svg ui
rirad (rirad) wrote :

This behavior (bug) is still present in Inkscape 0.46+devel r22242, built Sep 16 2009

Furthermore a crash can be invoked by doing to following:
When the active filter is removed from the filter list as described above under bug 2, add a new filter (using the button below the filter names), enable the empty filter by activating the check box, select eg the black outline filter from the menu (this should overwrite the current empty filter with the black outline parameters) -> crash

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

1) filter checkbox not updated correctly: name, status (applied, removed)
related bug #326560
2) once an active filter is removed, new filters can not be applied to that object
marking bug #401027 as duplicate (more precise description here)
3) Crash when combining a preset filter and an empty user defined one
already reported and fixed (see bug #430804)

jazzynico (jazzynico) wrote :

It seems that removing a filter doesn't update the filter links in the objects' style attribute.

Workaround for bug 2:
1. Open the XML editor (Shift+Ctrl+X).
2. Select the previously filtered object.
3. Remove the "filter:url(#filterXXXX)" part in the style attribute.

Changed in inkscape:
importance: Undecided → Medium
status: Confirmed → Triaged
su_v (suv-lp) wrote :

Related to issue 2:
Bug #275662 “Filter stays in object's css property after Filter Effect dialog removal”

John Smith (john-smithi) wrote :

Patch to fix bug 2 is available in bug #275662.

John Smith (john-smithi) wrote :

Fix for bug.2 is committed (bug #275662)

su_v (suv-lp) wrote :

Patch for bug.1 available in in bug 1089406.

insaner (insaner) wrote :

hi, if this bug (err, both bugs) is fixed, can we mark as resolved?

su_v (suv-lp) wrote :

Fix for bug 1 committed (bug #1089406) in revision 12232 (Author: Insaner)
Fix for bug 2 committed (bug #275662) in revision 11881 (Author: John Smith)

Changed in inkscape:
milestone: none → 0.49
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers