The small icon in the upper left corner is absent

Bug #388063 reported by riu on 2009-06-16
102
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned
Nominated for 0.47.x by mr. Ed
inkscape (Debian)
Fix Released
Unknown
inkscape (Fedora)
Won't Fix
Medium
inkscape (Ubuntu)
Undecided
Unassigned

Bug Description

The small icon in the left upper corner of the window is absent in the prerelease inkscape_0.47~pre0-0ubuntu1~8.04_i386. It is present in the 0.46 version for Ubuntu 8.04 Intel. See attachment.

riu (stanray) wrote :
su_v (suv-lp) wrote :

@Stan - do you also have the absent application icon in the task bar - as described in bug #396433?

Changed in inkscape:
status: New → Confirmed
riu (stanray) wrote :

The icon in the taskbar is absent too. (the video http://www.youtube.com/watch?v=rIlkVWxiAnM )

jazzynico (jazzynico) wrote :

Doesn't prevent Inkscape from working, but it would be nice to fix it before 0.47.

Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.47
jazzynico (jazzynico) wrote :

I don't know why nor which build changed it, but I no longer have this bug (Ubuntu 9.04, Inkscape rev. 21937).
Could someone else confirm it's fixed?

I could not confirm, but I can't guess how you have that revision
I hava package Version: 0.47~pre0-0ubuntu1~9.04 from
deb http://ppa.launchpad.net/inkscape.testers/ppa/ubuntu jaunty main
and version Inkscape 0.47pre0 r21549 (Jun 12 2009)

How can I get newer rev?

jazzynico (jazzynico) wrote :

You can compile Inkscape from SVN or source snapshots.
See http://wiki.inkscape.org/wiki/index.php/CompilingUbuntu

Ok, but I am supposing that bug report was against ubuntu package, not against upstream package.
 ... so you are saying fixed upstream .. I don't know

riu (stanray) wrote :

r21940 compiled on Ubuntu 8.04 has the same issue: no icon .
( http://inkscape.modevia.com/svn-snap/?M=D )

jazzynico (jazzynico) wrote :

Weird.
We have two differences:
Ubuntu 8.04/Ubuntu 9.04 (libs versions?)
Source snapshot/SVN.

I won't downgrade to Ubuntu 8.04, thus I can compile from modevia's snapshot and see if I can reproduce this bug...

jazzynico (jazzynico) wrote :

Can't reproduce with Ubuntu 9.04, compiled from snapshot 21940, and SVN rev. 21945 (fresh builds, share dirs removed).

Pablo Trabajos (pajarico) wrote :

Can't reproduce this either with 0.47pre1 on Win XP SP3. Guess is a Ubuntu thing. However, the icon on the help->about menu entry doesn't appear.

tags: added: ui
removed: icon inkscape
su_v (suv-lp) wrote :

@Pablo - see bug #371724 about this (non-unix platform) issue - a workaround has just been just committed.

Luca Bruno (lucab) on 2009-08-07
tags: added: linux
Luca Bruno (lucab) wrote :

Windows handles it via inkscape.ico, so it isn't affected. This is linux specific and still present in latest revisions (r22009 at the time of this writing). It seems to be uncoupled (at least not directly) from bug #371724, which had been recentrly worked on.

su_v (suv-lp) wrote :

@Luca - are you sure the linux bug here is not related to the underlying issue of #371724 (as confirmed by Krzysztof) i.e. possibly related to the build configuration to include/exclude librsvg and its SVG loader module (that's when bug #371724 started to appear on OS X as well), changing the internal icon name is only a (known) workaround... geared towards fixing the win32 bug.

What format is GNOME and/or Inkscape using for the icons displayed by the window manager (window decoration, task bar)?

Luca Bruno (lucab) wrote :

Well, not completely sure.. They're both related to theme issue, that's true, but I've tried the same workaround here and it doesn't work. I think it currently tries to use share/icons/inkscape.svg... I've tried both with appending -logo in source and renaming the file, and using a png too, but without success; icons debugging in preferences.xml doesn't help either.
But probably Krzysztof may speak more appropriately about this one too.

su_v (suv-lp) wrote :

'icons/inkscape.svg' is the same icon file that fails to load on win32 and osx if the SVG loader module is not found. Inkscape then should use the internal inkscape icon in 'icons/icons.svg' as fallback but fails to do so. Do you get any related console messages (GLib, gdk-pixbuf or similar) from Inkscape or the wm?

su_v (suv-lp) wrote :

renaming 'icons/inkscape.svg' was the easiest way for force Inkscape to use its internal inkscape-icon (worked on win32 and osx) - you could give that a try to see if it's really the same svg icon file that causes problems on linux/ubuntu.

su_v (suv-lp) wrote :

Maybe I'm barking up the wrong tree - could also be related to backing out the 'hicolor' icon theme from trunk - maybe not all links/files/references were restored to 'before-tango' status - would be helpful to know if this bug was present before SVN rev. 21418 (hicolor bitmap icons removed).

in 0.47~pre1-0ubuntu2 (karmic) icons return (taskbar and upperleft window)
it's close for me

In todays rawhide inkscape does not have an icon. Therefore it is hard to find the window in the application switcher.

The icon is present in the start menu and in help -> about inkscape.

See attached screenshot for more information.

[fm@thinkpad scor]$ rpm -q inkscape
inkscape-0.47-0.16.pre3.20091017svn.fc12.i686

Created attachment 367014
screenshot

gdi2k (gdi2k) wrote :

This bug is still present for me using full release version of Karmic, clean install (not updated), using the Dust theme, using Inkscape from the default repos. Screenshot attached.

su_v (suv-lp) wrote :

@gdi2k - which Inkscape version?

gdi2k (gdi2k) wrote :

From the About box in Inkscape:
Inkscape 0.47pre4 r22446, built Oct 15 2009

It's the one in the standard Karmic repos: inkscape-0.47~pre4-0ubuntu (karmic)

gdi2k (gdi2k) wrote :

Sorry, I should mention that I'm using the 64-bit version of Karmic, in case it makes a difference.

A work-around for the problem was added in package targeted for F-12:
inkscape-0.47-0.16.pre4.20091101svn.fc12

su_v (suv-lp) on 2009-11-15
tags: added: desktop-integration

This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

ScislaC (scislac) on 2009-11-24
Changed in inkscape:
milestone: 0.47 → none
andypiper (andypiperuk) wrote :

Seeing the same in 0.47pre4 on Karmic 9.10 32-bit - particularly noticeable here as I'm on a netbook and with the Maximus window manager applications appear just as single icons in the menubar, and Inkscape's is blank.

How could this bug be of low importance? It’s a typical usability defect. Imagine you have 10 applications opened (it’s not so rare in my case) and want to switch with Alt+Tab without Compiz (no preview window), how do you infer which window is Inkscape. Idem in the task list.

WvBraun (wvbraun) wrote :

I can confirm this one on Karmic 9.10 64bit upgraded from 9.04.
Inkscape was just installed from the packages and therefor is 0.47pre4.

I also think that this is not of low importance - it degrades usability as pointed out before and it looks bad.

ubby (kostas-sytske) wrote :

In Ubuntu Alpha 3 there is still no Inkscape icon on the taskbar.
Inkscape 0.47 r22583, built Dec 25 2009

su_v (suv-lp) on 2010-03-07
affects: ubuntu → inkscape (Ubuntu)
Changed in inkscape (Ubuntu):
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

Quoting from Debbugs 558720:

I believe that openbox uses the standard WM_HINTS X11 property to
decide what icon to display. Here's what an inkscape window currently
shows when i query it with xprop:

0 dkg@pip:~$ xprop WM_HINTS
WM_HINTS(WM_HINTS):
  Client accepts input or input focus: True
  Initial state is Normal State.
  window id # of group leader: 0x2400001
0 dkg@pip:~$

iceweasel, on the other hand, shows an icon, and xprop displays this
for one of its windows:

0 dkg@pip:~$ xprop WM_HINTS
WM_HINTS(WM_HINTS):
  Client accepts input or input focus: True
  Initial state is Normal State.
  bitmap id # to use for icon: 0x1c00030
  bitmap id # of mask for icon: 0x1c00031
  window id # of group leader: 0x1c00001
0 dkg@pip:~$

I believe that earlier versions of inksape used to do the same thing.

Changed in inkscape (Debian):
status: Unknown → Confirmed
gdi2k (gdi2k) wrote :

This seems to have fixed itself over the last couple of weeks for me on Ubuntu Karmic (64-bit).

Version: 0.47 r22583, built Mar 13 2010

Screenshot attached.

Alex Valavanis (valavanisalex) wrote :

@gdi2k: Did you build from source yourself? Do you still have the bug in the official Ubuntu package for Karmic? Have you tried the latest Ubuntu package for Lucid?

gdi2k (gdi2k) wrote :

My apologies, it seems it's been updated from a PPA, see attached.

I can't figure out a way of identifying which PPA the package came from - if you know, please let me know so I can point you to the right PPA.

I'll downgrade to the official Karmic version when I get home and post back in a few hours to see if the problem still exists with that.

Alex Valavanis (valavanisalex) wrote :

"apt-cache policy inkscape" should do the trick

gdi2k (gdi2k) wrote :

Didn't really provide much enlightenment;

gdi2k@x200:~$ apt-cache policy inkscape
inkscape:
  Installed: 0.47.0-1ubuntu2~ppa1
  Candidate: 0.47.0-1ubuntu2~ppa1
  Version table:
 *** 0.47.0-1ubuntu2~ppa1 0
        100 /var/lib/dpkg/status
     0.47~pre4-0ubuntu1 0
        500 http://ph.archive.ubuntu.com karmic/main Packages

I downgraded to the official Karmic version, and the icon is still there. I've been playing with a lot of theme PPAs in anticipation of Lucid, maybe something's changed there that affects this...

vjrj (vjrj) wrote :

Same issue after upgrading to Lucid:

$ apt-cache policy inkscape
inkscape:
  Instalados: 0.47.0-2ubuntu2
  Candidato: 0.47.0-2ubuntu2
  Tabla de versión:
 *** 0.47.0-2ubuntu2 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Andres Muniz (andresmp) wrote :

Icon is a white box with a blue line on top using ubuntu netbook remix ( karmic? not sure how to check this), inkscape 0.47. I think this is the same issue as all of the above.

Alex Valavanis (valavanisalex) wrote :

@Andres Type the following into a terminal to find your distribution version:

lsb_release -a

Andres Muniz (andresmp) wrote :

OK here goes!

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic

Just might go up to ubuntu 10.04 I'll post if icon changes.

summary: The small icon in the upper left corner is absent
- [inkscape_0.47~pre0-0ubuntu1~8.04_i386]
Alex Valavanis (valavanisalex) wrote :

@Andres Thanks for the info. This bug is still present in Lucid, but a few other minor fixes have been implemented.

vjrj (vjrj) wrote :

Yes it's still present in Lucid:

LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 10.04 LTS
Release: 10.04
Codename: lucid

Alex Valavanis (valavanisalex) wrote :

I just updated to 0.48, using the Ubuntu package in my PPA. Seems to be fixed. Can anyone else confirm that this is the case?

vjrj (vjrj) wrote :

Yes. It's fixed in 0.48:

apt-cache policy inkscape
inkscape:
  Installed: 0.48.0-0ubuntu1~10.04~ricotz1
  Candidate: 0.48.0-0ubuntu1~10.04~ricotz1
  Version table:
 *** 0.48.0-0ubuntu1~10.04~ricotz1 0
        500 http://ppa.launchpad.net/ricotz/ppa/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     0.47.0-2ubuntu2 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid/main Packages

Changed in inkscape:
status: Confirmed → Fix Released
milestone: none → 0.48
Alex Valavanis (valavanisalex) wrote :

This bug will be fixed in Ubuntu with the release of inkscape_0.48.0-1ubuntu1, which will appear in Maverick shortly. Please see bug #628048 for details.

Changed in inkscape (Ubuntu):
status: Confirmed → Fix Committed
Andres Muniz (andresmp) wrote :

Hi using Ubuntu netbook edition 10.04 (just did an update) with inkscape 0.47

Alex Valavanis (valavanisalex) wrote :

Fixed in Ubuntu with inkscape_0.48.0-1ubuntu1

Changed in inkscape (Ubuntu):
status: Fix Committed → Fix Released
Changed in inkscape (Debian):
status: Confirmed → Fix Released

This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we may not be able to fix it before Fedora 12 is end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora please change the 'version' of this
bug to the applicable version. If you are unable to change the version,
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Changed in inkscape (Fedora):
importance: Unknown → Medium
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.