Inkscape: A Vector Drawing Tool

Imagemagick Raster extensions not working

Reported by prkos on 2009-05-24
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

When I import an image I get this in console:

** (inkscape:29584): WARNING **: Ignoring font without family that will crash Pango

And when I try any of the Raster extensions (or the Live preview) the image doesn't change and I get this:

Caught exception: ImageMagick: no encode delegate for this image format `' @ magick/constitute.c/WriteImage/1144

Tested on build 21409, ubuntu Jaunty

jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 9.04, Inkscape rev. 21543, ImageMagick 6.4.5.4.dfsg1-1ubuntu3.1.
Tested with PNG format (same problem) and JPG (crash...).
I have lots of new problems with ImageMagick since I updated Ubuntu from 8.10 to 9.04 (I can't no longer use raster extensions with 0.46...). Do we have a dependency problem?

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.47
status: New → Confirmed
tags: added: regression
tags: added: extensions-plugins raster

Inkscape is also reported to crasj with either

--- snip ---
terminate called after throwing an instance of 'Magick::ErrorCoder'
what(): ImageMagick: no data returned `file:///home/serge/web_projects/Autorex_En/autorex/Autorex%20Picture/Autorex11.JPG'

Emergency save activated!
Emergency save completed. Inkscape will close now.
--- snip ---

or

--- snip ---
glibmm-ERROR **:
unhandled exception (type std::exception) in signal handler:
what: ImageMagick: no data returned `file:///home/serge/web_projects/Autorex_En/autorex/Autorex%20Picture/Autorex11.JPG'

aborting...

Emergency save activated!
Emergency save completed. Inkscape will close now.
--- snip ---

This is on Debian Squeeze with:

imagemagick 7:6.3.7.9
libglibmm-2.4- 2.20.0-1
libglib2.0-0 2.20.1-2

~suv (suv-lp) wrote :

see also bug #390024: I was unsure to mark it as a duplicate because on OS X, Inkscape crashes immediately whereas prkos describes a failure, not crash.

~suv (suv-lp) wrote :

bug #281637 - another duplicate?

bbyak (buliabyak) wrote :

fixed in 21703, please test

Changed in inkscape:
status: Confirmed → Fix Released
jazzynico (jazzynico) wrote :

Fix confirmed on Ubuntu 9.04.
Thanks Bulia!

~suv (suv-lp) wrote :

fix not confirmed with Inkscape 0.46+devel r21714 on OS X 10.5.7

Inkscape no longer crashes, but none of the raster effects (Extensions > Raster > …) work either. There is no entry in the undo-history after applying any of the raster extensions.

console msg when quitting:
Caught exception: ImageMagick: NoDecodeDelegateForThisImageFormat `/Users/suv/New_document_1-rect3048-591.png' @ blob.c/ImageToBlob/1327

reopening ok?

Changed in inkscape:
status: Fix Released → Confirmed
~suv (suv-lp) wrote :

Mac OS X 10.5.8 (9L30)
XQuartz 2.3.3.2 (xorg-server 1.4.2-apple42)
Inkscape 0.46+devel r22011, built Aug 7 2009

compiled with ImageMagick package installed:

LeWitt:svn suv$ port installed | grep ImageMagick
  ImageMagick @6.5.4-0_0+graphviz+gs+jbig+jpeg2+lcms+mpeg+perl+q16+rsvg+wmf (active)

Fix confirmed (SVN rev. 21703 committed by buliabyak),
still remains a build issue on OS X though (assigning to Michael Wybrow)

Changed in inkscape:
assignee: nobody → Michael Wybrow (mjwybrow)
status: Confirmed → Fix Committed
~suv (suv-lp) wrote :

Moving the open raster extension issue on osx to (duplicate) bug #390024, closing this bug as 'Fix released' per SVN rev. 21703 committed by buliabyak.

Changed in inkscape:
assignee: Michael Wybrow (mjwybrow) → nobody
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers