After ungrouping or decoupling a clone blur is no longer shown but style attribute still present.

Bug #304407 reported by Jaspervdg on 2008-12-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Krzysztof Kosinski

Bug Description

Open filters-gauss-01-b.svg from the test suite in SVN (https://inkscape.svn.sourceforge.net/svnroot/inkscape/gsoc-testsuite/tester/testcases/svgtestsuite-1.1/filters-gauss-01-b.svg). Select the main group (just click on the drawing) and ungroup. Now suddenly no blur is shown(!) anymore. However, the style attribute referencing the filter is still present on the clones...

Even pressing undo does not make the blur reappear. Saving and reloading does make the blur appear again.

After having saved and reopened (so the blur is visible again), decouple one of the clones, again no blur is shown. And again saving and reloading makes it appear again.

Splex (splex) wrote :

I believe the issue has to do with the grouping function not triggering a refresh of the filter rendering.

Once an object is either grouped or ungrouped, all filter(s) in the group/selection are no longer rendered. Once the objects are translated, a rendering refresh of the filters is triggered and the filters are again displayed correctly.

Even without triggering the refresh, bitmap exports display the filtered object correctly.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9108 on OS X 10.5.8

tags: added: filters-svg renderer
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Jon Grossart (jon-grossart) wrote :

This bug is still present in 0.48.2 (win 32), although I found it another way.

1. create a group of objects
2. clone that group
3. apply a filter to the clone
4. group the original and the clone
5. watch the filter disappear

You can also bring the filter back by unapplying and then reapplying the filter.

I'm a little surprised this bug is still around after ~3 years. Is it cleaned up with the new Cairo version?

ScislaC (scislac) wrote :

It appears to be different now in trunk w/ the cairo renderer... I did your steps to reproduce and the filter did not disappear on step 5., instead the object did. I entered the group, selected the visible original object, hit tab and it selected the filtered clone object and I noticed that both fill and stroke were "unset", I added a fill color and it turned that color and was still filtered. Bizarre behavior indeed.

jazzynico (jazzynico) wrote :

Original bug (objects disappear after ungrouping) still reproduced on Windows XP, trunk revision 12380.

The steps from comment #3 are a bit different, and are probably due to the same (slightly different) bug already reported in Bug #243729 "Grouping filtered text objects loses rendering of filter effects".

Changed in inkscape:
status: Confirmed → Triaged
Krzysztof Kosinski (tweenk) wrote :

Fixed in 12648.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
status: Triaged → Fix Committed
su_v (suv-lp) on 2013-10-01
Changed in inkscape:
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
su_v (suv-lp) wrote :

Follow-up report (new regression with rev >= 12468):
- Bug #1425542 “Filter applied on group does not auto redraw when edited”
  https://bugs.launchpad.net/inkscape/+bug/1425542

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers