Filter applied on group does not auto redraw when edited

Bug #1425542 reported by Alvin Wong on 2015-02-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Wong

Bug Description

If a filter is applied on a group (including Inkscape Layers, which can be done by manually adding the style with XML Editor), editing the filter does not update the rendering of the group unless the filter is reapplied manually, or toggling the visibility of the layer (can be the layer itself which the filter is applied on).

Example steps to reproduce:

1. Draw two shapes.
2. Group the two shapes.
3. Create a filter in the "Filter Editor" and add a "Flood" effect. (The group should be filled with the flood colour but this doesn't happen immediately.)
4. Hide and unhide the current layer to see the filter effect applied.
5. Change the "Flood Color". (The rendered colour should change but doesn't.)

Also affects objects like 3dboxes (internally stored as group containing 6 paths) when merging multiple preset filter effects (see duplicate bug #1435078).

Affects versions: rev >= 12648 (inc. 0.91)
Regression introduced on: rev 12648 http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12648

Alvin Wong (alvinhochun) on 2015-02-25
summary: - Filter applied on group does not auto update when edited
+ Filter applied on group does not auto redraw when edited
su_v (suv-lp) wrote :

Reproduced on OS X 10.7.5 with 0.91 r13725 and 0.91+devel r13941;
tests with archived builds confirm that the regression seems to be a side-effect of r12648 (fix for bug #304407).

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
tags: removed: ui
su_v (suv-lp) on 2015-02-26
Changed in inkscape:
milestone: none → 0.92
Alvin Wong (alvinhochun) wrote :

Apparently, reverting the changes to `sp-item-group.cpp` (https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12648/src/sp-item-group.cpp) is enough to fix this bug. Tested on 0.91 Windows 64-bit.

su_v (suv-lp) wrote :

Attaching the proposed change as diff against trunk r13950 to ease further testing.

su_v (suv-lp) wrote :

Patch tested successfully with 0.91+devel r13950 on OS X 10.7.5; so far, no regressions noticed when testing against the 'steps to reproduce' provided in bug reports known to have been fixed by r12648:
Bug #243729 “Grouping filtered text objects looses rendering of filter effects”
Bug #304407 “After ungrouping or decoupling a clone blur is no longer shown but style attribute still present.”
Bug #930593 “Grouping/ungrouping of filtered objects (groups|texts|clones) makes them disappear temporarily”

Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) wrote :

<off-topic>
Detail likely not really relevant to this report (bug #1425542): when repeating the steps to reproduce mentioned in comment 4 (e.g. group an object (a clone, or a text) and its blurred clone), Inkscape 0.91+devel r13950 (with or without patch) produces this console message:

** (inkscape:62042): CRITICAL **: void SPObject::requestModified(unsigned int): assertion 'this->document != NULL' failed
</off-topic>

su_v (suv-lp) on 2015-03-24
description: updated
jazzynico (jazzynico) on 2016-08-28
Changed in inkscape:
status: Triaged → In Progress
assignee: nobody → jazzynico (jazzynico)
jazzynico (jazzynico) wrote :

Fixed in the 0.92.x branch (rev. 15051) and trunk (rev. 15083).
Credit to Alvin (fixed thanks to his comment #2).
Thanks:!

Changed in inkscape:
assignee: jazzynico (jazzynico) → Alvin Wong (alvinhochun)
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers