incorrect locking/unlocking -- unlocking the layer locks the group which was choosen to be active

Bug #304251 reported by Yaroslav Halchenko on 2008-12-02
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

I found few groups locked without me ever locking them -- I was locking/unlocking the layers to which they belonged, but at the end, I resulted with some groups being locked (insensitive).

After I have created an example and presented it within IRC, mahfiaz summarized it as " the problem is that somehow when you save the file, the inner-group is selected and therefore it will be active when opening, when you then click the locking button, it is applied to the group not layer", but I think it is a bit different: it does unlock the layer, but also it locks the group which was set to be active layer in the .svg file, but as mahfiaz figured it out -- it is related to the content of current-layer upon opening

So, if you open attached file (in which insensitive set ONLY for the layer) in which inkscape:current-layer="g3550", and try to unlock 'Datasets' layer, you would end up with locked g3550 group (and layer itself and other elements than that group being unlocked). You can verify that in builtin XML browser or saving the file and grepping for insensitive.

thanks in advance for fixing it!!

Yaroslav Halchenko (yarikoptic) wrote :
mahfiaz (mahfiaz) wrote :

I reproduced this, at least part of the problem.
If anyone tries to reproduce this, and finds the explanations too messy to follow, just ask for explanation.

Changed in inkscape:
importance: Undecided → Low
jazzynico (jazzynico) wrote :

Tried to reproduce it with 0.46 and dev build, but when I open the attached file, g3550 is already locked...

right -- it is locked upon opening since the layer is locked (there is
no explicit insensitive for that group within .svg)... just
follow my original description and unlock the layer -- then you will
find that the g3550 gets is insensitive True set anyways

On Fri, 08 May 2009, JazzyNico wrote:

> Tried to reproduce it with 0.46 and dev build, but when I open the
> attached file, g3550 is already locked...
--
Yaroslav O. Halchenko
Postdoctoral Fellow, Department of Psychological and Brain Sciences
Dartmouth College, 419 Moore Hall, Hinman Box 6207, Hanover, NH 03755
WWW: http://www.linkedin.com/in/yarik

su_v (suv-lp) on 2011-10-01
tags: added: groups layers
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.47, 0.48.0 and 0.48.1
Not reproduced with Inkscape 0.48.2 and current trunk (r10635).

See also:
Bug #863974 "elements no longer available for selection"
Bug #845844 "Groups not selectable - turned insensitive (locked) without using object properties dialog"

Closing as 'Fix Released' with milestone 0.48.2 (even though I do not know which commit did change this behavior) - please reopen if you don't agree or if this issue reoccurs with the latest stable release.

Changed in inkscape:
milestone: none → 0.48.2
status: New → Fix Released
der_lunz (christian-kapeller) wrote :

It seems (part of) this issue still exists:

OS: Ubuntu 16.04 x64
Repo-URI: http://ppa.launchpad.net/inkscape.dev/trunk/ubuntu/
Version: 1:0.92.0+devel+1574 amd64

Locking a group of objects using [right-click/'Lock selected objects] locks a group. An attempt to unlock the same group [right-click/'Unlock objects below] fails.

- 'Lock group' sets 'sodipodi:insensitive':true on this group.
- 'Unlock objects below' neither removes nor toggles the same attribute.

Manually removing the 'sodipodi:insensitive' property in the XML Editor does unlock the group, which is the expected behaviour.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers