No raster resolution options for PDF save

Bug #246677 reported by reader4 on 2008-07-08
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

Other bugs (242484, 168434) have hinted at this problem but have not addressed it entirely. It would be beneficial to have a resolution limit on PDF outputs that contain raster images linked from the original SVG. It appears that this is possible with PS via Cairo, but not PDF. The utility is that screen-ready version (raster images at <= 90dpi) that is easy to distribute electronically can be saved alongside a print-ready version (raster images at 300dpi) that might be much larger in size.

jazzynico (jazzynico) wrote :

0.47 has a new PDF exporting option called "Resolution for rasterization (dpi)" that will probably fit your needs.
Please comment if it's not the case.

Changed in inkscape:
importance: Undecided → Wishlist
milestone: none → 0.47
status: New → Fix Committed
tags: added: exporting pdf
Risto H. Kurppa (risto.kurppa) wrote :

Awesome, pulling nightly build from PPA because of this. THANKS!

ScislaC (scislac) on 2009-11-24
Changed in inkscape:
status: Fix Committed → Fix Released
Ponchietto (ponchio) wrote :

I'm afraid the bug (missing feature) is still there:
the rasterization process is not applied to images unless some filtering is applied.

A workaround is to apply an "Identity filter" for example an identity color matrix,
setting Rasterized filter effects to true, of course.

Kence (cpeel) wrote :

I changed the status to Confirmed instead of Fixed because as Ponchietto mentioned in #3 - the raster image downsampling is only available if a filter has been applied to an image, not for every raster image.

Changed in inkscape:
status: Fix Released → Confirmed
su_v (suv-lp) on 2010-04-17
Changed in inkscape:
milestone: 0.47 → none
Granjow (simon-eu) wrote :

I'd be very happy if you fix this bug. Just exported a small half-postcard sized PDF with an image and received a 53 MB PDF :D

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers