Grouping filtered text objects loses rendering of filter effects

Bug #243729 reported by Textureglitch on 2008-06-28
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I'm on WinXP SP2 Inkscape 0.46, built Apr1 2008

Creating some text and grouping it with some other blurred text removes the blur. This bug doesn't seem to occur when grouping other kinds of objects or paths, only when the type is text.

Workarounds seem to be to move the group and then move it back, or to change the blur value and then change it back.

This appears to be a duplicate of Bug #168906, but that report is confusing to me. The title is correct, but the actual bug report is about Inkscape crashing and the real description seems to appear in comment no. 4. It looks like the title was changed later.

I'd recommend closing Bug #168906 since the crash issue was resolved.

sas (sas-sas) wrote :

Confirmed. I would close the other bug report, except that it's assigned to someone.

The bug occurs even if you just group the blurred text on its own (as a group of 1 object).

> Workarounds seem to be to move the group and then move it back

Or move it and then undo (Ctrl+Z).

Notice that ungrouping also loses the blur (and the same workaround applies).

Changed in inkscape:
status: New → Confirmed
importance: Undecided → Medium
Esther (melanes) wrote :

Bug and work around confirmed on Ubuntu Intrepid 8.10 build 10-24-08

tags: added: groups
removed: grouping ungroup

I am seeing this with Inkscape 0.47 and Vista SP2 64-bit.

I know of two more workarounds:

1. Turn the filter off and then back on for the object
2. Apply the filter and then turn it off for the group

su_v (suv-lp) wrote :

reproduced with Inkscape 0.47 on OS X 10.5.8. Bug is not limited to blur - it happens with other/predefined filters as well.

tags: added: filters-svg
jazzynico (jazzynico) on 2010-05-15
summary: - Grouping blurred text removes blur
+ Grouping filtered objects removes filter
su_v (suv-lp) on 2010-05-20
summary: - Grouping filtered objects removes filter
+ Grouping filtered text objects looses rendering of filter effects

Reproduced on Ubuntu 10.10, Inkscape 0.48.0-1ubuntu1.2 and trunk revision 10444 (new Cairo renderer).

Łukasz Remiś (lukas-remis) wrote :

Reproduced on Ubuntu 10.04, Inkscape 0.48.1 r9760

su_v (suv-lp) wrote :

Still present with the new renderer (tested with r10626 on Mac OS X 10.5.8), though slightly different (worse): The filtered text objects disappear after grouping (or ungrouping), and are partially visible (including the filter effects) when e.g. moving the group, or the ungrouped text objects.

Also affects clones of text objects.

Jon Grossart (jon-grossart) wrote :

Bug 304407 would seem to be a dupe of this one,.

ScislaC (scislac) on 2012-12-10
Changed in inkscape:
milestone: none → 0.49
tags: added: blocker
summary: - Grouping filtered text objects looses rendering of filter effects
+ Grouping filtered text objects loses rendering of filter effects
jazzynico (jazzynico) wrote :

Still reproduced on Windows XP, Inkscape trunk revision 12380.

Changed in inkscape:
status: Confirmed → Triaged
Martin Owens (doctormo) wrote :

* Moving text with blur to another layer exhibits the same issue
* Text already in a group, but regrouped exhibits the same problem
* Using the node tool, moving the text node at all exhibits the same problem
* Using undo for any operation (the move the text node back) does not restore, might exhibit the same issue if it could be seen
* Changing any attribute in the text node will bring it back

Conclusion: This isn't about selection, grouping or the actual verb in question. But is a more general re-rendering issue for text nodes that are moved. Possibly there is some extra call that is missing in the reordering event, but present in the attribute event.

Investigation continues.

Martin Owens (doctormo) wrote :

Further digging shows a very interesting effect. Moving the text by a short distance using the arrow keys looks normal. But if you start moving the blured text using shift+arrow, you'll start to see bits getting cropped off. Now if you move the text half to the right, one half down, you'll notice that only one quarter of the text is shown.

This looks very much like a bounding box error. It's unclear if this bounding box problem is the same as this node-add issue, but it could be. I wildly speculate that the rendering mechanism is attempting to get the bbox for the old position/node. Which won't work for node-add since that old node no longer exists.

Investigation continues...

Martin Owens (doctormo) wrote :

Further note: the above happens with blurred text regardless of group or ungroup.

Testing the text nodes without blur, but setting their position via xml to rule out mouse move events, shows that this text is rendered correctly. It's looking more like the text rending and filters are interacting out of order. Perhaps before the text node has it's bounding box updated.

Martin Owens (doctormo) on 2013-09-17
Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: Triaged → In Progress
Martin Owens (doctormo) wrote :

The movement bug mentioned above is fixed and confirmed not a part of this bug.

Martin Owens (doctormo) wrote :

Breakthrough: The filtered items are getting killed in Filter::render because they don't have a resolution. Finding fix.

Martin Owens (doctormo) wrote :

Fixed, see r12528, I'm getting more information on the implications of the fix but this bug is done.

Changed in inkscape:
status: In Progress → Fix Committed
Kris (kris-degussem) on 2013-09-23
tags: removed: blocker
Krzysztof Kosinski (tweenk) wrote :

A more correct fix is in r12648.

Changed in inkscape:
assignee: Martin Owens (doctormo) → Krzysztof Kosinski (tweenk)
Martin Owens (doctormo) wrote :

I'm mildly annoyed, my fix at Layout-TNG-Output.cpp:186 is still relevant; although I see you're setting the filter bbox for both inner and outer text pieces.

Changed in inkscape:
assignee: Krzysztof Kosinski (tweenk) → nobody
Inkode (krish22526) wrote :

I am using Inkscape Version 0.48.

Issue : Grouping works great, but say one text object is blurred, the other not, when I group these two, the blue effect goes off and the objects simply are grouped.

Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions