Inkscape: A Vector Drawing Tool

Make POT file easily available and up-to-date

Reported by Martin Srebotnjak on 2007-12-29
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Marcin Floryan

Bug Description

Most translators are not coders or computer geeks. A lot of us use simple tools like Poedit.
For this, we need a POT file to update our po files to continue translating.

Inkscape provides this POT file at the following adress:
http://inkscape.modevia.com/potfile/inkscape.pot

Although page http://inkscape.org/wiki/index.php/InterfaceTranslation#Interface_Translation
states, that it is updated on a weekly basis, it hasn't been updated since end of October! I would like to update Slovenian translation, now that you mention several new functionalities have been added to Inkscape in the last weeks, which probably means, there will be many new strings. I don't want to translate a day before (or a week after) the release date.

I propose you generate the POT file daily and keep it in the tree with other PO files. Then everything else would be a piece of cake for the translators (we would have a fixed link and just download the POT when we need the update).

Thanks,
m.

Bryce Harrington (bryce) on 2007-12-30
Changed in inkscape:
assignee: nobody → aaron-ekips
Aaron C Spike (acspike) wrote :

Including generated files in the tree causes a few specific annoyances, such as merge conflicts, which interfere with development. I've updated the file at the link and will once again begin to keep update it weekly. Sorry for the lapse. I think a better solution would be to move the file to inkscape.org and perhaps even generate the file with a cronjob on that server so that it no longer requires manual intervention.

Changed in inkscape:
status: New → In Progress
Bryce Harrington (bryce) wrote :

Aaron, if you can detail the steps needed for doing this, I can take care of setting it up on inkscape.org

Changed in inkscape:
importance: Undecided → Medium
status: In Progress → New
Aaron C Spike (acspike) wrote :

My script to do this looks something like:
cd /path/to/inkscape_svn
svn up
./autogen.sh
./configure
make clean
cd po
intltool-update --pot
cd ..
cp po/inkscape.pot /path/to/webroot/inkscape.po

Now I'm not sure if the autogen and configure steps are needed because I extracted this from a script that both built autopackages and generated this file. And yes I do have this scripted, but the manual intervention comes in when I have to turn my computer on. :-)

Martin Srebotnjak (miles) wrote :

Bryce,

on the main Inkscape webpage you state that Slovenian is 98% translated, but according to the available pot file it is 100% complete, so do not "lie" ;) :)

Unless someone will update the pot file - remember, all translators at this moment can translate only up to 98% because the pot file is old ... Unless they are programmers and download the whole cvs and do the gettext mumbo jumbo. I am sure not going to do this ...

So - to get the translation stats up - get the pot file automagically fresh and crispy, and we will do the translating! Also, around four links must be clicked from the main page to get to the pot file link, maybe you can put this page a bit higher in hierarchy (I know, I can make a bookmark of it, but still ...).

Thanks, m.

Aaron C Spike (acspike) wrote :

I can't fullfill my obligation to generate the potfiles right now. My linux box died this weekend. :-(

Bryce,
Any progress on moving this to inkscape.org?

Bryce Harrington (bryce) wrote :

Thanks Aaron, I'll take the bug. I'm not sure I'll have time to work on this before the release, but we'll see.

Changed in inkscape:
assignee: acspike → bryceharrington
status: New → Confirmed
Martin Srebotnjak (miles) wrote :

The release is nearing, maybe string freeze has arrived, but the pot file available was last updated last year. I cannot move Slovenian over 98%.

Thanks, m.

Luca Bruno (lucab) wrote :

No, we aren't yet in the string freeze, we'll announce it to translator when it's time.
I've put latest inkscape.pot here: http://www.unstable.it/luca/inkscape.pot I'll try to keep it update, even if I'm quite busy now.

Bryce Harrington (bryce) wrote :

Sorry, I wasn't able to get to this for the release. Unassigning myself so someone else can take a shot at it.

Changed in inkscape:
assignee: bryceharrington → nobody
Martin Srebotnjak (miles) wrote :

Any news on this one?

Marcin Floryan (mfloryan) wrote :

I will set up a little job to generate .pot file regularly and can publish it on my server.

Changed in inkscape:
assignee: nobody → mfloryan
Marcin Floryan (mfloryan) wrote :

Bryce, Is there an easy way to upload the generated inkscape.pot file to inkscape.org - I suppose I could do it simply via SVN? Any preferences? What URL should this be published. Obviously there needs to be one for 0.46 and one for 0.47.

Rygle (rygle) wrote :

Is this a duplicate of 220739??

Marcin Floryan (mfloryan) wrote :

No, it is not. This one is about providing an up-to-date inkscape.pot whereas the #220739 is about updating the POTFILES.in

Kris (kris-degussem) wrote :

I still did not see a place where to find an accurate po template file.
I would be willing to generate and commit a new pot file, if appropriate.
In attachment the pot-file de dato March 1, 2009, which I am using now to work further on the Dutch translations. Is it possible to place it for instance in the trunk/po directory?

jazzynico (jazzynico) wrote :

Thanks to Alexandre Prokoudine, inkscape.pot is now updated weekly in SVN.

Changed in inkscape:
status: Confirmed → In Progress
Martin Srebotnjak (miles) wrote :

Ok, that is first step. Can you now make a direct link to this file or its copy, and post it in the translation documentation of the Inkscape website? Even though it is a file in SVN and the link might change, maybe you can copy this file weekly to a fixed location?
This way the translator just bookmarks this direct link and downloads the pot file whenever needed.
Thanks.

Kris (kris-degussem) wrote :

This bug could be closed as the pot-file is frequently updated now and available at:
http://inkscape.svn.sourceforge.net/viewvc/inkscape/inkscape/trunk/po/inkscape.pot?view=log

Changed in inkscape:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers