Inkscape: A Vector Drawing Tool

group colour/color changes, brightness, contrast, HSV, more

Reported by naught101 on 2006-02-27
30
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

it would be awesome if it was possible in inkscape to
select a whole bunch or differently styled objects and
change the colours of all of them at once.

for example, I have hundreds of differently coloured
dots all over the page, and I want to change the all to
grey scale. all this would need is a script that would
find the colour values for each part of each object
(fill, stroke, gradient points, etc.) and reduce the
saturation to 0, while retaining the value.

similar things could be done by manipulating the Hue
(whoa, man, rainbows), or the Value (light/dark), or
the brightness (same? dunno), or the contrast (this
would be helpful).

some more cool things could surely be added. probably
the best idea would be to have a look at the Gimp's
Layers >> Colors menu.
that has lots of cool thing that would be extremely
useful in inkscape.

Jon A. Cruz (jon-joncruz) wrote :

Or an alternate approach might be to deal with named styles. Then have all

items set to that style and just change its definition in one place.

Bug Importer (bug-importer) wrote :

thats nice

Jon A. Cruz (jon-joncruz) wrote :

Closing "[ 1512342 ] HSV controls for selection" as a
duplicate of this RFE.

http://sourceforge.net/tracker/index.php?func=detail&aid=1512342&group_id=93438&atid=604309

naught101 (naught101) wrote :

joncruz: I also thought about that, but that would be a much
more limited way of doing it, as all the objects would need
the same style.

this way, you could have a blue object, and a red object,
and lighten them both at the same time.

what you're suggesting wouls also be very useful for a lot
of other things though - perhaps it should be a separate
feature request?

Bug Importer (bug-importer) wrote :

Or the effects you can apply to a Graphic/Movie Clip symbol
in Flash.

Change Alpha: already implemented through master opacity
Add tint: add a certain amount of a certain color to all the
objects in the group
Advanced: let's you basicly add/substract and/or multiply
each part of the color(RGBA) by a certain number and applies
it to all sub objects/paths.

things like this would be very useful. right now i am
exporting all my SVGs into PNGs and having a GIMP script
turn them greyscale because i used images from the Open
Clipart Library as backgrounds and there was no way to turn
them greyscale...

Hystrix (hystrix-) on 2007-12-20
Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
Popolon (popolon) wrote :

Duplicate of #170739
https://bugs.launchpad.net/inkscape/+bug/170739

Gnuplot (4.2.2) SVG output uses (only) group tag for style, the path should inherit from it's properties, at least if they don't have style. rsvg and gecko manage them, not inkscape, that's an issue to solve that could help for this bug too.

 http://www.w3.org/TR/SVG11/struct.html#InterfaceSVGGElement

An exemple of gnuplot output :

~suv (suv-lp) wrote :

The 'Color' extensions [1] implement most the requested features:
- Grayscale
- Desaturate
- Brighter/Darker
- Less/More Light
- Less/More Hue
- Less/More Saturation
(These extensions allow to lower or increase the hue, saturation and light of a selection, but not to choose the amount, and thus still can be improved).

…as well as other functions based on RGB values:
- Custom: transformation functions can be defined for R, G and B
- Negative
- Remove Red/Green/Blue
- Replace
- RGB Barrel

Additionally preset 'Color' SVG filter effects [2] add further options to manipulate the color of selected (bitmap and) vector objects.

Proposing to close the report as 'Fix Released' (the color extension scripts had been added in Inkscape 0.45, 2007-03-20 [3]).

[1] <http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Extensions-Color.html>
[2] <http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Filters-Preset-Color.html>
[3] <http://wiki.inkscape.org/wiki/index.php/Release_notes/0.45#New_effects>

mycae (mycae) wrote :

Hmm. The less/more hue is not very useful.

A hue rolling computation would be good: but only if there was an interactive mode. I came across this today, I had a lot of green objects that I wanted to keep the same saturation and value, but I wanted to interactively roll the hue, and observe the result.

hue+=rollValue;
hue=modulo(hue,1); //assume colour hue is mapped in f.p 0->1 (HSV))

This kind of computation can be done over groups of objects, in the same manner that you would do it in groups of pixels (think gimp's HSV sliders, or CMY colour balance tool)

~suv (suv-lp) wrote :

Related:
New module added in trunk for 'Extensions > Color': HSL Adjust
Allows to modify selection (or drawing) by adjusting Hue (360°, wraps around), Saturation (%) and Lightness (%)

Bug #979208 “New: Extensions > Color > HSL Adjust”
<https://bugs.launchpad.net/inkscape/+bug/979208>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers