wrong PDF export with rectangles

Bug #168275 reported by Pablo Rodríguez
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

Hi there,

in the attached file, you have two black rectangles with no stroke and
210mm height. Both are set to 0 in the Y axis. inkscape displays them
fine.

But when exporting to PDF (using inkscape-0.45pre1 + cairo-1.3.12, just in
case it would be relevant), Both rectangles aren't set to 0 in the Y axis
(they seem to be set to 1 or something similar).

Thanks for your help,

Pablo

Related branches

Revision history for this message
Pablo Rodríguez (ousia) wrote :
Revision history for this message
Pablo Rodríguez (ousia) wrote :

Originator: YES

File Added: ccover.pdf

Revision history for this message
Buliabyak-users (buliabyak-users) wrote :

Originator: NO

mental, please have alook at this one too

Revision history for this message
Buliabyak-users (buliabyak-users) wrote :

Originator: NO

actually, i don't see any difference btween pdf and svg. what exactly is
this problem?

Revision history for this message
Pablo Rodríguez (ousia) wrote :

Originator: YES

If you zoom at maximum and you view position 0,0 in the PDF file, you will
see a white line which is not there on the SVG file.

Revision history for this message
Bug Importer (bug-importer) wrote :

A single rectangle would be a better example..
---
<svg
   width="101"
   height="101">
  <rect
     width="100"
     height="100"
     x="0.5"
     y="0.5"
     style="fill:#550000;stroke:#003855;stroke-width:1" />
</svg>
---

Export to Pdf and zoom in at the top and bottom. You will see the phantom
white line at the bottom and that the top border is too thin. The error
clearly sits in the coordinate change (and probably does so in other
exporters as well since i used the internal pdf writer and the bug reporter
attached a cairo pdf)

Here are the important lines:

/MediaBox [ 0 0 80.80000305 80.80000305 ]
stream
0.8 0 0 -0.8 0 81 cm

The 81 should be 80.8

/Ulf

Revision history for this message
Peter Lewerin (vermeil-deactivatedaccount) wrote :

I'm setting this to confirmed in accordance with <URL http://wiki.inkscape.org/wiki/index.php/BugTriageProjects>.

Changed in inkscape:
status: New → Confirmed
Revision history for this message
Tom Davidson (tjd-mit) wrote :

posibly a dupe of/related to bug 168957?

Revision history for this message
Ckemmer (ckemmer) wrote :

I think it is related to bug 168957, not exactly a duplicate.

jazzynico (jazzynico)
tags: added: exporting pdf
Revision history for this message
theAdib (theadib) wrote :

is this issue still existing?

Revision history for this message
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.46+devel r22240 on OS X 10.5.8 (cairo 1.8.8) when exporting above attached file <http://launchpadlibrarian.net/10578544/ccover.svgz> to PDF.

Could bug #385267 be related?

theAdib (theadib)
tags: added: cairo
Revision history for this message
su_v (suv-lp) wrote :

related reports:
Bug #168957 “export to PDF leaves white gaps between rects”
Bug #169048 “White gaps around rectangles in PS/PDF”
Bug #385267 “y-position of bitmaps (linked or used as patterns) is changed in PDF export ”

Revision history for this message
Johan Engelen (johanengelen) wrote :

extra detail: bug shows when exporting with export-area-page. It does not show when export-area-drawing is set.

Revision history for this message
Johan Engelen (johanengelen) wrote :

For some reason, there was a "ceil" on the document's height and width in the cairo exporter (pdf/eps/ps). I removed it, and now the white line at the bottom is gone. (r9306)
Can someone confirm this indeed fixes the issue and now the positioning is accurate?

I cannot see why the "ceil" was added, since the svn history got gobbled...

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: Mental-users (mental-users) → Johan Engelen (johanengelen)
Changed in inkscape:
milestone: none → 0.48
Revision history for this message
su_v (suv-lp) wrote :

fix (committed in revision 9306) confirmed with Inkscape 0.47+devel r9307 on OS X 10.5.8

jazzynico (jazzynico)
Changed in inkscape:
status: Fix Committed → Fix Released
freddy zee (freddy79)
Changed in inkscape:
assignee: Johan Engelen (johanengelen) → freddy zee (freddy79)
su_v (suv-lp)
Changed in inkscape:
assignee: freddy zee (freddy79) → Johan Engelen (johanengelen)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers