Inkscape: A Vector Drawing Tool

Changing layer order does not update layer selector

Reported by Dwyip on 2005-07-11
38
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
John Smith

Bug Description

When adding a new layer and changing its z-order, the
new layer's position is not correctly represented in
the layer selection box (in bottom status bar); it
remains in its old location. Activating the layer
selection box a second time causes the correct order to
be shown.

Dwyip (dwyip) wrote :

I should clarify the procedure:

- Add a new layer.
- Change the layer order.
- Check the layer selection box.

Rwst (rwst) wrote :

Clearly confirmed. I can't even get to the correct state in the selection
box.

Jon A. Cruz (jon-joncruz) wrote :

It appears that all the layer cleanup has corrected this.

~suv (suv-lp) on 2009-10-20
tags: added: layers
removed: linux
Pablo Trabajos (pajarico) wrote :

This has reappeared in 0.47pre4. I've set bug #306314 as duplicate of this one because it's newer and it is the same problem, only updated.

Changed in inkscape:
status: Fix Released → Won't Fix
status: Won't Fix → In Progress
Lawrence (annon0m0s) wrote :

This bug is still happening in 0.47 released "Inkscape 0.47 r22583, built Nov 21 2009".

~suv (suv-lp) wrote :

reproduced with Inkscape 0.47 on OS X 10.5.8
changing status back to 'Confirmed' as there has been no documented work 'In Progress' since 2006-05-26

Changed in inkscape:
status: In Progress → Confirmed
John Smith (john-smithi) wrote :

Should be fixed by commit r11692.

When reordering layers (from the Layers menu or keyboard Ctrl+Shift+PgUp, or DnD in the Layers dialog), the layers selector seems to be updating correctly.

Changed in inkscape:
assignee: Jon A. Cruz (jon-joncruz) → John Smith (john-smithi)
status: Confirmed → Fix Committed
John Smith (john-smithi) on 2012-09-22
Changed in inkscape:
status: Fix Committed → In Progress
John Smith (john-smithi) wrote :

Further commit r11709 should complete the fix.

Changed in inkscape:
status: In Progress → Fix Committed
~suv (suv-lp) on 2012-09-27
Changed in inkscape:
milestone: none → 0.49
~suv (suv-lp) wrote :

Follow-up report:
Bug #1066543 “Performance regression with layers in trunk”

John Smith (john-smithi) wrote :

Committed r11883.
Reverting this fix due to issues (Bug #1066543 and Bug #1080378).

Changed in inkscape:
status: Fix Committed → Confirmed
~suv (suv-lp) wrote :

Removing milestone based on [1]: better fix would require major refactoring of the layer selector.

---
[1] <https://bugs.launchpad.net/inkscape/+bug/1066543/comments/2>

Changed in inkscape:
milestone: 0.49 → none
yagolf (yagonuchera) wrote :

I think I can confirm bug in Inkscape 0.48+devel r on Linux Mint 13 Maya (Gnome Shell)

The way I found I can reproduce the bug is by manually dragging a layer to the bottom to reorder its z-index. The layer list does get reordered but in reality the layer in question keeps its original z-index. Clicking on the arrow to "lower the current layer to the bottom" fixes it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers