Copy & paste of group with shaped path corrupts it, in v0.92

Bug #1656527 reported by Ratatosk on 2017-01-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jabiertxof
0.92.x
Medium
Jabiertxof

Bug Description

This bug is new to v0.92, never saw it in 0.91.

Steps to reproduce:

1. Start Inkscape 0.92 (with a fresh document)
2. With pen or bezier tool create a path with a shape (path effect), e.g. ellipse.
3. Group it with some other object(s).
4. Copy and paste the group. Looks good. But...
5. Ungroup or try to edit the shaped path and watch disaster strike.
   (If editing before ungrouping, the path effect is gone
    and replaced by lots of extra nodes around the shape of it.
    If ungrouping directly, the shape is just gone.)

Oddly, if the shaped path is NOT in a group, copy and paste seems to work flawlessly.

Tried with Inkscape version 0.92.0+66 for Ubuntu (both 14.04 and 16.04).

________________________________________

Maybe this is somehow related to bug 1656093. Copying and pasting of path effects is clearly problematic in Inkscape 0.92.
What I think makes this bug particularly devious, though, is you get no warning anything went wrong with your pasted group, and that you now have corrupted objects – until you ungroup or try to edit the shaped paths.

Related branches

jazzynico (jazzynico) wrote :

Reproduced on Windows XP (32-bit), lp:inkscape/0.92.x rev. 15318.
You don't need to group with other objects. The same issue can be reproduced if you just group the object alone (for faster reproduction).

As for bug #1656093, the console shows the following message when copying the group:
----
WARNING **: Unknown LPE type specified, LPE stack effectively disabled
----

Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
importance: Undecided → Medium
milestone: none → 0.92.1
status: New → Triaged
Jabiertxof (jabiertxof) wrote :

This fix the bug related to clipboard.

Changed in inkscape:
status: Triaged → In Progress
Jabiertxof (jabiertxof) wrote :

Fixed in trunk in r.15426 and in 0.92.x in r.15325

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2017-01-21
Changed in inkscape:
milestone: 0.92.1 → 0.93
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers