End marker/start marker drop-down menus are empty

Bug #1638373 reported by Jakub Krajniak on 2016-11-01
146
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
inkscape (Ubuntu)
Medium
Mattia Rizzolo
Yakkety
Medium
Mattia Rizzolo
Zesty
Medium
Mattia Rizzolo

Bug Description

[ Impact ]
The dropdown menus for start marker, end marker and mid markers do not contains any arrows to select. I have clean up all local settings and run inkscape fresh but the same problem.

This is caused by scour being called during the build, a change inadvertently added in the 0.91-11 upload. The fix used it to just not call scour.

[ Test case ]
Compare the file /usr/share/inkscape/markers/markers.svg from the built package with upstream's http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_91_BRANCH/download/nicoduf%40yahoo.fr-20110829175757-0rzahc4xhhr2l6u5/markers.svg-20091128124040-aej0x7yhxng1m6ly-449/markers.svg - it should be at the very least equivalent (if not equal), currently it contains only comments.

[Regression Potential]
noe really

Seen in in:

- Inkscape 0.91 r13725 on Ubuntu 16.10
- Inkscape 0.91-11 r13725 on Ubuntu 16.10 (official package from yakkety)
- DistroRelease: Ubuntu 16.10, Package: inkscape 0.91-11
- Inkscape 0.92, ubuntu 16.04 LTS
- Ubuntu 16.04 - upgrade today to 0.92
- Kubuntu 14.04, and recently updated Inkscape to version 0.92.0

Jakub Krajniak (jkrajniak) wrote :
Hachmann (marenhachmann) wrote :

Something is really odd about Inkscape on Ubuntu 16.10. In the answers section, there was someone who didn't have all the filters available anymore after an upgrade...

@Jakub: Can you compare your file at /usr/share/inkscape/markers/markers.svg with this file (sorry for long link):

http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_91_BRANCH/download/nicoduf%40yahoo.fr-20110829175757-0rzahc4xhhr2l6u5/markers.svg-20091128124040-aej0x7yhxng1m6ly-449/markers.svg

That's the one that *should* be in that location.

Jakub Krajniak (jkrajniak) wrote :

The files are completely different, here is what I found in /usr/share/inkscape/markers/markers.svg:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!--
NOTE: this file is currently (0.48+) edited manually.
Insert the new markers into the <defs>.
-->
<svg xmlns="http://www.w3.org/2000/svg">
 <defs id="defs3"><!-- Arrows --><!-- 1 LARGE --><!-- 1 Medium --><!-- 1 small --><!-- 2 LARGE --><!-- 2 Medium --><!-- 2 small --><!-- Tail --><!-- distance markers --><!-- round dots --><!-- squares --><!-- diamonds --><!-- diamonds placed at the start of the line --><!-- diamonds placed at the end of the line --><!-- empty diamonds --><!-- empty diamonds placed at the start of the line --><!-- empty diamonds placed at the end of the line --><!-- triangles --><!-- Empty Triangles --><!-- stops --><!-- filled semicircles --><!-- non-filled semicircles --><!-- scissors --><!-- Others --><!-- Infinite lines --></defs>
</svg>

I removed inkscape and install it again, but it's the same.

Hachmann (marenhachmann) wrote :

Jakub, is that the complete file? It's basically empty.

If so, the solution to your problem is to download the linked file from comment #2, and use it to replace the file you have pasted here. You need to do the replacing as root user.

Reinstalling won't help, as it appears that the Ubuntu package is damaged.

Can you post the output of

$ apt-cache policy inkscape

please?

This will tell us where the package you are using stems from (I'd assume the official Ubuntu 16.10 repos, but who knows...).

Jakub Krajniak (jkrajniak) wrote :

Yes, that's the whole file. Temporarily I did how you suggested and replaced the file.

Here is the apt-cache policy inkscape:

@jakubkrajniak Downloads $ apt-cache policy inkscape
inkscape:
  Installed: 0.91-11
  Candidate: 0.91-11
  Version table:
 *** 0.91-11 500
        500 http://pl.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
        100 /var/lib/dpkg/status

Hachmann (marenhachmann) wrote :

Could it be that someone 'cleaned' all svg files in the /usr/share directory? They are all significantly smaller.

Hachmann (marenhachmann) wrote :

(referring to the Ubuntu 0.91-11 package)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu):
status: New → Confirmed

For what it's worth, I can confirm that downloading the file and putting it in the correct place is a valid work-around.

I have the same values for apt-cache policy inkscape as Jakub.

Hachmann (marenhachmann) wrote :

@Filip and Jakub: It appears that almost all svg files in the /usr/share/inkscape directory have been modified in the package for your version of Ubuntu.

So if you're missing a filter, or a symbol set, a pattern or whatever, you can apply the same solution, only copying a different file from the repo into a different directory.

Location for the files:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_91_BRANCH/files/head:/share/

Or you can use the Inkscape version from the ppa:
https://launchpad.net/~inkscape.dev/+archive/ubuntu/stable

rot13 (pp) wrote :

I have the same problem and I tried installing from PPA, but then I get:

The following packages have unmet dependencies:
 inkscape : Depends: libpoppler58 (>= 0.41.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

I only have libpoppler61, not 58, in my packages.

# apt-cache policy inkscape
inkscape:
  Installed: 0.91-11
  Candidate: 0.91.0+51~ubuntu16.10.1
  Version table:
     0.91.0+51~ubuntu16.10.1 500
        500 http://ppa.launchpad.net/inkscape.dev/stable/ubuntu yakkety/main amd64 Packages
 *** 0.91-11 500
        500 http://pl.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
        100 /var/lib/dpkg/status
# apt-cache policy libpoppler58
libpoppler58:
  Installed: (none)
  Candidate: (none)
  Version table:
# apt-cache policy libpoppler61
libpoppler61:
  Installed: 0.44.0-3ubuntu2
  Candidate: 0.44.0-3ubuntu2
  Version table:
 *** 0.44.0-3ubuntu2 500
        500 http://pl.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
        100 /var/lib/dpkg/status

Hachmann (marenhachmann) wrote :

@rot13: Ah, that's unfortunate...

Can you post this as a new bug report? It's a problem on the Inkscape side of the ppa / build process, and not a downstream packaging problem (and also add this info: for Ubuntu 16.04, libpoppler58 is available, while 61 is not, so hopefully it is not exchanged, but rather both versions should be allowed - else it won't work on the LTS version anymore).

You can also just copy the whole share/... folder from the repo, meanwhile (and remove the ppa, use the version from Ubuntu repos).

jazzynico (jazzynico) on 2016-11-07
tags: added: linux packaging

As a workaround I downloaded libpoppler58 .deb and the libpng12 .deb which it required, then put them in the same folder and ran from that folder in terminal...

sudo dpkg -i libpoppler58_0.41.0-0ubuntu1.1_i386.deb libpng12-0_1.2.54-1ubuntu1_i386.deb

...before attempting to install Inkscape stable again which succeeded.

Please note, my architecture is i386 and yours may be different, so download the correct matching .debs for your platform. I searched for Xenial packages in each case.

Seems libpoppler58 can live alongside libpoppler61 if necessary - nothing needed to be downgraded or uninstalled that I could see and Inkscape stable seemed to launch and run OK after this.

Hachmann (marenhachmann) wrote :

Could one of you turn this into a separate report? It's unrelated to the main issue here.

vmagnin (vincent-magnin) wrote :

Same problem. Downloading the file from comment 2 solved my problem.

the same with patterns.svg ...

Hachmann (marenhachmann) wrote :

There's a snap package for 0.92 available now in Ubuntu App center, and a deb package in the ppa.

Do these solve the problems from this thread for everyone? (i.e. does the snap package have all markers, and does the ppa deb install without a problem on standard Yakkety?)

su_v (suv-lp) on 2017-01-11
description: updated
su_v (suv-lp) on 2017-01-11
description: updated
Mattia Rizzolo (mapreri) wrote :

Speaking about the 0.91-11 package as found in the official Ubuntu archive: this seems to be caused by dh_scour being running during the build, apparently scour tries to optimaze the .svg, but fails shortly on it do to the particular nature of those particular .svg (containing only markers/defines, but nothing that uses them).

The best fix here is to just stop calling dh_scour at all, there is no need for it anyway, and calling it never was intentional at all.

Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Mattia Rizzolo (mapreri)
Hachmann (marenhachmann) wrote :

Where did those two people get their 0.92 builds for 16.04 from?

Bryce Harrington (bryce) on 2017-01-12
Changed in inkscape (Ubuntu Yakkety):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Mattia Rizzolo (mapreri)
Mattia Rizzolo (mapreri) wrote :

And uploaded the fix to Debian Unstable, should get into zesty by tomorrow, then I'll look at fixing it in yakkety too.

Changed in inkscape (Ubuntu Zesty):
status: Triaged → In Progress
Changed in inkscape (Ubuntu Yakkety):
status: Triaged → In Progress
su_v (suv-lp) wrote :

Hachmann wrote:
> Where did those two people get their 0.92 builds for 16.04 from?

@Hachmann - presumably from the stable trunk PPA:
https://launchpad.net/~inkscape.dev/+archive/ubuntu/stable
(inkscape.dev PPAs are also affected because changes from the 0.91-11 packaging rules had been copied. valavanisalex has been notified by mapreri.)

Hachmann (marenhachmann) wrote :

Ah, thanks! Good that they reported right away :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.92.0-3

---------------
inkscape (0.92.0-3) unstable; urgency=medium

  * d/rules: don't run dh_scour, to avoid breaking internal SVGs (markers, …).
    LP: #1638373

 -- Mattia Rizzolo <email address hidden> Thu, 12 Jan 2017 01:05:44 +0100

Changed in inkscape (Ubuntu Zesty):
status: In Progress → Fix Released
Mattia Rizzolo (mapreri) on 2017-01-12
description: updated
Mattia Rizzolo (mapreri) wrote :

I just sent the package for yakkety to my sponsor (I can't upload inkscape (which is in main) myself).

Find the debdiff from current yakkety attached.

Changed in inkscape:
status: New → Triaged
importance: Undecided → High
Alex Valavanis (valavanisalex) wrote :

Patch applied in daily and stable PPAs

Hachmann (marenhachmann) wrote :

Yay :D Thank you, Alex and Mattia!

Hello Jakub, or anyone else affected,

Accepted inkscape into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/inkscape/0.91-11ubuntu16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in inkscape (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Jakub Krajniak (jkrajniak) wrote :

Confirmed that the latest proposed package version solved the bug.

Package version:
inkscape:
  Installed: 0.91-11ubuntu16.10.1
  Candidate: 0.91-11ubuntu16.10.1
  Version table:
 *** 0.91-11ubuntu16.10.1 400
        400 http://nl.archive.ubuntu.com/ubuntu yakkety-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.91-11 500
        500 http://nl.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages

Jeremy Bicha (jbicha) on 2017-01-13
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.91-11ubuntu16.10.1

---------------
inkscape (0.91-11ubuntu16.10.1) yakkety; urgency=medium

  * d/rules: don't run dh_scour, to avoid breaking internal SVGs (markers, …).
    LP: #1638373

 -- Mattia Rizzolo <email address hidden> Thu, 12 Jan 2017 09:47:37 +0100

Changed in inkscape (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for inkscape has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

jazzynico (jazzynico) on 2017-01-25
Changed in inkscape:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers