Crash while arranging objects after tweaking

Bug #1490196 reported by sreeraj on 2015-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Mc

Bug Description

Steps to reproduce:

1)Launch inkscape
2) Add one rectangle
3) Duplicate the rectangle(say total 16)
4)Select All
5)Arrage into 4x4 rows and columns
6)Select Tweak Object Tool(Shift+F2)
7)select Duplicate object with shift delete option
8)Drag through the 4x4 arrangement once.
9)Select all objects
10)Click Arrange

Result: Crash

 /home/username/New document 1.2015_08_30_02_25_54.0.svg
Emergency save completed. Inkscape will close now.

Version used: Inkscape 0.91+devel r14324
OS: Ubuntu 14.04, 64bit. Intel i5.

sreeraj (sreerajc-programming) wrote :

The crash message

su_v (suv-lp) wrote :

> 7)select Duplicate object with shift delete option

Could you try to explain this step differently?
There are 15 duplicates of the original rectangle totally - which one to select? (The current selection at this point is still all 16 rectangles, after having them aligned into rows & columns in step 5)
What does 'shift delete option' refer to?

> 8)Drag through the 4x4 arrangement once.

The tweak stores the last used options across sessions - does it matter which tweak mode is used? If any of the tweak tool options matter, could you describe them in detail?

Changed in inkscape:
status: New → Incomplete
tags: added: aligning crash
sreeraj (sreerajc-programming) wrote :

I am adding more explanation.

6)Select Tweak Object Tool(Shift+F2)

7)select the Tweak Mode placed at 6th position from left which has a tool tip: Duplicate objects, with shift delete.

    Other modes are not causing the crash.

8)Drag the Tweak tool across all 16 rectangles at least once.

9) Once the drag is done next mouse click should be on Arrange button.

Now the crash should occur.

sreeraj (sreerajc-programming) wrote :
su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with Inkscape 0.48.5 and 0.91 r13725
- reproduced with Inkscape 0.91 r14332

Based on tests with archived builds:
- not reproduced with rev <= 14073
- with rev 14073 - 14243, 'Rows and Columns' is broken (bug #1473711)
- reproduced with rev >= 14244
the regression is possibly related to the changes of the SelContainer branch merged in rev 14074, and only was exposed after fixing the typo that prevented 'Rows and Columns' from working at all (r14244):
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14074
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14244

Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: Incomplete → Confirmed
tags: added: regression
su_v (suv-lp) wrote :

Attaching full backtrace from Inkscape 0.91+devel r14326 (debug build, OS X 10.7.5).

tags: added: selection
jazzynico (jazzynico) wrote :

Also reproduced on Windows XP (32bit) with Inkscape trunk rev. 14332.

Changed in inkscape:
status: Confirmed → Triaged
Mc (mc...) wrote :

This bug may be due to the fact that sp_compare_x_position was not a well-founded order (it was not antisymmetric)

Pushed a fix in r14334.

Changed in inkscape:
assignee: nobody → Mc (mc...)
su_v (suv-lp) on 2015-09-15
Changed in inkscape:
milestone: 0.92 → none
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers