Cannot style spaces in text + Styling spaces moves them to next tspan

Bug #1477723 reported by Mc on 2015-07-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Mc

Bug Description

In text (whether it is simple text or flowed), when trying to style some spaces, either nothing is happening, or the spaces are moved to the next tspan, even if it displaces them of several chars.

Steps to reproduce :
-take the text tool
-write " x y abcde"
- try to style the space between x and y => nothing happens
- style the "d"
- try to style the space between x and y => the space is not styled, moved before the "d" into its tspan

NB: Probably a followup bug of https://bugs.launchpad.net/inkscape/+bug/254686 or https://bugs.launchpad.net/inkscape/+bug/272100

tested with 0.91 stable and with trunk r14252

Mc (mc...) on 2015-07-23
description: updated
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91+devel r14252 on OS X 10.7.5.

Changed in inkscape:
status: New → Confirmed
tags: removed: space
su_v (suv-lp) wrote :

Setting same bug status level as originally defined for bug #272100 (related issue filed for older versions) - feel free to revert or raise it if you think this was done in error and the importance needs to be raised.

Changed in inkscape:
importance: Undecided → Low
Mc (mc...) wrote :

After some investigation, the problems seems to come from "tidy_operator_styled_whitespace" which may need to be either fixed, or (better ?) removed.
The mailing-list discussion is on http://inkscape.13.x6.nabble.com/removal-of-quot-tidy-operator-styled-whitespace-quot-td4974036.html

Mc (mc...) wrote :

Committed in r14258

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Mc (mc...)
su_v (suv-lp) wrote :

JFTR - available information about history of the related code section [1]:

* Commit which added tidy_operator_styled_whitespace():
http://bazaar.launchpad.net/~vcs-imports/inkscape/old-main/revision/7785

* Related bug report:
Bug #166680 (sf1233702) “whitespace-only spans must be merged”
https://bugs.launchpad.net/inkscape/+bug/sf1233702

--
[1] see also: https://gist.github.com/su-v/79a91029f184864a350d

Changed in inkscape:
milestone: none → 0.92
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
Antoine Amarilli (a3nm) wrote :

Just tested in 0.92 from Debian, the bug as reported seems to be fixed indeed. To me the bug could be closed.

Thanks a lot for your work on this!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers