User palettes not available if all shared system palettes are deleted from installation

Bug #1447971 reported by Paulo Silva on 2015-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

i did a dist-upgrade to Ubuntu yesterday (14.10 to 15.04), and Inkscape got upgraded to version 0.91 - the situation is that it isn't reading palettes from ~/.config/inkscape/palettes anymore, only from /usr/share/inkscape - and i only want to have my own custom palettes (and i have a "cleaning" script with "sudo rm /usr/share/inkscape/palettes/*" for assuring i haven't available the original palettes ) - how can i get this situation fixed? i guess it's a bug blocking the palettes from ~/.config/inkscape/palettes , or some default misconfiguration ocurred after the upgrade? thanks!

description: updated
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.91 r13725 and 0.91+devel r14059 on OS X (regular, linux-style local build and installation).

The palettes are loaded as expected from the default location "$HOME/.config/inkscape/palettes", or - if the environment of the launching shell sets up different paths for (some of the) XDG Base Directories - from "$XDG_CONFIG_HOME/inkscape/palettes".

Could you please:
- provide the system information (paths) as displayed in Inkscape's preferences (menu 'Edit > Preferences > System')
- attach the current content of your current user's ~/.config/inkscape/palettes/ directory (zipped or tar'd), to allow testing the palettes on other systems
- ideally, maybe also attach the user's current Inkscape preferences file (~/.config/inkscape/preferences.xml)

tags: added: color preferences ui
removed: custom home palette
Changed in inkscape:
status: New → Incomplete
su_v (suv-lp) wrote :

On 2015-04-24 10:55 (+0200), Paulo Silva wrote:
> (and i have a "cleaning" script with "sudo rm
> /usr/share/inkscape/palettes/*" for assuring i haven't available the
> original palettes )

Nevermind - this manual tinkering with inkscape's installed shared resources (deleting all palettes which are installed and shared by Inkscape) apparently causes that no other palettes are loaded either.

Changed in inkscape:
importance: Undecided → Low
status: Incomplete → Confirmed
su_v (suv-lp) wrote :

With a single GPL file still kept alive in the default (system) location for Inkscape's shared resources (e.g. the default inkscape palette 'inkscape.gpl'), the user-installed palettes show up just fine.

su_v (suv-lp) wrote :

Seems to be intentional (caveat: I could be wrong - I don't code C/C++ myself):

<quote>

    loadEmUp();
    if ( !systemSwatchPages.empty() ) {
</quote>
https://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_91_BRANCH/view/head:/src/ui/dialog/swatches.cpp#L609

summary: - palettes from ~/.config/inkscape/palettes not opening
+ User palettes not loaded if all shared system palettes are deleted from
+ installation
summary: - User palettes not loaded if all shared system palettes are deleted from
- installation
+ User palettes not available if all shared system palettes are deleted
+ from installation
su_v (suv-lp) wrote :

Based on tests with archived builds (not reproduced with r11752, reproduced with r11759), this seems to be a regression introduced in rev 11757 to fix bug #1060563:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11757#src/ui/dialog/swatches.cpp

tags: added: regression
Changed in inkscape:
milestone: none → 0.92
jazzynico (jazzynico) on 2016-08-30
Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Fixed in lp:inkscape rev. 15093 and in lp:inkscape/0.92.x rev. 15058.

Changed in inkscape:
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers