[win64] Transparent objects and empty areas print black

Bug #1418865 reported by vac on 2015-02-06
118
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Patrick Storz
Inkscape Devlibs for Windows 64-bit
High
Patrick Storz

Bug Description

I'm using Inkscape 0.91 r13725 on windows x64.
(btw: thanks for new version - great job!)

When I'm printing new (empty) document I get black piece of paper.
For tests I recommend using PDF printer - it wont ruin printer ink;)

The only work around is to make white rectangle which covers whole page.

I have read about similar problem here: http://www.inkscapeforum.com/viewtopic.php?f=5&t=17048
but this was a problem with clipping. Now I print empty document so I expected empty page;

Thank you in advance for help.

Additional data:
================

Observed so far with these printers:
- Win7 x64 / SHARP MX-2614N
- Win7 x64 / PDF Creator 1.7.1
- Win7 / HP 8250
- Win7 / Sharp MX2300 (shared) [1]
- ? / Canon MX925
- ? / FreePDF

Not reproduced with:
- Win8.1 / Canon MG7120 [1]
- Win7 x64 / Microsoft XPS Document Writer (partialy - document is fine but the thumbnail of the document is affected)

Other variations:
=================

Bug #1425393 “Raster printing prints solid black background”
(only with bitmap backend, but not with vector backend)

--
[1] related topic on inkscapeforum.com:
    http://www.inkscapeforum.com/viewtopic.php?f=5&t=18426

su_v (suv-lp) wrote :

Did you install the 32bit or 64bit version of Inkscape 0.91?

tags: removed: background black print
Changed in inkscape:
status: New → Incomplete
su_v (suv-lp) wrote :

Possibly the same issue as reported earlier as
- Bug #1416825 “inkscape prints negative”

vac (vac) wrote :

I'm using 64bit version of Inkscape 0.91 (r13725)

su_v (suv-lp) on 2015-02-08
Changed in inkscape:
status: Incomplete → New
tags: added: win64
vac (vac) wrote :

You were right - on 32bit version there is no such problem.
32bit binaries prints fine.
64bit binaries and 64bit installer don't.

Rick Uhlenkott (rduhlenkott) wrote :

I'm having the same problem with the production .91 r13725. Transparent objects and empty areas print black. Filled objects print correctly. Win7, 64bit. HP 8250.

.91 pre3 printed correctly.

su_v (suv-lp) on 2015-02-10
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
Changed in inkscape-devlibs64:
importance: Undecided → High
su_v (suv-lp) on 2015-02-13
summary: - Black background on print
+ [win64] Transparent objects and empty areas print black
su_v (suv-lp) wrote :

Does the same issue also affect saving a copy as PDF with 64bit builds (as opposed to output via print dialog)?

su_v (suv-lp) wrote :

... or saving a copy as PostScript.

Saved as PDF correctly for me.

Rick

In a message dated 2/13/2015 9:55:53 A.M. Mountain Standard Time,
<email address hidden> writes:

Does the same issue also affect saving a copy as PDF with 64bit builds
(as opposed to output via print dialog)?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1418865

Title:
[win64] Transparent objects and empty areas print black

Status in Inkscape: A Vector Drawing Tool:
Confirmed
Status in Inkscape Devlibs for Windows 64-bit:
New

Bug description:
I'm using Inkscape 0.91 r13725 on windows x64.
(btw: thanks for new version - great job!)

When I'm printing new (empty) document I get black piece of paper.
For tests I recommend using PDF printer - it wont ruin printer ink;)

The only work around is to make white rectangle which covers whole
page.

I have read about similar problem here:
http://www.inkscapeforum.com/viewtopic.php?f=5&t=17048
but this was a problem with clipping. Now I print empty document so I
expected empty page;

Thank you in advance for help.

To manage notifications about this bug go to:
https://bugs.launchpad.net/inkscape/+bug/1418865/+subscriptions

vac (vac) wrote :

Saving a copy as PDF or PS is working fine (there is no such problems) - I have checked it with empty document and with fancy semi-transparent shapes.

su_v (suv-lp) on 2015-02-17
description: updated
su_v (suv-lp) on 2015-02-17
description: updated
vac (vac) on 2015-02-17
description: updated
vac (vac) wrote :

With Microsoft XPS Document Writer (virtual printer) on Win7 x64 it's very interesting:
The XPS document is fine when you are browsing it (and printing) but the thumbnail (icon) of it in explorer is black.
I have attached a screenshot to make it clear.

description: updated
su_v (suv-lp) on 2015-02-25
description: updated
Silvernerd1 (silvernerd1) wrote :

My system: Inkscape 0.91 r13725 64 Bit, Windows 8.1 64 Bit

When I create a new Inkscape document, draw something and print it, everything works fine. When I add the SVG-file attached into my documen and print it again, the backgound is black.

Could this be of help for you developers?

servomonitor (servomonitor) wrote :

I have the same problem. It appeared with Inkscape 0.91 r13725 with a Canon MX925 and FreePDF. Both create a black background where the document has a black background.

su_v (suv-lp) on 2015-03-28
description: updated
Vangelis B (sneaker) wrote :

I installed 0.91 today (Windows 64-bit, msi installer) and I had a similar problem.

I tried printing a page and the background was all black. After various tests (adding/removing elements from the page) I found out that this was caused by the opacity of some Objects. More specifically, when some squares had 80% Opacity, the background would print black. When I would put them at 100% everything was printed fine.

I repeated the tests with a virtual pdf printer and I got the same results. I also tried installing Inkscape (same version/installer) on a friend's computer (windows 64-bit) and got the exact same results.

Here is the test case I run:

- Open a new document
- Create a square inside the page
- Set the opacity of the square at any number below 100 (ie 80%)
- Print the page (doesn't matter if vector or bitmap)
- The background of the page is printed black
- Set the opacity of the square at 100%
- Print the page
- The background of the page is printed white

If you believe that this is a separate bug and needs its own entry let me know and I will create a new post.

Adding to the description of Vangelis B (2015-04-16), I have found the same behaviour occurs if one of the objects has a "blur" setting of >0.

Inkscape 0.91 r13725
Windowxs7 SP1 Ultimate 64bit
Canon MP500 Series Printer

su_v (suv-lp) wrote :

AFAICT likely related upstream bug in cairo:
https://bugs.freedesktop.org/show_bug.cgi?id=91835

tags: added: cairo
su_v (suv-lp) on 2015-10-14
Changed in inkscape:
milestone: none → 0.92
C.Spengler (cspengler) wrote :

Windows 10, Canon 9000, 64-bit. Same problem

Hachmann (marenhachmann) wrote :

Will this be fixed for 0.92? It's a very frequent issue users experience.

Hachmann (marenhachmann) wrote :

Please, Eduard, can you confirm that this is fixed?

It needs a specific cairo version, where this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=91835
is fixed.

I'd like to add it to the 'Relevant fixed bugs' section in the release notes.

Mc (mc...) wrote :

I think it should be ok: the version we have is normally 1.15.2

https://www.cairographics.org/news/cairo-1.15.2/

* Fix various issues with printing and transparent images on Win32.

Patrick Storz (ede123) wrote :

Hi Maren, (If you need someones feedback you should probably use the "Subscribe someone else" function above. I only noticed this question due to your mail to the "devel" list.)

devlibs64 include cairo 1.15.2 which should include the fix [1] to the cairo bug linked in comment 15.

I don't have a phyical printer available right now, but both, Microsoft XPS and PDF printers seem to work fine. Maybe someone who was able to reproduce the bug before could verify (just to be safe).

[1] https://cgit.freedesktop.org/cairo/commit/?id=e5d4f520aaa0107f82ad7683e4f9763d6edcc23b

Hachmann (marenhachmann) wrote :

> * Fix various issues with printing and transparent images on Win32.

Interestingly, it was Win64 for us... did we have the Win32 version of cairo in the 64bit Inkscape version?

@Eduard: I didn't know if it was okay to do that or if you maybe already were subscribed.
Thanks for answering!

@anyone interested in this report:

Please test if it is fixed with one of the recent pre-release versions from here:
https://inkscape.org/en/*developer/galleries/092pre2/

Patrick Storz (ede123) wrote :

> Interestingly, it was Win64 for us... did we have the Win32 version of cairo in the 64bit Inkscape version?

No, "Win32" is just the (a bit ignorant) name used for Windows (or more specifically the Windows API that software built for Windows has to use) in the *nix world. See [1] if you're interested in the details.

If you want input from me you can always subscribe me (otherwise don't expect an answer ;-) ). You can find out if someone is already subscribed by looking at the list of "Other bug subscribers" above (to the right).

[1] https://de.wikipedia.org/wiki/Windows_Application_Programming_Interface

vac (vac) wrote :

I have tested this again on this build: Inkscape-0.92pre2-x64.7z
About window says that it is: Inkscape 0.92pre2 15127

I'm on windows 10 at the moment and the results are:
- PDF Creator 1.7.1 - OK
- Microsoft Print to PDF - OK

- Microsoft XPS Document Writer (.xps and .oxps file) - Partialy ok:
document on microsoft xps viewer looks fine but:
thumbnail of document (which can be seen in explorer) is corrupted - see attachment.

@Eduard: could you double check if your XPS have proper thumbnails in explorer?

Hachmann (marenhachmann) wrote :

@Eduard: Thank you for the explanation (and for the hint about subscribing you)!

Rick Uhlenkott (rduhlenkott) wrote :

Test print came out with no unwanted black areas.

Rick U

In a message dated 10/22/2016 10:14:58 A.M. Mountain Daylight Time,
<email address hidden> writes:

@anyone interested in this report:

Please test if it is fixed with one of the recent pre-release versions
from here:
https://inkscape.org/en/*developer/galleries/092pre2/

David Bolton (davidkbolton) wrote :

I can confirm that black background on print when one object has opacity, as described by "Vangelis B (sneaker)" 2015-04-16 above is fixed in the 092pre2 version linked to in Rick Uhlenkott's comment directly above.

Hachmann (marenhachmann) wrote :

@Rick and David: Thank you for testing!

@Bug team: do the user feedback / Eduard's and vac's tests suffice for closing this now?

jazzynico (jazzynico) wrote :

@Hachmann - Yes, that should be enough. If not, it's always possible to reopen the report.
Thanks!

Changed in inkscape-devlibs64:
status: New → Fix Released
Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Eduard Braun (eduard-braun2)
Changed in inkscape-devlibs64:
assignee: nobody → Eduard Braun (eduard-braun2)
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released

Works in 0.92 on Windows 64 bit

I hate to say it, but I'm seeing this issue tonight on Windows 10 x64 using Inkscape v0.92.3 (2405546, 2018-03-11) both 32-bit and 64-bit varieties.

As viewed in Inkscape: https://imgur.com/rMDMGb0

As viewed in Adobe Reader after File > Save a Copy > PDF: https://imgur.com/JGwYASr

SVG is attached.

RE #30: Same issue on Linux Mint.

Hachmann (marenhachmann) wrote :

@Josh:

This is a different problem, it has to do with the weird masking in the file (which mainly consists of masked raster images...), and affects pdf/postscript export.

It does not have to do with this issue which was specifically about printing any transparent objects on Windows, 64 bit.

I can't currently search for this, but maybe you could do a search in our bug reports to find the correct one and append your example file there?

To have your file export to pdf well, ungroup everything, remove all masks and clips, and redraw (or trace) the red border in its black box.

As a workaround, export to PNG and print that, as PNG export does not seem to be affected by this masking/postscript issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.