Update the built-in Scour Extension to 0.30

Bug #1411149 reported by jazzynico on 2015-01-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Patrick Storz

Bug Description

Follow-up to Bug ​#927290 Update the built-in Scour Extension to 0.26 .

The new Scour versions are available at:
https://pypi.python.org/pypi/scour/
https://github.com/oberstet/scour/commits/master

Related branches

jazzynico (jazzynico) on 2015-01-15
description: updated
Patrick Storz (ede123) wrote :

Just a quick update:
I'm currently looking into this issue.

There are two and a half problems to solve:

* First and most important: Is Scour's Apache license (Version 2) compatible with Inkscape's GPL license (Version 2)? See also https://github.com/codedread/scour/issues/7 . In my opinion we should be fine though (see https://github.com/codedread/scour/issues/7#issuecomment-158662122). Does anybody feel differently (or is there some substantial historical information on this potential license incompatibility)?

* Secondly: The latest version of Scour (https://github.com/codedread/scour) was updated to also support Python 3, partially by using the compatibility module "six" (https://pypi.python.org/pypi/six). We have to find a way to either a) include this module which might be difficult at this time or b) make Scour independent of "six" (sadly Scour's current maintainer Tobias Oberstein has declined my pull request for this, see https://github.com/codedread/scour/pull/12). Maybe we can include a local copy of the module in Inkscape?

* And the half problem: We have to check if the latest Scour still works with Python 2.6.5 (which we use on Windows). This is not much of a problem at all, though, since I'm determined to make the necessary adjustments myself, so basically we only have to resolve the other two problems.

Patrick Storz (ede123) wrote :

I've succeeded in making the latest version of Scour work with Inkscape, see http://bazaar.launchpad.net/~eduard-braun2/inkscape/scour/revision/14483

I solved the second issue above by including a copy of the module "six" alongside with the extension. In case we ever plan to update to Python 3 this will probably be useful anyway.

As a next step I intend to redesign the Scour settings dialog a little to
a) account for the new settings available in the new Scour version and
b) make it a little bit clearer and thereby hopefully easier to use for beginners

Therefore we're down to one issue (the licensing) so if anybody has any input I want to hear it!

su_v (suv-lp) wrote :

On 2015-11-22 01:00 (+0100), Eduard Braun wrote:
> As a next step I intend to redesign the Scour settings dialog a little to
> a) account for the new settings available in the new Scour version and

Please keep bug #748639 in mind when redesigning the dialog - there is no scrollable window or text view available in INX-based dialogs, and the current minimal height of the dialog is already an issue on small screens.

Patrick Storz (ede123) wrote :

Thanks, that's useful input!
Actually I intend to convert the current "Help" tabs (which actually define the dialogs current height) to tooltips using the "_gui-description" attribute of params.
This will not only make it easier to use (with the description always at hand) but will also make translations easier (changes/additions to parameter descriptions won't invalidate the translations for the whole help page).

(Just to be sure: Usage of "_gui-description" should work since Inkscape 0.91, right? I found bug #1164568 and a cryptic warning on http://wiki.inkscape.org/wiki/index.php/INX_Parameters#gui-tip but from what I get the bug should be fixed and the Wiki should probably be updated as it does not even get the attribute names right...)

su_v (suv-lp) wrote :

On 2015-11-22 01:47 (+0100), Eduard Braun wrote:
> Just to be sure: Usage of "_gui-description" should work since
> Inkscape 0.91, right?

Yes.

Patrick Storz (ede123) wrote :

Here's the first version of the reworked Scour export dialog.
- All settings now have a tooltip that replaces the former help pages
- The settings are split across three tabs. I tried to achieve an intuitive arrangement/grouping.

Please let me know if you have any suggestions regarding layout, arrangement/order of settings, wording, labels/order of tabs, etc.

Patrick Storz (ede123) wrote :
Patrick Storz (ede123) wrote :
Patrick Storz (ede123) wrote :
jazzynico (jazzynico) wrote :

Thanks for working on it Eduard!

Changed in inkscape:
assignee: jazzynico (jazzynico) → Eduard Braun (eduard-braun2)
status: Triaged → In Progress
Patrick Storz (ede123) wrote :

From my side this is ready to be merged (I just made the request here: https://code.launchpad.net/~eduard-braun2/inkscape/scour/+merge/278387)

jazzynico (jazzynico) wrote :

The python scripts seem to work as expected on Windows XP. Apart from the patch issue (not a blocker at all), the INX dialog doesn't show the spacer character as a spacer...
Screenshot attached.

Patrick Storz (ede123) wrote :

Seems like the UI font used on Windows XP does not have this character (em quad) and therefore shows the Unicode character code (U+2001)... I'll check if I can find an alternative that also works on Windows XP.

If anybody know of a better way to produce empty vertical space in an .inx please let me now (I already tried an empty description and an description only containing a simple space character both of which were stripped from the output)

Patrick Storz (ede123) wrote :

I worked around the issue by using an encoded non-breaking space (" "), see http://bazaar.launchpad.net/~eduard-braun2/inkscape/scour/revision/14486

I assume this should work fine with all fonts that could potentially be used to draw the UI.

jazzynico (jazzynico) wrote :

Fix confirmed on Windows XP. Thanks Eduard!

Patrick Storz (ede123) wrote :

Fix committed in r14577
- the Python Scour module is now an external dependency
- the Scour extension was updated to work with recent versions of Scour (0.32 as of the time of this writing)

Changed in inkscape:
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers