constrained node dragging and path rotating, they snap back to previous position

Bug #1265026 reported by Cojnel on 2013-12-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Diederik van Lierop

Bug Description

Turn on cusp node snapping
Draw two lines that meet at their end points
Pick the node editing tool
Hold down ctrl and start dragging the node where the lines meet,
as long as the cursor is within snapping distance of the dragged node,
then it snaps back to it's previous position with the snap messsage
"Cusp node to cusp node".

The same thing happens if ctrl + alt is held down to constrain the nodes movement
to the slope of the line (or the node handles direction if a handle has been dragged out).

It also happens if both cusp and smooth node snapping is turned on
and one draws a line to a smooth node and follows the steps above.

A similar thing happens when rotating a path with it's
center of rotation at the point where two paths meet.

Turn on both cusp node and rotation center snapping
With two lines meeting at their endpoints (like above)
Pick the select tool
Select one of the lines
Click on it once to show it's center of rotation
Snap the center of rotation to the node where the lines meet
and drag on a rotation handle.

The path that's being rotated snaps back to it's
previous angle when the cursor stops moving.

tested with r12862
on linux mint 15 cinnamon 32bit

it does not happen in v0.48.4 r9939

Cojnel (cojnel) wrote :
Cojnel (cojnel) wrote :
jazzynico (jazzynico) on 2014-01-14
Changed in inkscape:
importance: Undecided → Medium
su_v (suv-lp) wrote :

Reproduced with r10795, r12981 on OS X 10.7.5.

AFAICT node-dragging with 'Ctrl' was also reported as:
- Bug #681286 “[snapping] nodes ctrl-drag not always working properly”
  <https://bugs.launchpad.net/inkscape/+bug/681286>

Changed in inkscape:
status: New → Confirmed
tags: added: node-editing regression
removed: shortcuts ui
Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

I believe this has been fixed as of rev. 13527. Please test!

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2014-08-17
Changed in inkscape:
milestone: none → 0.91
su_v (suv-lp) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers