[snapping] nodes ctrl-drag not always working properly

Bug #681286 reported by LucaDC on 2010-11-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Diederik van Lierop

Bug Description

When the drawing has more than few paths (I haven't checked exactly how many), nodes ctrl-drag stops working properly.
It seems related to the "self-snapping" problem already seen for the rotation center, but slightly different: the point always snaps to itself, also if the cursor is moved outside the snap-trigger distance.
In any case, the only way to move the point is disabling all snapping options, but then you cannot ctrl-move it AND snap. Maybe related to the number of snapping solutions found?
I've made the attached file to make this evident: try ctrl-moving the nodes of the big red segment; for me (Windows XP SP3, since many releases ago) they don't move or snap to something else following an obscure criterion (it seems that the snapping happens when the cursor EXITS the snapping area and when reentering it goes back to self-snapping: try moving slightly around a target).
Please take a look at this because as soon as my drawings evolve over a not so much high level of complication, I can't ctrl-drag anymore and always have to use guides (great guides! ;) instead.
Thanks.

LucaDC (dicappello) wrote :
su_v (suv-lp) on 2010-11-26
tags: added: snapping
LucaDC (dicappello) wrote :

This problem is still not solved and I find it very annoying while working on complex drawings.
I finally decided to look for a simpler example hoping it will help.

I've tried different snapping options but the problem is always present.
Anyway, my options are: "Enable snap indicator" selected, "Delay" 0 ms, "Only snap the node closest to the pointer" not selected, "Weight factor" 0.5, "Snap the mouse pointer..." not selected.

Follow this:
 - open ctrl-snap.svg (zoom is at 150%, if you zoom in the problem may eventually disappear);
 - select node tool (F2);
 - select the red segment's lower node (the one over the black segment);
 - grab it and ctrl-drag it vertically down toward the circle: while you stay near the vertical, the node keeps snapping to its original position; if you move horizontally away from the vertical, the movement becomes correct;

And now another problem (don't know if it's related but it seems to be triggered by this one, at least):
 - let the node snap to its original position (just move the pointer to the vertical and release it);
 - clicking away, deselect the segment (you'll have to click twice: one for deselecting the node, the second to deselect the segment; or press esc twice);
 - if you didn't do something else meanwhile (if you did, please close and reopen the file a do only this sequence), you shouldn't be able to select the red segment clicking on it, even if switching to the select tool (F1); you can only drag-select it or select the other black objects; after zooming in or out selection is possible again.

I'm waiting for confirmation that this problem doesn't affect only me.
Thanks.

su_v (suv-lp) on 2012-01-25
tags: added: node-editing
su_v (suv-lp) wrote :

Both issues from comment #2 reproduced with mentioned snap settings in 0.48+devel r10922 on OS X Lion:
- When Ctrl-drag vertically downwards, the node insists on snapping to itself, works better if Ctrl+dragging diagonally downwards
- After letting the node snap to itself, the path is no longer selectable by clicking on it - neither in the node tool nor the select tool context (cycling through the objects with 'Tab' works).

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2012-01-25
summary: - nodes ctrl-drag not always working properly
+ [snapping] nodes ctrl-drag not always working properly
Cojnel (cojnel) wrote :

The second problem in comment #2 where paths become unclickable,
sounds similar to comment #2 in this report:

Bug #1256597 “several actions outputs to the terminal: “warning:...”
https://bugs.launchpad.net/inkscape/+bug/1256597

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

Cojnel was right, the second issue was different and fixed already some time ago. But the main issue here should have been fixed as of rev. 13527. Please test!

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2014-08-17
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.91
LucaDC (dicappello) wrote :

I find it's fixed in the previously attached files. Also, I quickly tried on some others where I remember I recently experienced this problem and couldn't reproduce it.
I too can confirm the second issue has already been addressed.
Thanks.

Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers