Broken Link: Bug Page Not Found From Program Link

Bug #1264371 reported by KitchM on 2013-12-26
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Masato HASHIMOTO
Inkscape-website
High
Martin Owens

Bug Description

While I can get the manual page from the Help menu, I cannot get the bug reporting page. The link takes me to:

http://inkscape.org/en/report_bugs.php/

and gives a message:

Not Found

The requested URL /en/report_bugs.php/ was not found on this server.

I am using Inkscape 0.48.4 r9939 on Fedora 20 and Xfce 2.10.1, with Firefox 26.0. I selected Help>Report A Bug.

su_v (suv-lp) on 2013-12-26
tags: added: website
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Martin Owens (doctormo) wrote :

This needs to be patched as it contains no root directory I could have together a redirect like the docs.

Let me know what report_bugs.php did (if anything) so the functionality can be replicated if needed.

tags: added: trusty
Sergio Benjamim (sergio-br2) wrote :

In the Inkscape trunk, i got the error:

(process:27293): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

In the stable inkscape, it appears an error window, if i click in cancel, inkscape freezes and if i click in the close button of this window, inkscape crashes.

Alvin Penner (apenner) wrote :

I guess my question would be, does an appropriate web page for this function actually exist?

previously the link was to something like this:
http://dev.inkscape.org/report_bugs.php
which contains info on how to run gdb.

the closest link I can find now is to:
http://inkscape.org/en/develop/bug-management/
which does not mention gdb or backtraces

Alvin Penner (apenner) wrote :

sorry about that, I guess the intended link is:

http://inkscape.org/en/contribute/report-bugs/

would it be alright to simply hard-code this address into the appropriate Python file, or is it intended to use a php file instead?

su_v (suv-lp) wrote :

> would it be alright to simply hard-code this address into the appropriate Python file

IMHO no - this won't help with current inkscape installations. The current URL needs at least a redirection to the new one (server-side).

Christian González (droetker) wrote :

And translations are not managed then, in Austria/Germany it would be
http://inkscape.org/de/contribute/report-bugs/

Alvin Penner (apenner) wrote :

just confirming that this bug still exists, rev 13288

Changed in inkscape-web:
status: New → Confirmed
Masato HASHIMOTO (hashimo) wrote :

url should be:
http://inkscape.org/contribute/report-bugs/
The server redirects to your language page if you have already visited inkscape.org and chosen your language, otherwise English page will be shown as default.

jazzynico (jazzynico) on 2014-05-14
Changed in inkscape-web:
status: Confirmed → Triaged
Changed in inkscape:
status: Confirmed → Triaged
milestone: none → 0.91
tags: added: backport-proposed
Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
jazzynico (jazzynico) wrote :

Fix committed in the trunk, revision 13375.
Masato, thanks for giving the right link!

Changed in inkscape:
status: Triaged → In Progress
assignee: jazzynico (jazzynico) → Masato HASHIMOTO (hashimo)
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

Backported to 0.48.x, revision 10026.

Changed in inkscape:
milestone: 0.91 → 0.48.5
Martin Owens (doctormo) wrote :

Thanks Jazzy. I can confirm the right link is in.

tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
Martin Owens (doctormo) on 2014-11-28
Changed in inkscape-web:
status: Triaged → Fix Released
importance: Undecided → High
su_v (suv-lp) wrote :

AFAICT this is not fully fixed (at least server side) - if I use the the menu item 'Help > Report a bug' for example in Inkscape 0.48.4, the browser ends up with 'Page not found'.

Martin Owens (doctormo) wrote :

~suv, it's working here. I've refreshed the cache just in case there's a urls issue. Please retry.

Changed in inkscape-web:
assignee: nobody → Martin Owens (doctormo)
su_v (suv-lp) wrote :

@Martin: thx - now it's working here too. Sorry for the noise earlier (I probably should have waited a bit longer before trying).

su_v (suv-lp) wrote :

… and thanks a lot for fixing it server-side!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers