snap messages stop working after pressing esc while drawing a bezier curve

Bug #1260544 reported by Cojnel on 2013-12-13
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Diederik van Lierop

Bug Description

1. Draw a path or a shape on the page
(to have something to snap to).
2. turn on a snapping mode (like path snapping)
3. pick the bezier curves tool
4. place the first node on the page,
move the cursor to check that it snaps to
the previously drawn object.
5. press Esc
6. move the cursor near the object,
the snap message doesn't get displayed anymore.

To display the snap messages again,
perform either of these two actions,

Pick the bezier curves tool again,
or
click once on the page to set a new node,

Snapping seams to be calculated in the background,
because if one clicks near the object,
then the node snaps to it.

Tested with:
r12848 on linux mint 15 cinnamon 32bit

Cojnel (cojnel) on 2013-12-13
tags: added: shortcuts snapping ui
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.48.4 and trunk revision 12851.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Cojnel (cojnel) wrote :

Pressing the shortcut: ctrl + z
has the same effect as pressing Esc,
while drawing a bezier path.

Tested with v0.48.4 r9939 and r12976.

su_v (suv-lp) wrote :

On OS X 10.7.5,
- not reproduced with 0.47 (no snap indicator messages before the first node is set with pen tool)
- reproduced with 0.48.0, 0.48.4 and current trunk (r12981)

Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

This should have been fixed as of rev. 13785.

Please test!

Changed in inkscape:
status: Triaged → Fix Committed
su_v (suv-lp) on 2015-02-17
Changed in inkscape:
milestone: none → 0.92
su_v (suv-lp) wrote :
tags: added: backport-proposed
ScislaC (scislac) wrote :

Patch from comment #5 committed in 0.91.x r13769

su_v (suv-lp) on 2015-09-28
tags: removed: backport-proposed
Changed in inkscape:
milestone: 0.92 → 0.91.1
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers