Incorrect implementation of plural forms

Bug #1247985 reported by Alexandre Prokoudine on 2013-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

In src/sp-flowtext.cpp:300

    return g_strdup_printf(ngettext(_("(%d character%s)"), _("(%d characters%s)"), nChars), nChars, trunc);

This implementation of plural forms isn't recognized by gettext tools. You get two separate messages in the PO file instead of one.

description: updated
jazzynico (jazzynico) on 2013-11-06
Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
importance: Undecided → Low
milestone: none → 0.49
status: New → In Progress
jazzynico (jazzynico) on 2013-11-06
tags: added: translation
jazzynico (jazzynico) wrote :

Partially fixed in the trunk, revision 12780.

The plural form is now correctly recognized, but there's still an old bug (also reproduced with 0.48.3.1 on Crunchbang Waldorf -a Debian stable based distro) : the plural is correctly rendered when you type more than one character, but also (instead if the singular) when you type one character. It doesn't seem to be linked to the French translation since the default English (US) interface also shows the issue.
I'll take a look a bit later.

jazzynico (jazzynico) wrote :

The additional issue reported comment #1 had nothing to do with the original report, and was due to an error in src/text-context.cpp (use of gettext instead of ngettext). I've fixed it revision 12781 anyway.

Closing fix released.

Changed in inkscape:
milestone: 0.49 → none
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers