Terminate in an unusual way when working with large image files

Bug #1244928 reported by Nick Carriere on 2013-10-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

I get the "Microsoft Visual C++ Runtime Library" box with message "The application has requested the Runtime to terminate in an unusual way. Please contact the application's support team for more information". Then: "Inkscape has encountered an internal error and will close now. Automatic backups were done to ...."

I have just started a fairly new document. Starting a new one again doesn't help.

I am working with layering of 3 or 4 quite large jpg files 3540x2364 (4MB) and 10000x10000px png file (38MB).

This happens with you add new files (embedded) and also when cutting an image object. Unlike Bug #1165274 it it triggered by doing something to an image.

Inkscape 0.48.4 r9939

Windows 7 Home, 8GB RAM
Colour depth = 32-bit

Thanks.

su_v (suv-lp) wrote :

Likely related to (or a duplicate of)
- Bug #414413 “[Win32] Crashes when working with imported bitmaps”
  <https://bugs.launchpad.net/inkscape/+bug/414413>

Similar earlier reports (win32):
- Bug #1214182 “Image Importing causes crash”
- Bug #1165274 “This application has requested the runtime to term...”
- Bug #1161414 “Crash while opening big tiff file”

tags: added: bitmap crash win32
description: updated
description: updated
description: updated
description: updated
summary: - Terminate in an unusual way when working with large png files
+ Terminate in an unusual way when working with large image files
jazzynico (jazzynico) on 2013-12-11
Changed in inkscape:
importance: Undecided → High
Stephen Edwards (esdwards) wrote :

Steve Edwards (<email address hidden>) on 2014-4-22
   Same problem. I can't work for more than 5mins. I'm not using large files. I'm just drawing a grid with a few coloured dots on it. I'm not even conected to the internet so my OS hasn't been updated. In fact nothing has changed in months. In fact the last thing that changed was, I installed Inkscape. It worked ok before, but now, suddenly it doesn't. Like everyone else I tried uninstalling and reinstalling, but to no avail.

Stephen Edwards (esdwards) wrote :

I have fixed the problem by moving the project to another computer. Originally I was using an Advent 9617 Pentium Dual-Core T2330 1.60GHz with 2GB ram and XP Home edition service pack 3 ( I don't understand what all of this means, I just copied it off the computer). I have now moved to a Dell Inspiron 9400 Genuine Intel(R)CPU T2400 1.83GHz 987MHz with 2GB ram and XP Professional service pack 3 ( a much slower computer) both are laptops. Something else I noticed that was a bit strange on the first computer (when Inkscape didn't work properly) was that to open Inkscape it only required 1 click on the desktop icon, On the second computer it needs a double click, and in the window where you open saved files, I only had to select the file to open it. I never had to click the open box. On the second I have to click the open box or double click when selecting, to open. The Inkscape edition is the same in each case 0.48.4.1
                   Hope this is of some help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers