Inkscape crashed out of the blue

Bug #1229687 reported by George Karavasilev on 2013-09-24
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

So, I was doing some standard Inkscape work (creating and editing perfectly ordinary .svg files) and it started crashing.
I saved some of those files, closed all Inkscape windows and tried to open another perfectly ordinary .svg file and got the thing I have attached as a debug log.
Help? Anyone?

su_v (suv-lp) wrote :

Please add information about your system (e.g. which linux distro) and about inkscape's version (see Inkscape menu 'Help > About Inkscape') to the bug description.

George Karavasilev wrote:
> and tried to open another perfectly ordinary .svg file
> and got the thing I have attached as a debug log.

Could you please attach a sample SVG file which triggers the reported crash on your system when trying to open it, to allow further investigation?

Changed in inkscape:
importance: Undecided → High
status: New → Incomplete

The distro is Ubuntu 13.04, the Inkscape version (according to Synaptic as I can't open Inkscape, it crashes) is 0.48.4-0.1ubuntu2.
As for the files:
https://dl.dropboxusercontent.com/u/2656555/stuff-that-caused-the-crash.tar.gz
Last thing I did was saved the gtk-preferences.svg after recolouring it for pure white ffffffff to dark grey 555555ff. Then I tried opening the two otehr files (first the three lines, after that the radar) and couldn't open them. Then I started Inkscape in terminal and it threw the segfault and then I reported the bug.

su_v (suv-lp) on 2013-09-24
Changed in inkscape:
status: Incomplete → New
su_v (suv-lp) wrote :

Not reproduced
- with Inkscape 0.48.4 on OS X 10.7.5
- with Inkscape 0.48.4 on Ubuntu 12.10 (VM)
- with current trunk on Ubuntu 12.04, Ubuntu 13.04 and OS X 10.7.5
(all files from the tarball open without crash, saving first some edits to gtk-preferences.svg does not trigger a crash either)

Based on the backtrace - could it be that you opened the files via 'File > Import From Open Clip Art Library', and not via 'File > Open'?

If so, this is a duplicate of bug #1042463.

I can not test anything that requires opening Inkscape as it crashes.
However I just installed the trunk version (+ gtk 3 support) and it works like a charm and I can not reproduce the bug with it.

Ok, here is a backtrace with the -dbg packages of libxml2 and librsvg installed:
http://pastebin.com/M54Y35tn

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments