Text Control Bar fails to set new default font family (rev >= 12131)

Bug #1227232 reported by BobSongs on 2013-09-18
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Tavmjong Bah

Bug Description

O/S: Windows XP Home, SP3
Inkscape version: 0.48+devel r12483

First issue: font weight drop-down list problematic:

- F8 and click tableau.
- Type "Test"
- Select "Bold" from Control Bar drop-down menu.

• Text correctly changes to Bold / "Bold" appears in Control Bar, as expected.

- Click elsewhere on tableau.

• Problem: Control Bar shows "Bold" as font weight instead of reverting to "Normal".

- Type "Test".

• Problem: text weight is Normal / Control bar indicates "Bold".

- Highlight text (this step makes no difference)
- Select "Bold" from drop-down menu.

• Problem: font weight remains Normal.

--------------

Second issue: Font selection from the Text Control Bar is also problematic.

- F8 - but do not click Tableau.
- From the Control Bar click Font drop-down list to select a different font from current.
- Click tableau.

• Problem: font name reverts to previous.

Issue occurs if tableau is clicked during the process:

- F1 to revert to selection tool.
- F8 to restore Text tool.
- Click tableau.
- Select different font from the drop-down list.

• Newly selected font name appears in Control Bar, cursor remains on tableau as expected.

- Type the letter "A".

• Letter does not appear on tableau but activates an Inkscape feature ("Spray", for example, if the letter A is typed).

Comments please.

Related branches

su_v (suv-lp) wrote :

In the future, please avoid filing multiple issues in one report, thx.
(It is cumbersome to triage and track progress on individual issues if they are included in a single report)

> First issue: font weight drop-down list problematic:

Duplicate of
- Bug #1188996 “real font-style does not correspond with selected style”
  <https://bugs.launchpad.net/inkscape/+bug/1188996>

> Second issue: Font selection from the Text Control Bar is also problematic.

Related earlier reports:
- Bug #687517 “Mouse focus is trapped in the 'Font size' GtkComboBoxEntry on the Text options toolbar”
  <https://bugs.launchpad.net/inkscape/+bug/687517>
- Bug #687521 “Mouse focus is trapped in GtkComboBox on tool controls bar for <Space> (switch tool)”
  <https://bugs.launchpad.net/inkscape/+bug/687521>
- and probably others …

Might already covered by Martin's more recent
- Bug #1222425 “Text Tool Focus UI Problems”
  <https://bugs.launchpad.net/inkscape/+bug/1222425>

BobSongs (bobspcrepair) wrote :

Excellent, good to see these were captured.

I did search for related bugs, but my attempts at guessing wordings for similar posts failed.

I added the two together because the text Control Bar issues are various.

It is understandable why such a bar would replace the 0.48 version to accommodate fonts that have more options than just bold/italic/bold-italic.

su_v (suv-lp) wrote :

Issue not covered in earlier reports:

> Second issue: Font selection from the Text Control Bar is also problematic.
>
> - F8 - but do not click Tableau.
> - From the Control Bar click Font drop-down list to select a different font from current.
> - Click tableau.
>
> • Problem: font name reverts to previous.

Reproduced with current trunk (r12729) on OS X 10.7.5: setting a new default font via text tool controls bar is no longer possible.
«Changes made when no text object is selected (…) change the default style. The default style can also be set with the Set as Default button in the Text and Font dialog. »
<http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Text-Formatting.html#Text-Formatting-CurrentStyle>

Based on tests with archived builds:
- not reproduced with rev <= 12130,
- reproduced with rev >= 12131,
this change appears to be a side-effect of
- Revision 12131: Move code from text-toolbar to font-lister in preparation to share code with font-selector/text-edit.
  <http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12131>

tags: added: fonts regression
summary: - Issues with Text Control Bar
+ trunk: Text Control Bar fails to set new default font family
Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.49
status: New → Confirmed
su_v (suv-lp) on 2014-03-26
summary: - trunk: Text Control Bar fails to set new default font family
+ trunk: Text Control Bar fails to set new default font family (rev >=
+ 12131)
su_v (suv-lp) on 2014-11-06
Changed in inkscape:
milestone: 0.91 → 0.92
su_v (suv-lp) on 2015-02-11
summary: - trunk: Text Control Bar fails to set new default font family (rev >=
- 12131)
+ Text Control Bar fails to set new default font family (rev >= 12131)
su_v (suv-lp) wrote :
Changed in inkscape:
assignee: nobody → tav (tav)
status: Confirmed → Fix Committed
assignee: tav (tav) → Tavmjong Bah (tavmjong-free)
su_v (suv-lp) wrote :

Backport of r14072 for lp:inkscape/0.91.x attached.

tags: added: backport-proposed
ScislaC (scislac) wrote :

patch from comment 6 applied to 0.91.x in r13765

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-15
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers