Manual text kerning not working since r12471

Bug #1215575 reported by Vladimir Savic on 2013-08-22
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

Kerning text using alt+arrow keyboard shortcuts or secondary toolbar spingboxes doesn't work in trunk anymore. Thanks to su_v's dissection abilities, it's been determined that changes introduced in revision 12471 have caused it. Furthermore, here are some additional snippets stripped from IRC conversation:

<su_v> vlada: and it also fails to properly render manually kerned text created with older revisions (at least in a quick test with r12470 / r12471)
<su_v> vlada: seems to affect PDF import too (at least when PDF contains text)

su_v (suv-lp) wrote :

Reproduced on OS X 10.7.5 (as discussed on irc)

tags: added: regression text
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.49
status: New → Confirmed
tags: added: blocker
su_v (suv-lp) wrote :

~suv wrote:
> Reproduced on OS X 10.7.5

Also reproduced on
- Ubuntu 12.04 (VM, 64bit) (trunk PPA r12481)
- Ubuntu 12.10 (VM, 64bit) (local build r12481)

Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) wrote :

AFAICT adjusted 'dx' and 'dy' values are correctly stored with the associated tspan, but not used when rendering the kerned text on-canvas.

su_v (suv-lp) wrote :

Related newer reports describing the issue with text from PDF files from a different perspective (underlying issue AFAICT same as what is reported here - absolute and relative kerning of text is currently broken):
- Bug #1217050 “unwanted clip-path + paragraphs upside down when importing a pdf”
- Bug #1217055 “kerning is lost when removing a clip-path”

Johan Engelen (johanengelen) wrote :

I undid the offending change from r12471. It tried to fix the less important bug 1208002. Fixing that one needs more thought.
committed in r12506

Changed in inkscape:
status: Triaged → Fix Released
assignee: nobody → Johan Engelen (johanengelen)
su_v (suv-lp) wrote :

Fix confirmed with r12506 on OS X 10.7.5 - many thx, Johan!

Related reports are also confirmed fixed - I will link them as duplicates to this one, since the underlying issue is the same.

tags: removed: blocker
Changed in inkscape:
milestone: 0.49 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers