INX <optiongroup> broken

Bug #1171434 reported by su_v on 2013-04-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
John Smith

Bug Description

Current trunk and 0.48.x branch r9948 no longer sets parameters based on <optiongroup> defined in the INX file.

This INX element is still used by a couple of extensions bundled with Inkscape, as well as by an unknown number of externally developed custom extensions.

Sample steps to reproduce:
1) launch trunk with default (new) prefs
2) open 'Extensions > Render > 3D Polyhedron'
3) switch to the second tab, define different rotation angles for X-, Y-, and Z-Axis
4) preview the result

Expected result:
The inserted cube is rotated around each axis as defined the in the dialog

Actual result:
The inserted cube is rotated several times around the default axis (X). It is not possible to rotate it around an explicitly chosen different axis (Y, or Z).
The parameters for the <optiongroup> are also no longer stored in the preferences file.

Not reproduced with Inkscape 0.48.4 and 0.48+devel <= r12265
Reproduced with Inkscape 0.48+devel r12268 and later revisions

Possibly introduced with r12267 "fix bug where extension radiobutton parameters cannot be set from cmdline"
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12267>

Tested on OS X 10.7.5 with
- GTK+/Quartz 2.24.17, gtkmm 2.24.2, glib 2.34.3, glibmm 2.32.1
- GTK+/X11 2.24.13, gtkmm 2.24.2, glib 2.32.4, glibmm 2.34.1

Note: does not affect lists of choices defined with <enum>

Related branches

Minimal test case

Confirmed on Debian testing, Inkscape trunk revision 12304.

Changed in inkscape:
importance: Undecided → High
status: New → Triaged
su_v (suv-lp) wrote :

Also affects PDF export (current 'page|drawing' area setting in the export dialog no longer takes effect).

Changed in inkscape:
milestone: none → 0.49
su_v (suv-lp) wrote :

Also affects bitmap import (current 'embed|link' option no longer takes effect).

@Johan - any chance you could revisit the changes in r12267?
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12267>

su_v (suv-lp) wrote :

AFAIU the changes in r12267 try to fix
- Bug #1102069 “pdf-export using the --export-area-drawing option”
  <https://bugs.launchpad.net/inkscape/+bug/1102069>
but at the same time break the optiongroup parameter used in the GUI (and for all use cases, not just PDF export).

John Smith (john-smithi) wrote :

Looks to be a bug in the ParamRadioButton/optiongroup mixing the label and value.
Tested with PDF export page/drawing UI option.

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
status: Triaged → In Progress
John Smith (john-smithi) wrote :

Attached v2 should correctly use the value instead of the label

su_v (suv-lp) wrote :

1171434.v2.patch does not work for me on OS X 10.7.5 (current parameter value not taken from extensions dialog), using
- Inkscape 0.48+devel r12315, glib 2.32.4, GTK+/X11 2.24.13
- Inkscape 0.48+devel r12315, glib 2.34.3, GTK+Quartz 2.24.17

Console output with minimal testcase (comment #1) and fresh preferences file when choosing any option of the first parameter (optiongroup with guitext ≠ value):

** (inkscape:21735): WARNING **: Couldn't set ParamRadioButton Option 1

** (inkscape:21735): WARNING **: Couldn't set ParamRadioButton Option 3

** (inkscape:21735): WARNING **: Couldn't set ParamRadioButton Option 2

John Smith (john-smithi) wrote :

Attached v3 should also fix issue with minimal test case (comment #1).

su_v (suv-lp) wrote :

Quick test of 1171434.v3.patch with r12319 looks ok on OS X 10.7.5 (I haven't yet checked for possible regressions wrt to bug #1102069).

This issue needs to be backported to the stable release branch because the change which introduced it was also committed to 0.48.x in revision 9948.

Changed in inkscape:
milestone: 0.49 → 0.48.5
su_v (suv-lp) wrote :

On 2013-05-05 08:55 +0100, John Smith wrote in <https://bugs.launchpad.net/bugs/1102069>:
> Committed as r12322.
> Tested with no regressions to bug #1102069.
>
> ** Changed in: inkscape
> Status: Triaged => Fix Committed
>
> ** Changed in: inkscape
> Assignee: (unassigned) => John Smith (john-smithi)

Changed in inkscape:
status: In Progress → Fix Committed
milestone: 0.48.5 → 0.49
tags: added: backport-proposed
summary: - trunk: INX <optiongroup> broken
+ INX <optiongroup> broken
su_v (suv-lp) on 2013-05-05
description: updated
John Smith (john-smithi) wrote :

Committed as r12322.
Tested with no regressions to bug #1102069.

su_v (suv-lp) wrote :

On 2013-05-02 19:31 +0100, ~suv wrote:
> This issue needs to be backported to the stable release branch because
> the change which introduced it was also committed to 0.48.x in revision
> 9948.

Proposing to instead revert revision 9948 of the stable release branch:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_48_BRANCH/revision/9948>

Reasons:
1) The committed change does break GUI options in extension dialogs as described in this report.
2) The committed change has no effect as claimed in the commit message on choosing the export area on the command line: the extension dialog for PDF/PS export in current stable do not use radiobuttons - it's still all booleans [*] (the fix for bug #499965 was not backported to the stable release branch) and works as expected.
3) Choosing (PDF) export area via command line is not broken with current stable release 0.48.4 (see bug #1102069 - the regression was introduced in trunk only).

@Johan - could you please revisit the changes you committed to the stable release branch in r9948, and consider reverting it? Else IMHO the risk is high that the next bug-fix release (0.48.5) will ship with yet another regression (this time one we even knew about before the release).

-----
[*] PDF export options in stable and trunk:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_48_BRANCH/view/9948/src/extension/internal/cairo-renderer-pdf-out.cpp#L232>
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/view/12322/src/extension/internal/cairo-renderer-pdf-out.cpp#L237>

jazzynico (jazzynico) wrote :

Setting milestone to 0.48.5 so that we don't forget to backport.

Changed in inkscape:
milestone: 0.49 → 0.48.5
status: Fix Committed → Triaged
su_v (suv-lp) wrote :

Fix for stable release branch <lp:inkscape/0.48.x> committed in r9953 (reverts r9948 [*]).

--
[*] Johan was consulted via PM.

Changed in inkscape:
status: Triaged → Fix Committed
Kris (kris-degussem) on 2013-12-11
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers