allow reordering and saving of filter order

Bug #1168814 reported by insaner on 2013-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Martin Owens

Bug Description

it is useful when working with a lot of filters to be able to reorder these and be able to keep this order across saves. i've already found out how to allow the reordering via drag and drop while working on another bug, but its the saving this state that needs to be done.

if someone wants to give a couple tips on how to accomplish this it would really speed things up for me to get this done.

insaner (insaner) on 2013-04-14
Changed in inkscape:
assignee: nobody → insaner (insaner)
jazzynico (jazzynico) on 2013-04-15
tags: added: filters-svg ui
Changed in inkscape:
importance: Undecided → Wishlist
jazzynico (jazzynico) wrote :

The filters list order depends on the filters order in the SVG file. Thus reordering the <filter> element in the <defs> should work.
Another possibility would be to add an inkscape:filter-order attribute in the filters definition. But I'm always a bit reluctant to add new inkscape specific attributes.

Changed in inkscape:
status: New → Triaged
insaner (insaner) wrote :

would this make for a good GSoC easy-fix?

jazzynico (jazzynico) wrote :

Not sure it is that easy. Of course it would be easier with your partial patch attached to the report.
But it still needs some understanding on how the elements are managed internally.

insaner (insaner) on 2013-04-21
Changed in inkscape:
assignee: insaner (insaner) → nobody
insaner (insaner) wrote :

heres part one.. the easy part. this should set the rows reorderable, such that now you can drag and drop them into the right place..

what is needed is to make this sync with inkscape's internal representation of the data.. of which i know close to nothing about.

Martin Owens (doctormo) wrote :

See r12394 for a nice fix, it took a while to get the right solution and I learned a bit more about the codebase. But you can see from the diff, it's quite a small fix over all.

Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: Triaged → Fix Committed
insaner (insaner) wrote :

wow awesome.. thats great! yeah theres no way that i couldve come up with that solution with my current working knowledge of gtk, etc.. this will definitely move me way forward in that direction and in solving future bugs i might run into (maybe even a couple that are currently open)

oh, by the way, i found that reordering is not marking the document as "dirty", (ie, puts a little asterisk next to the name calling out "save me!") so to save any reordering, something else in the document must be modified.

thanks martin!

jazzynico (jazzynico) on 2013-06-28
Changed in inkscape:
milestone: none → 0.49
su_v (suv-lp) wrote :

Follow-up report:
- Bug #1220143 “trunk: crash in Inkscape::UI::Dialog::FilterEffectsDialog::FilterModifier::on_filter_reorder ()”
  <https://bugs.launchpad.net/inkscape/+bug/1220143>

su_v (suv-lp) wrote :

Follow-up report:
- Bug #1239296 “trunk: interference of XML and Filter Effects Editor (hang on dialog open and app quit) (rev >= 12394)”
  <https://bugs.launchpad.net/inkscape/+bug/1239296>

su_v (suv-lp) wrote :

JFYI - the changes from r12394 have been partially disabled in r13055 due to regressions reported in bug #1239296.

Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers