GTK3: current color swatches (status bar, tool controls bar) do not display flat colors

Bug #1016900 reported by su_v on 2012-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alex Valavanis

Bug Description

The color swatches in the status bar (current selection) and on the tool controls bar (last used style or the tool's own style) fail to display flat colors (gradients and text messages like 'Pattern', 'None' and 'Unset' are displayed just fine).

Works as expected in GTK2 builds.

Tested with Inkscape 0.48+devel r11512 on OS X 10.7.4
glib 2.32.3, gtk3/x11 3.4.3, gtkmm 3.4

su_v (suv-lp) on 2012-06-23
summary: GTK3: current color swatches (status bar, tool controls bar) do not
- diaply color
+ display flat colors
Changed in inkscape:
status: New → Triaged
importance: Undecided → Medium
su_v (suv-lp) wrote :

Also affects
- Document Properties > Page | Guides | Grids
- Preferences > Tools (tool's own style)
- Preferences > Interface > Grids

tags: added: gtk3
removed: gtk3-regression
Alex Valavanis (valavanisalex) wrote :

Should be fixed in lp:inkscape r11994

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
milestone: none → 0.49
status: Triaged → Fix Committed
su_v (suv-lp) wrote :

> Also affects
> - Document Properties > Page | Guides | Grids
> - Preferences > Tools (tool's own style)
> - Preferences > Interface > Grids

AFAICT not fixed yet (r11997) - do you want this to be tracked in a separate report?

Alex Valavanis (valavanisalex) wrote :

Re comment #2...

Oops... missed that detail! Yes, probably best to track them separately. The drawing issues may be caused by distinct things!

Changed in inkscape:
status: Fix Committed → Fix Released
milestone: 0.49 → none
su_v (suv-lp) wrote :

Follow-up report filed as:
Bug #1094504 “GTK3: RegisteredColorPicker (e.g. for grid, guides color) does not show preview of current color”
<https://bugs.launchpad.net/inkscape/+bug/1094504>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers