GTK3: RegisteredColorPicker (e.g. for grid, guides color) does not show preview of current color

Bug #1094504 reported by su_v on 2012-12-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jabiertxof

Bug Description

Follow-up report to bug #1016900:

The custom widget 'RegisteredColorPicker' used as button to open a color selector dialog (to set the color for various items e.g. in Document Properties and Preferences) doesn't render a preview of the current color (solid color swatch as used in the status bar style indicator).

Affects:
- Document Properties > Page | Guides | Grids
- Preferences > Tools (tool's own style)
- Preferences > Interface > Grids
and possibly other places I might have missed.

Reproduced with Inkscape 0.48+devel r11997 on OS X 10.7.4, using
- GTK+/X11 3.4.4, gtkmm 3.4.0, glib 2.32.4
- GTK+/Quartz 3.6.2, gtkmm 3.6.0, glib 2.24.3

su_v (suv-lp) on 2012-12-29
summary: - GTK3: RegisteredColorPicker (e.g. grid, guides color) does not show
+ GTK3: RegisteredColorPicker (e.g. for grid, guides color) does not show
preview of current color
Changed in inkscape:
status: New → Triaged
importance: Undecided → Medium
tags: added: color ui
Alex Valavanis (valavanisalex) wrote :

Should be fixed in lp:inkscape r12185. Seemed to be an issue with vertical fill property of the colour swatch widget not being set

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
status: Triaged → Fix Released
su_v (suv-lp) wrote :

> status: Triaged → Fix Released

Cannot confirm this being fixed on OS X:
Buttons which preview a color setting (RGB, Alpha) are still rendered empty without preview (compared with GTK2 builds, same revision), e.g. document background color, grid and guides color in document properties, colors for default grid in preferences.

Tested with r12185 on OS X 10.7.4, using
- GTK+/X11 3.4.4, gtkmm 3.4.0, glib 2.32.4
- GTK+/Quartz 3.6.4, gtkmm 3.6.0, glib 2.24.3

GTK+ themes tested: Adwaita, Ubuntu Ambiance (Unico engine)

Changed in inkscape:
status: Fix Released → Incomplete
su_v (suv-lp) wrote :

> status: Fix Released → Incomplete

Needs verification whether this only affects OS X builds now (>= r12185).

jazzynico (jazzynico) wrote :

> Needs verification whether this only affects OS X builds now (>= r12185).

Also affects Debian testing, with revision 12189.

Changed in inkscape:
status: Incomplete → Triaged
Changed in inkscape:
assignee: Alex Valavanis (valavanisalex) → nobody
Jabiertxof (jabiertxof) on 2017-09-23
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
Jabiertxof (jabiertxof) wrote :

Fix on r.944a8da0e8. I put as fix released because I forget there is no release for GTK3 0.92.2, please update if is wrong.

Changed in inkscape:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers