indicator-sound play controls not exposed in HUD

Bug #949032 reported by Jo-Erlend Schinstad on 2012-03-07
100
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Won't Fix
Low
Unassigned
The Sound Menu
Won't Fix
Low
Unassigned
indicator-sound (Ubuntu)
Low
Unassigned

Bug Description

The graphical Previous/Play/Next buttons in the indicator-sound menu are not appearing in the HUD.

This appears to be because they use a special widget.

I expected to be able to type something like "play" in HUD and get an option like "Sound > Play", since there's control for that in the sound menu, but that's not possible.

The menu item to launch Rhythmbox itself shows up, but not the equivalents of the graphical indicator controls.

Paul Sladen (sladen) on 2012-03-07
description: updated
description: updated
tags: added: hud indicators
Changed in indicator-sound:
status: New → Triaged
Changed in indicator-sound (Ubuntu):
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in indicator-sound:
importance: Undecided → High
Changed in indicator-sound (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Olli Ries (ories) on 2012-03-12
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2012-03-13
Changed in indicator-sound:
milestone: none → 0.8.4.0
Conor Curran (cjcurran) wrote :

Will simply set the MPRIS name of player in the standard dbusmenuitem label prop on the transport item.

Transport item is of type : "x-canonical-sound-menu-player-transport-type"

And the MPRIS identity property of the default player for precise is ""Rhythmbox'

Changed in indicator-sound:
status: Triaged → Fix Committed
Changed in indicator-sound (Ubuntu):
status: Triaged → In Progress
Conor Curran (cjcurran) on 2012-03-16
Changed in indicator-sound:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.4.0-0ubuntu1

---------------
indicator-sound (0.8.4.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - indicator-sound "Choose Playlist" menu item does nothing when using
      Rhythmbox (LP: #952550)
    - crashed with SIGSEGV in g_strdup() (LP: #946607)
    - crashed with SIGABRT in pa_operation_unref() (LP: #944148)
    - crashed with signal 5 in g_type_create_instance() (LP: #921755)
    - slider on unmute resets volume (LP: #921065)
    - play controls not exposed in HUD (LP: #949032)
    - unity-panel-service at 100% cpu when opened /w rb without album
      cover (LP: #806848)
 -- Ken VanDine <email address hidden> Fri, 16 Mar 2012 14:04:30 -0400

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Omer Akram (om26er) on 2012-03-17
no longer affects: unity (Ubuntu)
Changed in unity:
milestone: none → 5.8.0
status: Triaged → Fix Released
milestone: 5.8.0 → none
Achim (ach1m) wrote :

I can't find this functionality in the HUD is this bug really fixed?
Also someone else opened Bug #962686 after this fix was already released.

Sebastián Mancilla (smancill) wrote :

Using indicator-sound 0.8.5.0-0ubuntu2, and the bug is still there. The audio controls do not appear in the HUD.

Omer Akram (om26er) wrote :

Yes, the issue was never fixed.

Changed in indicator-sound (Ubuntu):
status: Fix Released → Confirmed
Changed in indicator-sound:
status: Fix Released → Confirmed
Changed in unity:
status: Fix Released → Confirmed
Lars Karlitski (larsu) wrote :

This will take more effort on both the sound menu and indicator-appmenu, too much for this late in the cycle. Marking as low priority for now.

Changed in indicator-sound:
importance: High → Low
Changed in indicator-sound (Ubuntu):
importance: High → Low
Changed in indicator-appmenu:
status: New → Confirmed
importance: Undecided → Low
no longer affects: unity
David Barnett (mu-mind) wrote :

Related: https://bugs.launchpad.net/bugs/1027547 (Support multimedia keys in Sound Menu)

David Barnett (mu-mind) wrote :

Lars, can you elaborate on what needs to be done in indicator-appmenu? And could somebody remove the 0.8.4 milestone since that didn't happen?

I started looking into getting this fixed, but since I'm not a Ubuntu developer and have no idea what I'm doing, really, I'm not expecting to get very far.

What I've discovered so far is there seems to be a one-to-one correspondence between HUD entries and normal menu items in indicator-sound. As a first pass, I was going to try adding an invisible "Play"/"Pause" item under "Mute", but investigating that idea I found that just turning the visible property off on the "Mute" button removes it from the HUD menu. Is it possible to add HUD items that don't show up in the UI?

Thinking about this more, it should really support multiple play/pause items. Example scenario: I'm listening to music in Rhythmbox and I open my browser, which restores a YouTube tab with webapp integration enabled. So I have both Rhythmbox and YouTube in the "Play" state, and I should have two "Pause" options in the HUD: "Sound > Rhythmbox > Pause" and "Sound > YouTube > Pause".

Lars Karlitski (larsu) wrote :

Hi David, thanks for looking into it.

It is not currently possible to add HUD items that are not visible in the menu (but there are some considerations to add that in the future).

In the mean time, the HUD could be patched to gain knowledge of the special type of menu item the sound menu is using for its player controls. Whenever it sees that kind of menu item, it would add the three entries "Previous", "Play", and "Next" to the HUD. However, these strings need to come from the sound menu itself to allow for translations. Also, it doesn't solve the problem of multiple players that you described: the name of the player has to be communicated as well.

Changed in indicator-sound:
milestone: 0.8.4 → none
Changed in indicator-sound:
assignee: Conor Curran (cjcurran) → nobody
Changed in indicator-sound (Ubuntu):
status: Confirmed → Triaged
Lars Karlitski (larsu) wrote :

The HUD doesn't show indicators currenty. It's unclear whether it will start doing that again in the future.

Changed in indicator-appmenu:
status: Confirmed → Won't Fix
Changed in indicator-sound:
status: Confirmed → Won't Fix
Changed in indicator-sound (Ubuntu):
status: Triaged → Won't Fix
Ingo Gerth (igerth) wrote :

Why this regression? Where does it come from?

I frequently used the HUD to perform such tasks as logging out. Disappointing.

Right. Why was indicators removed from the HUD? That was somewhat useful to me. But if it's unclear whether indicators will come back into the HUD, why mark this bug as "won't fix"?

Lars Karlitski (larsu) wrote :

I think the regression was caused when getting the HUD ready for the phone.

I marked it as "Won't Fix" for indicator-sound because it would need to be fixed in the HUD. There's already bug #1165420 which tracks the bug for hud.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers