The icon does not change based on the actual charge level

Bug #1215520 reported by Pat McGowan on 2013-08-22
84
This bug affects 15 people
Affects Status Importance Assigned to Milestone
indicator-power
Fix Released
Medium
Charles Kerr
indicator-power (Ubuntu)
Medium
Charles Kerr

Bug Description

indicator-power 12.10.6daily13.03.07-0ubuntu1, Ubuntu 13.04
indicator-power 12.10.6+13.10.20130821-0ubuntu1, Ubuntu S

The icon is always the same indicating something like 10% charge even when 90% charged. <https://launchpadlibrarian.net/148600965/bug-1215520-charge.png>

<https://wiki.ubuntu.com/Power#Icons>: "And if it is charging, the icon interior should feature a lightning bolt emblem. Depending on clarity and space available, the icon interior may also be filled from left to right approximately as much as the amount charged."

Related branches

Pat McGowan (pat-mcgowan) wrote :
Pat McGowan (pat-mcgowan) wrote :

I am told this is as designed, but not clear why we would not expose information that is readily available

I also prefer a visual indication of the charge % on the menu, exact percentage is not interesting, relative percentage is that I can understand at a glance.

Matthew Paul Thomas (mpt) wrote :

Whoever told you it was by design was mistaken.

no longer affects: ubuntu-ux
description: updated
Changed in indicator-power (Ubuntu):
status: New → Triaged
Changed in indicator-power (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Adolfo Jayme (fitojb) on 2013-08-29
Changed in indicator-power (Ubuntu):
importance: Undecided → Medium
Charles Kerr (charlesk) on 2013-08-30
Changed in indicator-power:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) wrote :

This behavior was introduced in http://bazaar.launchpad.net/~jjardon/indicator-power/master/revision/108 because it was difficult to distinguish the battery fill level from the ⚡ symbol in the icon. See bug #824629 for background.

Let's drop the #824629 code and just use the battery-XXX-charging icons.

Michał Sawicz (saviq) wrote :

This affects touch as well, battery icon is red even at 90% charge - usability bad.

Michał Sawicz (saviq) wrote :
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-power at revision 203, scheduled for release in indicator-power, milestone Unknown

Changed in indicator-power:
status: In Progress → Fix Committed
tags: added: qa-manual-testing qa-touch rls-s-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+13.10.20131004-0ubuntu1

---------------
indicator-power (12.10.6+13.10.20131004-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * Revert bug #824629 code -- use the correct charge % when deciding
    what icon to use. (LP: #1215520, #824629)
  * Listen for the "Resuming" signal from upower to refresh devices when
    resuming from suspend/hibernate. (LP: #1224931)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 204
 -- Ubuntu daily release <email address hidden> Fri, 04 Oct 2013 02:28:43 +0000

Changed in indicator-power (Ubuntu):
status: Triaged → Fix Released
Charles Kerr (charlesk) on 2013-10-09
Changed in indicator-power:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers