Comment 45 for bug 627195

JaSauders (jasauders) wrote :

Running 14.04.2 here with some of the same issues. I was seeing it with ownCloud client, network manager, and a weather applet known as my-weather-indicator. The issue came up at random, but it was easy to replicate within a matter of 15-20 seconds while continuously navigating around open windows followed by opening applications with system tray icons.

I brought up conversation with some other users who gave me a suggestion that has, so far, worked. Figured I'd post it here in case it can benefit anybody else until the bug can be properly fixed. I ran this in terminal, followed by a log out/log in.

dconf write /org/compiz/profiles/unity/plugins/core/focus-prevention-level 0

This is a similar idea that Rael posted in response 43 above. I seem to recall Ubuntu switching to dconf over gconf at some point. I tested it in my 14.04.2 virtual machine (brand new, but fully updated install) however the gconf key didn't appear to fix the issue, as I was still able to replicate it. In the same VM, that dconf write command above seemed to fix the issue, as I have been unable to replicate it in my VM, nor my main laptop.

The default focus-prevention-level is 1, which is considered "low", but appears to be the cause of this random behavior. Setting it to 0 seems to make it consistent. I haven't ran with this change for days/weeks/months, but in my tinkering so far today, the issue hasn't resurfaced a single time.